Download it now!
Bug 112322 - Menu text disappears under mouse cursor (kde4 VCL plugin)
Summary: Menu text disappears under mouse cursor (kde4 VCL plugin)
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: kde4
Keywords:
Depends on:
Blocks: Main-Menu KDE
  Show dependency treegraph
 
Reported: 2017-09-11 06:52 UTC by Eric
Modified: 2018-12-21 18:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen Capture showing issue (65.09 KB, image/png)
2017-09-11 06:52 UTC, Eric
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2017-09-11 06:52:28 UTC
Created attachment 136162 [details]
Screen Capture showing issue

Current info from Calc's Help/About: 
Version: 5.3.3.2
Build ID: 30m0(Build:2)
CPU Threads: 12; OS Version: Linux 4.4; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

OS:
  X86_64 OpenSuse 42.2 and also 42.3 
  KDE 5.32.0   Plasma 5.8.7  Qt version 5.6.2

When i select a Menu and move the mouse cursor over a menu item the text of that item disappears, this happens in both Calc and Writer (havent tried the others)
Clicking the now blank item still works as epxected
Moving the mouse off the menu item causes the text to reappear.
No other apps such as firefox, kate, konsole etc have this issue, only libreoffice
I also did a an upgrade yesterday from OpenSuse Leap 42.2 to 42.3 the issue hasn't changed

In the attachment note that:
The mouse is actually hovered over the 'Spelling F7' menu item  but it doesn't show in this screen capture.
Notice the missing 'Tools' and 'Spelling F7' menu item text
Comment 1 Xisco Faulí 2017-09-12 23:34:12 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Eric 2017-09-13 05:22:34 UTC
Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 12; OS: Linux 4.4; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: CL

This has the same issue
Comment 3 Eric 2017-09-16 03:53:36 UTC
Tested in latest release - shows same issue
Comment 4 Aron Budea 2017-09-17 04:58:32 UTC
Could you try running LibreOffice like this, and report if that changes anything?
SAL_USE_VCLPLUGIN=gtk soffice
SAL_USE_VCLPLUGIN=gtk3 soffice

This is just to see if the issue is with the kde4 VCL plugin.
Comment 5 Eric 2017-09-17 05:11:03 UTC
Neither var helps my original (5.3) Libre Office but 
in the latest (5.4)version 
   SAL_USE_VCLPLUGIN=gtk soffice
fixes the menu issue
while
   SAL_USE_VCLPLUGIN=gtk3 soffice
has no effect (the menu item still disappears)
Comment 6 Xisco Faulí 2017-09-17 09:43:24 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2017-09-17 09:45:22 UTC
What about SAL_USE_VCLPLUGIN=gen soffice ?
Comment 8 Eric 2017-09-17 14:24:30 UTC
SAL_USE_VCLPLUGIN=gen soffice
works on both versions

Note that i have both versions installed, I run
SAL_USE_VCLPLUGIN=gen soffice
in my home directory and i run
SAL_USE_VCLPLUGIN=gen ./soffice in the newer versions program directory
Not sure if that matters but i thought i should mention it
Comment 9 Eric 2017-09-17 14:36:37 UTC
Also, i noticed that the look has changed now, the text on the menu bar is smaller The view in conditional format (as an example) looks different, the drop down boxes look smaller and have a different style. The data on the sheet looks the same tho. Did running the new version change a style setting in the old version perhaps?
Comment 10 Xisco Faulí 2017-09-21 10:23:49 UTC
Might it be related to the theme you use? Which one is it ? What happens if you change it?
Comment 11 Eric 2017-09-24 12:42:16 UTC
yeh, turned out the theme and toolbar icon size got reset when i ran the newest version. I changed it back and its fine now.
So... the menu text disappearing is resolved if i use SAL_USE_VCLPLUGIN=gen
but what exactly is that and why is it necessary? Is it just a temporary workaround?
Comment 12 Eric 2017-09-24 13:19:37 UTC
After a bit of debug i see that the reason the view is so different is the use of
 SAL_USE_VCLPLUGIN=gen
The input line text box is too small now and so is the menu text (too small for comfortable use anyways) and I dont see any way to set those sizes. 
  If i start office without that env var the look and feel returns to normal but the menu text under the mouse disappears again.
So, in my view the  SAL_USE_VCLPLUGIN=gen is not a viable fix although it may help determine whats going on with the menus and text under the mouse.
Comment 13 Aron Budea 2017-09-24 16:49:59 UTC
(In reply to Eric from comment #11)
> So... the menu text disappearing is resolved if i use SAL_USE_VCLPLUGIN=gen
> but what exactly is that and why is it necessary? Is it just a temporary
> workaround?
It's just a hint for the devs where to look for the issue (a rather important detail, actually, since different pieces of code are involved).
Comment 14 Caolán McNamara 2017-09-25 09:47:54 UTC
If the menu text is disappearing under SAL_USE_VCLPLUGIN=gtk3 that is a very surprising finding as the menus are native there. I rather suspect that the gtk3 vclplug wasn't available or something like that and so a different one was used
Comment 15 Eric 2017-09-25 12:13:32 UTC
If you now the filename of the gtk3 plugin I can check if it is on my system and where. Perhaps from that we can determine why the SAL_USE_VCLPLUGIN=gtk3 has no effect.
Comment 16 Jan-Marek Glogowski 2017-09-28 17:48:45 UTC
You don't need the filename. The info is in Help/About as "VCL: ???".

Since there are automatic fallbacks, if a VCL plugin isn't installed, just always check Help/About.

And please move / delete your "~/.config/libreoffice/4" profile. If this helps, we're probably missing some migration code for old profiles / menu renames / UNO name changes.
Comment 17 Eric 2017-09-29 14:35:09 UTC
(In my Help About it says this:
Version: 5.3.5.2
Build ID: 30m0(Build:2)
CPU Threads: 12; OS Version: Linux 4.13; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: CL

Deleteting my libreoffice profile didnt help
Comment 18 Caolán McNamara 2017-10-17 08:49:03 UTC
some theme issue, no evidence that gtk3 is actually involved, so removing that tag
Comment 19 Xisco Faulí 2017-10-18 10:45:23 UTC
I'm wondering if the situation has improved after 01f674a95ddec76dc4c8ecfccdca1773657e47cb.


Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 20 Xisco Faulí 2017-10-18 11:33:57 UTC
Sorry, wrong comment
Comment 21 Eric 2017-11-16 09:33:44 UTC
Its been two months - any movement on this?
Comment 22 Xisco Faulí 2017-11-16 09:38:31 UTC
(In reply to Eric from comment #21)
> Its been two months - any movement on this?

Any chance you test it in a daily build from http://dev-builds.libreoffice.org/daily/master/ ?
Comment 23 Eric 2017-11-17 06:47:15 UTC
I went and looked at the site you referenced but how do i make use of it? e.g what do i download and how to install it. will it over-write my existing install of LO?
Comment 24 Aron Budea 2017-11-17 15:39:37 UTC
(In reply to Eric from comment #23)
> I went and looked at the site you referenced but how do i make use of it?
> e.g what do i download and how to install it. will it over-write my existing
> install of LO?
Since you have OpenSUSE, you want to install this:
http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/current/

The steps are descibed here:
https://wiki.documentfoundation.org/Installing_in_parallel/Linux

No, it won't overwrite your existing install.
Comment 25 Aron Budea 2017-11-17 15:41:21 UTC
(In reply to Aron Budea from comment #24)
> Since you have OpenSUSE, you want to install this:
> http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/
> current/
I meant, the rpm from this location. Refer to the installation steps for the details on "installing", it's more like, unpacking the package contents in a directory of your choice.
Comment 26 Eric 2017-11-17 18:36:22 UTC
I installed: master~2017-11-17_00.29.00_LibreOfficeDev_6.0.0.0.alpha1_Linux_x86-64_deb.tar.gz

Version: 6.0.0.0.alpha1+
Build ID: 0f73433b13ba9e3f38193ddd86f4b9b767a36bb2
CPU threads: 12; OS: Linux 4.13; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-11-17_00:29:00
Locale: en-US (en_US.UTF-8); Calc: CL

The menu problem still exists.
Comment 27 Aron Budea 2018-01-08 18:38:52 UTC
Someone in #libreoffice was having the issue with missing main menu (the whole thing, not just the item under the cursor, similar to bug 107764), and they reported typing the following in terminal before starting up LO was a workaround. Can you give it a try if it helps here?

"unset DBUS_SESSION_BUS_ADDRESS"
Comment 28 Eric 2018-01-08 20:22:59 UTC
I tried unsetting the var and running soffice from the konsole window (where I unset that var) and the menu items still go blank. 
Just as an FYI my settings were like this before i unset DBUS_SESSION_BUS_ADDRESS
# env|grep DB
XKEYSYMDB=/usr/X11R6/lib/X11/XKeysymDB
KONSOLE_DBUS_SERVICE=:1.69506
KONSOLE_DBUS_WINDOW=/Windows/1
KONSOLE_DBUS_SESSION=/Sessions/1
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-WIhdbXGkvd,guid=432f84671fb8da605b364bb95a410592
Comment 29 ed38 2018-01-27 11:54:48 UTC
Hi all,

You can try this :

Go to 
System Settings
Application Style
Widget Style
Breeze -> Configure
Frame tab
--> Uncheck Draw a thin line to indicate focus...
--> Apply

Restart Libreoffice

It worked for me.

Regards,
Ed
Comment 30 Eric 2018-01-27 22:55:44 UTC
Wow! that fixed it!
Thanks so much!
Comment 31 jn 2018-12-21 17:46:35 UTC
I have the same problem, om Mint 19.1 x64 Cinnamon, LibreOffice 6.1.4.2. Changing various types of system theme does not seem to help. The problem occurs on e.g. the spell checker window (the one generated by pressing F7). And I can't find those menu options used to implement the work around.
Comment 32 jn 2018-12-21 17:56:50 UTC
Problem seems fixed in LibreOffice 6.*2* (the daily/testing version).
Comment 33 Xisco Faulí 2018-12-21 18:01:48 UTC
(In reply to jn from comment #32)
> Problem seems fixed in LibreOffice 6.*2* (the daily/testing version).

is it KDE4 or KDE5 ? you can check it in Help - About LibreOffice...
Comment 34 Xisco Faulí 2018-12-21 18:12:17 UTC
Anyway, KDE4 support was removed in master in the following commit:

author	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-09-05 02:53:07 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-12-17 18:33:13 +0100
commit	410bf59de02192c2daf1158b9de76ec0ebab4c56 (patch)
tree	be010e92b862f169076de979796075c925c3e576
parent	6a53832080cf201e960113de8e1887d99e857606 (diff)
kde5: remove older kde/tde plugins, and references to that
KDE4 is out of maintenance upstream since Nov. 2014, and binaries
provided by TDF have switched to KDE5 as the official backend.

Closing as RESOLVED WONTFIX