Bug 112549 - Full screen mode should hide title bar and Gnome Shell top bar
Summary: Full screen mode should hide title bar and Gnome Shell top bar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.0.0 target:5.4.4
Keywords: needsDevEval
: 113175 113890 (view as bug list)
Depends on:
Blocks: Full-Screen-Mode GTK3
  Show dependency treegraph
 
Reported: 2017-09-21 11:04 UTC by Alex
Modified: 2017-12-07 20:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
LO full screen (15.97 KB, image/png)
2017-09-21 11:04 UTC, Alex
Details
LO full screen + GNOME full screen (8.80 KB, image/png)
2017-09-21 11:05 UTC, Alex
Details
Fullscreen mode on Windows (80.72 KB, image/png)
2017-10-30 08:30 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2017-09-21 11:04:40 UTC
Created attachment 136428 [details]
LO full screen

Currently when switching to full-screen both LibreOffice title bar and taskbar (windows)/gnome top bar (linux) are visible.
In my opinion both are not needed. Best full-screen mode offers Blender where both app title-bar and taskbar/topbar are hidden like this:
https://upload.wikimedia.org/wikipedia/commons/thumb/6/6a/Blender269DefaultView.png/800px-Blender269DefaultView.png

GNOME Shell offers full-screen switch for every app so it's possible to do under Linux switching first LibreOffice to full-screen then using GNOME function. Unfortunately it's not possible under Windows.
Comment 1 Alex 2017-09-21 11:05:12 UTC
Created attachment 136429 [details]
LO full screen + GNOME full screen
Comment 2 Heiko Tietze 2017-10-29 08:28:31 UTC
Works as expected with LXQt on X/Kwin at Arch Linux; FullHD display (tested with fresh and master). 

If there is an issue with Gnome Shell it's up to devs to decide if it can be solved.
Comment 3 Yousuf Philips (jay) 2017-10-29 13:57:28 UTC
This is a Gnome Shell only issue as it doesnt affect windows.
Comment 4 Yousuf Philips (jay) 2017-10-29 14:45:17 UTC
So this issue doesnt happen in Ubuntu Gnome 17.04 with LO 5.3.1 and Gnome 3.24.0, but does with Ubuntu 17.10 with LO 5.4.1 and Gnome 3.26.1. In Ubuntu 17.10, the menu bar is also visible in full screen mode.
Comment 5 Alex 2017-10-30 07:23:04 UTC
It doesn't hide Windows task bar too.
Comment 6 Heiko Tietze 2017-10-30 07:57:47 UTC
(In reply to Alex from comment #5)
> It doesn't hide Windows task bar too.

It does.

Version: 6.0.0.0.alpha0+
Build ID: b087e451527f2e497ccab83b63b4f10099bfb8b8
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-03_23:43:39
Locale: de-DE (de_DE); Calc: group
Comment 7 Alex 2017-10-30 08:30:28 UTC
Created attachment 137365 [details]
Fullscreen mode on Windows

Take a look, Windows 10 screen.
Comment 8 Yousuf Philips (jay) 2017-10-30 10:45:02 UTC
(In reply to Alex from comment #7)
> Take a look, Windows 10 screen.

Then likely a Windows 10 only issue, as it doesnt happen in Windows 8.1 with me.
Comment 9 Alex 2017-10-30 11:53:06 UTC
Blender/Krita/FreeCAD fullscreen work fine under W10.
Comment 10 Buovjaga 2017-11-09 15:32:10 UTC
*** Bug 113175 has been marked as a duplicate of this bug. ***
Comment 11 Caolán McNamara 2017-11-10 13:54:48 UTC
Re comment #4 the menubar in gtk3 I can do something about. The other problem I can't reproduce under gnome-shell 3.24 so either something has changed with gnome-shell 3.26 or the build being used was against an older gtk3 without the required full screen api calls.

The original report of comment #1 doesn't state what toolkit is in use. What does help about say for VCL:, gtk or gtk3 ?
Comment 12 Commit Notification 2017-11-10 20:24:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97d09553425b59d030fd4d8f039a4a9994b674cf

Related: tdf#112549 gtk3 hide/show menubar on enter/exit fullscreen

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Buovjaga 2017-11-10 21:03:33 UTC
(In reply to Alex from comment #7)
> Created attachment 137365 [details]
> Fullscreen mode on Windows
> 
> Take a look, Windows 10 screen.

This is bug 103203
Comment 14 Yousuf Philips (jay) 2017-11-10 21:46:46 UTC
(In reply to Caolán McNamara from comment #11)
> Re comment #4 the menubar in gtk3 I can do something about. The other
> problem I can't reproduce under gnome-shell 3.24 so either something has
> changed with gnome-shell 3.26 or the build being used was against an older
> gtk3 without the required full screen api calls.

According to ubuntu's package info[1], the libreoffice-gtk3 requires libgtk-3-0 (>= 3.19.12), the same as the version in 17.04.

Is there a means to know which version of gtk3 LO was build against?

[1] https://packages.ubuntu.com/artful/libreoffice-gtk3
Comment 15 Caolán McNamara 2017-11-16 10:56:46 UTC
Upgraded to Fedora 27 with gnome-shell 3.26 and (with above menubar fix in place) I get correct full-screen behaviour.

caolan->philipz85: You are getting the problem under Ubuntu 17.10 with the stock distro LibreOffice, right ?
Comment 16 Yousuf Philips (jay) 2017-11-16 21:42:17 UTC
(In reply to Caolán McNamara from comment #15)
> caolan->philipz85: You are getting the problem under Ubuntu 17.10 with the
> stock distro LibreOffice, right ?

With 17.10 only the menubar is showing, which your patch will likely fix if its backported to 5.4. Also the full screen toolbar which is supposed to be floating is docked and if i try to drag it as floating it wont move.
Comment 17 Caolán McNamara 2017-11-17 09:38:01 UTC
The floating thing is a different known issue with dockable windows and wayland and gtk3 so put that aside.

The menubar is fixed (https://gerrit.libreoffice.org/#/c/44809/ is the 5-4 backport)

I think the gtk3 problem is fixed with my menubar fix and the original problem in comment #1 is actually the gtk2 backend rather than the gtk3 one
Comment 18 Caolán McNamara 2017-11-17 10:04:25 UTC
I can reproduce the problem of comment 1 with the gtk2 backend under gnome-shell.

I already have a hack in place for gtk2 to launch a helper which uses gtk3, if installed on the host, to set a window to go full-screen and span all monitors. If I extend this for the current-monitor full-screen case then that works.
Comment 19 Commit Notification 2017-11-17 17:06:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=33b194c2b8eb51facc452f5f7e2b4cef7ee34339&h=libreoffice-5-4

Related: tdf#112549 gtk3 hide/show menubar on enter/exit fullscreen

It will be available in 5.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2017-11-17 20:55:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=946ff7a6768f8207a7d26dfec0f090c08aeabbb9

Resolves: tdf#112549 use gtk3 to set gtk2 window fullscreen...

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Caolán McNamara 2017-11-20 12:52:39 UTC
backport of the other piece to 5-4 for gtk2 in gerrit
Comment 22 Commit Notification 2017-12-01 01:14:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=abcfe9bef8f2d545106ce495cd0f7ca419de8e8e&h=libreoffice-5-4

Resolves: tdf#112549 use gtk3 to set gtk2 window fullscreen...

It will be available in 5.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Yousuf Philips (jay) 2017-12-02 11:54:09 UTC
(In reply to Caolán McNamara from comment #21)
> backport of the other piece to 5-4 for gtk2 in gerrit

Assume this fix resolve bug 113890.
Comment 24 Caolán McNamara 2017-12-07 20:17:24 UTC
yes, that's right, little helper program for the gtk2 inside gnome case
Comment 25 Caolán McNamara 2017-12-07 20:17:49 UTC
*** Bug 113890 has been marked as a duplicate of this bug. ***