Bug 112886 - FILESAVE DOCX: Each save adds a tab space to footnotes
Summary: FILESAVE DOCX: Each save adds a tab space to footnotes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
: 51811 113553 114389 (view as bug list)
Depends on:
Blocks: DOCX-Footnote-Endnote
  Show dependency treegraph
 
Reported: 2017-10-04 21:58 UTC by Aibara
Modified: 2019-03-20 18:00 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A docx saved once: note the tab space in the footnote (6.27 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-10-04 21:59 UTC, Aibara
Details
The file saved twice: now there are two tab spaces (6.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-10-04 21:59 UTC, Aibara
Details
A third save means a third tab space added. (6.30 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-10-04 22:00 UTC, Aibara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aibara 2017-10-04 21:58:31 UTC
Description:
Each time a docx file with footnotes is saved a tab space is added to the beginning of the footnote, just after the number.

Steps to Reproduce:
1. Create a file with a footnote or open an already extant .docx with a footnote.
2. Save it as a .docx.

Actual Results:  
A tab space is added to the beginning of the footnote.

Expected Results:
No tab should be added since the user did not actually add one.


Reproducible: Always

User Profile Reset: Yes

Additional Info:
This is really nasty when editing .docx files, especially when someone asks you to read over their work and you end up destroying their formatting. The space is added to every single footnote.

This is definitely a regression, though I'm not sure when the problem was first introduced.

I could only reproduce this with .docx files, not with .odt or older .doc files.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Aibara 2017-10-04 21:59:07 UTC
Created attachment 136770 [details]
A docx saved once: note the tab space in the footnote
Comment 2 Aibara 2017-10-04 21:59:39 UTC
Created attachment 136771 [details]
The file saved twice: now there are two tab spaces
Comment 3 Aibara 2017-10-04 22:00:06 UTC
Created attachment 136772 [details]
A third save means a third tab space added.
Comment 4 m.a.riosv 2017-10-04 22:44:10 UTC

*** This bug has been marked as a duplicate of bug 93121 ***
Comment 5 Justin L 2018-03-21 17:01:26 UTC
Not a duplicate. Bibisect confirmed my expectation that Miklos' fix for bug 105095 caused this. LO ALWAYS exports a tab, not only when the margin is non-zero.  However, it probably OUGHT to only export a tab when the margin is non-zero since the tab's purpose is to emulate LO's alignment with the paragraph margin.

A work-around is to ensure a tiny margin in the footnote paragraph style.
Comment 6 Gabor Kelemen 2018-03-26 09:05:46 UTC
*** Bug 113553 has been marked as a duplicate of this bug. ***
Comment 7 Dieter Praas 2018-03-26 09:19:55 UTC
(In reply to Gabor Kelemen from comment #6)
> *** Bug 113553 has been marked as a duplicate of this bug. ***

=> inherited from OOo
Comment 8 Justin L 2018-03-26 17:04:01 UTC
proposed fix at https://gerrit.libreoffice.org/51912

Please note that a tab is STILL there when opened in MSWord.  That is a different bug - bug 106062.  Also note that if there is NO tab, then one will be added if the margin is zero (typically MS-authored documents).  That is the result of the fix for bug 105095.
Comment 9 Commit Notification 2018-03-29 12:41:24 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3138abfb052a4241cfca4b8d430c139cca50a85c

tdf#112886 ooxmlimport: skip useless footnote placeholder

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Justin L 2018-03-29 13:51:45 UTC
Not planning to backport - too much chance for unintended regressions.
Comment 11 Mike Kaganski 2018-07-03 14:21:29 UTC
*** Bug 51811 has been marked as a duplicate of this bug. ***
Comment 12 Mike Kaganski 2018-07-03 14:21:43 UTC
*** Bug 114389 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2019-03-20 18:00:52 UTC
*** Bug 113553 has been marked as a duplicate of this bug. ***