Download it now!
Bug 51811 - DOCX: on each FILESAVE, an extra tab is inserted between footnote number and text
Summary: DOCX: on each FILESAVE, an extra tab is inserted between footnote number and ...
Status: RESOLVED DUPLICATE of bug 112886
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: All All
: medium major
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-06 18:55 UTC by Urmas
Modified: 2018-07-03 14:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-07-06 18:55:25 UTC
With each save of DOCX documents, its footnotes will get an extra tabulator between its number and text.
Comment 1 pierre-yves samyn 2012-07-08 05:33:19 UTC
Hello

I confirm with Windows 7 64bits & Version 3.6.0.0.beta3 (Build ID: 3e2b862)

The first save : adds tab, second save : no extra tab, then each save = one more tab.

Steps to reproduce:
1. File> New
2. Type "test"
3. Insert> Footnote/Endnote, Numbering : Automatic, Ok
Cursor in the footnotes zone
4. Type "footnote text"
5. File> Save > (give a name), Type:Microsoft Word 2007/2010 XML (.docx) (*.docx)
6. Confirm "Use Microsoft... format"
7. File> Reload
8. Tab added (so one tab before "Footnote text")
9. File> Save as : same name, same file type (overwrite)
10. File> Reload (no extra tab)
11. File> Save as (same name, same file type)
12. File> Reload (2 tabs)

Redo 11 & 12 add extra tabs

Regards
Pierre-Yves
Comment 2 Roman Eisele 2012-07-19 10:32:35 UTC
Following the steps given by pierre-yves samyn (thank you!), this bug is REPRODUCIBLE also on MacOS X (10.6.8, Intel)
* with LibreOffice 3.5.5.3 (Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21)
* with LibreOffice 3.6.0.1 (Build ID: 73f9fb6),
both with German langpack installed, but UI language set to US English.
Comment 3 Roman Eisele 2012-07-19 10:41:57 UTC
Hello Luboš,
hello Miklós,
I insert your mail address into the CC list of this bug because you are our
experts for .docx import/export. This is an interesting bug with footnotes in .docx files, please take a look at it. IMHO there is a chance that it should be rather easy to fix, because it seems reasonable that this bug is located at a place in the code where the tab characters gets added to the footnote (probably on filesave, but maybe on fileopen).

Thank you very much in advance!
Comment 4 Hydriotaphia 2012-10-05 20:47:29 UTC
Dear all, 

I have been annoyed by this bug since using the older and current versions of OpenOffice, and those of LibreOffice as well. I first noticed this when making a document switching OpenOffice/ LibreOffice and MS Word 2007/ 2010 (both in English version and Japanese version). 

Consistent use of "doc" (not docx) format could be a workaround, but as some of you might have noticed, the appearance of doc documents (especially line spacing of body texts, and of endnotes) is different betwwen OpenOffice/ LibreOffice and MS Word 2003/ 2007/ 2010. 

Hope this bug is fixed shortly.

Hajime
Comment 5 Roman Eisele 2012-10-06 17:13:57 UTC
Thank you for your comment! However, what is the intention of the keyword “NEEDINFO” here? Added by accident? ;-)
Comment 6 Hydriotaphia 2013-02-11 16:06:05 UTC
Alas, it seems that the problem (extra tab insertion every time when saving documents in the docx format) still exists in version 4.0.0.3.
Comment 7 manj_k 2013-04-14 08:33:06 UTC
Resetting "Version: 3.5.5.3 release"

@ Hydriotaphia
Please have a look at 
https://wiki.documentfoundation.org/BugReport_Details#Version
Comment 8 David 2013-12-07 11:30:13 UTC
This bug persists in 4.0.4.2 (I have 4.1.2.3 on another machine, and keep forgetting to check there). I assume that this bug (and ? duplicate #39205) are still in need of attention since both remain "Not assigned"?

@manj_k - I followed your link, but wasn't sure what it meant, and it seems broken. Is this what is intended?

https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Version

This bug makes filesharing with non-LibO colleagues very difficult. (I edit a journal, and I notice this bug in that context a *lot*!) It would make life so much easier if it was eradicated. (P.s., I'm simply a "user" with no programming skills - alas!)
Comment 10 Miloš Jovanović 2018-01-16 11:48:57 UTC
Issue should not be marked as FIXED as it persists in Version: 5.4.4.2 Build ID: 1:5.4.4~rc2-0ubuntu0.17.10.1~lo1

Each successive opening of .docx file (even if it hasn't been edited in MS Word) adds another tab between footnote number and text. Similar behavior as in #39205.

I'd be happy to debug whatever necessary.
Comment 11 Miloš Jovanović 2018-01-16 11:54:03 UTC
Seems to be a duplicate of #113553.

https://bugs.documentfoundation.org/show_bug.cgi?id=113553

*** This bug has been marked as a duplicate of bug 113553 ***
Comment 12 Mike Kaganski 2018-07-03 14:21:29 UTC

*** This bug has been marked as a duplicate of bug 112886 ***