Bug 113553 - FILESAVE: DOCX: space between footnote number and the content doubles after RT
Summary: FILESAVE: DOCX: space between footnote number and the content doubles after RT
Status: RESOLVED DUPLICATE of bug 112886
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Footnote-Endnote
  Show dependency treegraph
 
Reported: 2017-10-31 12:33 UTC by Xisco Faulí
Modified: 2019-03-20 18:00 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison MSO 2010 and LibreOffice 6.0 (45.78 KB, image/png)
2017-10-31 12:33 UTC, Xisco Faulí
Details
Simple file to illustrate the issue (15.83 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-11-28 16:54 UTC, Gabor Kelemen
Details
The previous sample saved and reloaded twice in current LO 6 master (11.73 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-11-28 16:55 UTC, Gabor Kelemen
Details
The twice saved sample and the original side by side in LO 6 (62.89 KB, image/png)
2017-11-28 16:56 UTC, Gabor Kelemen
Details
The sample file saved by LO 5.3.3 (11.76 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-11-29 11:17 UTC, Gabor Kelemen
Details
5.3 added only one tab and that was visible only in Word, not in LO. (156.16 KB, image/png)
2017-11-29 11:18 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-10-31 12:33:09 UTC
Created attachment 137405 [details]
comparison MSO 2010 and LibreOffice 6.0

Steps to reproduce:
1. Open attachment 49300 [details] from bug 39378
2. Save it as DOCX
3. Open the new file

Observed behaviour: the space between footnote number and the content doubles after RT

reproduced in

Version: 6.0.0.0.alpha1+
Build ID: d30522e46ca884e9bc74af21711d9537e8118859
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2017-10-31 12:37:18 UTC
it seems it's an old bug.
I can reproduce it in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

however, the import part got broken in b38629ae210b204a6d24d6e9c5c62eaaf563d494 and recently fixed in abc440a691efb872afac385ce5ed28cd5db56c8c

@Miklos, since you fixed the import part, I thought you might be interested in this one too...
Comment 2 Dieter Praas 2017-10-31 14:34:55 UTC
Reproducible for me

Version: 6.0.0.0.alpha1 (x64)
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: group

Additional observation: When I open the attached document in LO 5.4 the footnote number in the footnot area has another size than in LO 6.0 (I guess 12 instead of 8). I don't know which one is the right one.
Comment 3 Gabor Kelemen 2017-11-28 16:54:32 UTC
Created attachment 138045 [details]
Simple file to illustrate the issue

This is a simple test file made in Word 2013.
It has two default formatted footnotes, and there is no tab between the footnote number and the footnote text, only one space.

Save this in LO 5.4+ and a tab character is added after the footnote number. Save it again and another tab is added.
Comment 4 Gabor Kelemen 2017-11-28 16:55:33 UTC
Created attachment 138046 [details]
The previous sample saved and reloaded twice in current LO 6 master

Version: 6.1.0.0.alpha0+
Build ID: 25622034bcef0b6bc3a8e6c150189f85672b2c9e
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: hu-HU (hu_HU.UTF-8); Calc: group threaded
Comment 5 Gabor Kelemen 2017-11-28 16:56:19 UTC
Created attachment 138047 [details]
The twice saved sample and the original side by side in LO 6
Comment 6 Gabor Kelemen 2017-11-29 11:17:05 UTC
Created attachment 138058 [details]
The sample file saved by LO 5.3.3
Comment 7 Gabor Kelemen 2017-11-29 11:18:49 UTC
Created attachment 138059 [details]
5.3 added only one tab and that was visible only in Word, not in LO.

Even after resaving there was only one extra tab added.
I think we might consider this as a regression from bug#105095
Comment 8 Xisco Faulí 2017-12-11 12:48:45 UTC
*** Bug 114389 has been marked as a duplicate of this bug. ***
Comment 9 nokidding 2017-12-11 13:13:08 UTC
Agree bug 114389 is similar to the above except for two things I observed in my example (https://bugs.documentfoundation.org/attachment.cgi?id=138360): 1. footnote tab is incremental, more openings create more unwanted tabs and this is evident in links; 2. the unwanted tab is present in both MO and LO.
Comment 10 Miloš Jovanović 2018-01-16 11:54:03 UTC
*** Bug 51811 has been marked as a duplicate of this bug. ***
Comment 11 Miloš Jovanović 2018-01-16 12:02:17 UTC
Indeed an old bug that keeps reappearing. I can reproduce it on Version: 5.4.4.2 Build ID: 1:5.4.4~rc2-0ubuntu0.17.10.1~lo1. Each save adds a successive tab.

To explain why the bug is very important. The vast majority of academic workers make heavy use of footnotes and rely on Track Changes to work with people who use .docx (editors, collaborators). The bug makes Writer practically useless for academic work.
Comment 12 Angelos Skembris 2018-03-23 15:14:43 UTC
Please note that this is still present in version 6.0.1. (the #51811 version, where a tab is added). 

Also, the "Footnote" style seems to really want a tab stop at 1 cm. Deleting the stop in the style configuration dialog box, saving and reopening the document results in the tab stop being present again (along with the tab after the footnote number, of course).
Comment 13 Gabor Kelemen 2018-03-26 09:05:46 UTC

*** This bug has been marked as a duplicate of bug 112886 ***
Comment 14 Luke Munn 2019-01-29 21:03:16 UTC
I can confirm that this is still occurring on 6.0.4.2. Namely, when saving from ODT to DOCX, a tab is added before every single footnote. 

I imagine that, while new versions add more features, do bug fixes, etc, the Import/Export Docx code doesn't get touched, which is why this has been an issue, it seems, since 2015. 

As Milos noted, this is indeed a significant issue for academics wishing to use LO. I use and advocate for FOSS, but others do use Word for tracking changes and commenting. To keep having massive tabs appearing in my work, and my supervisor to keep mentioning it, is a bit embarrassing. I really like LO in a lot of ways, but this aspect is painful. 

Could this please be fixed?
Comment 15 rene 2019-02-26 18:29:10 UTC
Just adding that this bug persists to be a problem with the following version/config:

Version: 6.0.6.2
Build ID: 6.0.6.2-3.fc28
CPU threads: 4; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

As previous reporters noted this created lot's of trouble for people trying to move to FOSS in environments where most others still did not, such as legal academia.
Comment 16 Dieter Praas 2019-02-27 16:51:35 UTC
If it is really a duplicate of bug 112886, it should be fixed in 6.1. René and Luke, could you give it a try?
Comment 17 Xisco Faulí 2019-03-20 18:00:52 UTC
(In reply to Dieter Praas from comment #16)
> If it is really a duplicate of bug 112886, it should be fixed in 6.1. René
> and Luke, could you give it a try?

The issue is not reproducible in

Version: 6.3.0.0.alpha0+
Build ID: eb128a7d6bbc27b4dbbf9461c81c90e40203b114
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 112886 ***