Download it now!
Bug 113019 - menu text/background color does not follows desktop's color's theme
Summary: menu text/background color does not follows desktop's color's theme
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 119845 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2017-10-09 15:34 UTC by opensuse.lietuviu.kalba
Modified: 2020-01-07 15:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
selected menu root entry ("Table") is not visible because of near white backgroud (46.51 KB, image/png)
2017-10-09 15:34 UTC, opensuse.lietuviu.kalba
Details
not selected menu entries with black text are poorly visible with dark manu backgroud (46.39 KB, image/png)
2017-10-09 15:36 UTC, opensuse.lietuviu.kalba
Details
6.1.0master~2018-02-14 Zion color scheme (4.82 KB, image/png)
2018-02-14 10:30 UTC, opensuse.lietuviu.kalba
Details
Expected result with Zion color scheme (example from KDE native program) (13.97 KB, image/png)
2018-02-14 10:34 UTC, opensuse.lietuviu.kalba
Details
MP4 video of LibreOffice 6.1.0 RC2 (2.75 MB, video/mp4)
2018-07-23 08:23 UTC, opensuse.lietuviu.kalba
Details
WEBM video of LibreOffice 6.1.0 RC2 (2.7 (745.55 KB, video/webm)
2018-07-23 08:29 UTC, opensuse.lietuviu.kalba
Details
Video of expected result (KDE Dolphin example) (1.25 MB, video/x-msvideo)
2018-07-23 08:37 UTC, opensuse.lietuviu.kalba
Details
WebM Video of expected result (KDE Dolphin example) (372.13 KB, video/webm)
2018-07-23 08:39 UTC, opensuse.lietuviu.kalba
Details
LibreOffice 6.3.4.2 - seems OK (30.29 KB, image/png)
2020-01-05 20:33 UTC, opensuse.lietuviu.kalba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2017-10-09 15:34:40 UTC
Created attachment 136875 [details]
selected menu root entry ("Table") is not visible because of near white backgroud

Menu text color is always black for non-selected entries and white for selected entries (i.e. does not follows desktop's color's theme), 
meanwhile menu's background - does follow desktop's color's theme.
As result: 
if background color is dark - non-selected entries are invisible;
if background color is almost white – selected entries are almost invisible!

If menu entries text color will follow desktop color theme - text will be visible always.
Comment 1 opensuse.lietuviu.kalba 2017-10-09 15:36:49 UTC
Created attachment 136876 [details]
not selected menu entries with black text are poorly visible with dark manu backgroud
Comment 2 opensuse.lietuviu.kalba 2017-10-09 15:37:47 UTC
I use Linux OS with KDE desktop
Comment 3 opensuse.lietuviu.kalba 2017-10-09 15:50:36 UTC
After removing libobasis5.4-kde-integration package menu starts to follow GTK theme, but I prefer to use libobasis5.4-kde-integration package to use native KDE file-browser dialogs
Comment 4 opensuse.lietuviu.kalba 2017-10-09 16:38:10 UTC
I tested same LibreOffice 5.4.2 in KDE 4 (in VirtualBox) - here colors are used correctly. Thus problem is only with KDE Plasma 5 desktop (at least with 5.8 version).
Comment 5 Buovjaga 2017-11-04 17:44:32 UTC
A new backend is in development, so it might make sense to wait for it: https://cgit.freedesktop.org/libreoffice/core/log/?h=private/jmux/qt5
Comment 6 Xisco Faulí 2018-01-09 11:13:35 UTC
The qt5 work is merged in master now, however, it's not finished yet.
Comment 7 Xisco Faulí 2018-02-14 09:55:36 UTC
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongsidethe standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 8 opensuse.lietuviu.kalba 2018-02-14 10:30:32 UTC
Created attachment 139896 [details]
6.1.0master~2018-02-14 Zion color scheme

Now word "Table" in meniu is visible, more colors respected, but still not as desired: background for word "Table" should change background.
Comment 9 opensuse.lietuviu.kalba 2018-02-14 10:31:46 UTC
After testing master~2018-02-14, problem still exist: changing status to unconfirmed
Comment 10 opensuse.lietuviu.kalba 2018-02-14 10:34:39 UTC
Created attachment 139897 [details]
Expected result with Zion color scheme (example from KDE native program)

LibreOffice should look like native KDE program, see example. Both meniu root and selected lower item has changed background.
Comment 11 opensuse.lietuviu.kalba 2018-02-14 10:45:43 UTC
To be more precise:
background for _active_ root menu element may have different color than _non active_ (e.g. for word Table in while entering into Table menu)
Comment 12 opensuse.lietuviu.kalba 2018-07-23 08:23:45 UTC
Created attachment 143710 [details]
MP4 video of LibreOffice 6.1.0 RC2

See MP4 video – problem still exist in LibreOffice 6.1.0 RC2. Root menu elements are not visible, because their background color don't follow KDE Plasma5 (Qt5) theme. 

Versija: 6.1.0.2
Darinio identifikatorius: b3972dcf1284967612d5ee04fea9d15bcf0cc106
Procesoriaus gijos: 4; OS:Linux 4.4; Sąsajos pateikimas: numatytasis; VCL: kde4; 
Lokalė: lt-LT (lt_LT.UTF-8); Calc: group threaded

P.S. Why VLC is named as KDE4, shouldn't it be named as Qt5 now?
Comment 13 opensuse.lietuviu.kalba 2018-07-23 08:29:30 UTC
Created attachment 143711 [details]
WEBM video of LibreOffice 6.1.0 RC2 (2.7

same video as above, but converted to webm (vp9) format
Comment 14 opensuse.lietuviu.kalba 2018-07-23 08:37:13 UTC
Created attachment 143712 [details]
Video of expected result (KDE Dolphin example)

Expected result is behaviour as in native KDE Plasma 5 program, like Dolphin.
Comment 15 opensuse.lietuviu.kalba 2018-07-23 08:39:00 UTC
Created attachment 143713 [details]
WebM Video of expected result (KDE Dolphin example)

same video as above, converted to WEBM (vp9) format
Comment 16 Buovjaga 2018-07-23 08:54:04 UTC
(In reply to opensuse.lietuviu.kalba from comment #12)
> P.S. Why VLC is named as KDE4, shouldn't it be named as Qt5 now?

It is not yet ready, so it will only come to 6.2 (will be named kde5).
Comment 17 Buovjaga 2018-10-05 11:37:26 UTC
*** Bug 119845 has been marked as a duplicate of this bug. ***
Comment 18 Buovjaga 2018-10-05 11:37:48 UTC
NEW per dupe
Comment 19 Buovjaga 2019-01-01 18:24:07 UTC
Changed to Zion in the KDE color settings and tested with the new KDE5 LibreOffice backend. Unfortunately, the menu highlighting is dark grey instead of Zion's violet. Other elements correctly use violet, such as selections in the sidebar.

Version: 6.3.0.0.alpha0+
Build ID: 2c7b0030b40de00e8c9ab997bdfe83631861968a
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Comment 20 Jan-Marek Glogowski 2019-06-13 00:25:11 UTC
Can someone retest this please with 6.3 or master with kde5 / qt5?

Zion is unusable for me on Debian Buster, either with LO or with kate. Both menus are broken (black on dark gray). And I realized that menus don't follow style change events. I always had to restart the application.

Since we now use native Qt menus (not for popups!), it should follow KDE's style.
Comment 21 Buovjaga 2019-06-13 04:28:18 UTC
opensuse.lietuviu.kalba: as Zion is broken, can you do more testing with other color schemes?
Comment 22 QA Administrators 2019-12-11 03:39:31 UTC Comment hidden (obsolete)
Comment 23 opensuse.lietuviu.kalba 2020-01-05 20:33:12 UTC
Created attachment 156951 [details]
LibreOffice 6.3.4.2 - seems OK

Seems fixed in LO 6.3
Comment 24 opensuse.lietuviu.kalba 2020-01-05 20:33:52 UTC
Closing as fixed
Comment 25 Xisco Faulí 2020-01-07 15:12:56 UTC
Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.