Download it now!
Bug 116585 - Text is black on black inside the Math formula editor with "Breeze dark" theme (KDE)
Summary: Text is black on black inside the Math formula editor with "Breeze dark" them...
Status: RESOLVED DUPLICATE of bug 90297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-03-23 12:38 UTC by n.tsimakuridze
Modified: 2019-05-10 06:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with kde5 (51.00 KB, image/png)
2019-03-28 23:13 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description n.tsimakuridze 2018-03-23 12:38:13 UTC
Description:
I use KDE neon and recently switched to "Breeze dark" theme. This correctly makes the background colors in Libre Office (including the formula editor in Wirter) dark. However it doesn't change the font color in the formula editor to white (or some other light colour), so I get black font on black background which is invisible.

Steps to Reproduce:
1. Choose "breeze dark" theme on KDE neon (probably does the same with other dark themes and other systems)
2. Open Libre Office Writer
3. Insert > Object > Formula
4. Typed anything

Actual Results:  
text appears as black on black background (so is not visible)

Expected Results:
text should appear as white (or whatever color is specified as primary color by the theme)


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36 OPR/51.0.2830.55
Comment 1 Buovjaga 2018-03-29 14:05:45 UTC
Repro.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 9c459fd919cb8199a69fc2d630742930e533285b
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 29th 2018
Comment 2 Alex Thurgood 2018-11-14 08:58:52 UTC
Seems like bug 121380 might be a possible duplicate of this report.
Comment 3 ckoresko 2018-12-31 19:36:57 UTC
I see the same issue with the Adwaita-dark theme on GNOME3.30.2.  

I set the "Document background" to black and the "Font color" to white under "Options -> LibreOffice -> Application Colors" and inserted a formula in Writer by doing Alt-I - O - F to get the formula text entry box.  The text in the entry box was white on a black background as expected, and the formula in the Writer page display was also white on a black background.  But when I clicked on a blank part of the Writer document to finish entering the formula, the formula switched to black on black.  

I haven't found any way to change the color of the finished formula except by putting explicit colors in the formula itself.  I don't want to do that since the light color would probably persist even if someone opened the .odt file with LO configured for black text on a white background.
Comment 4 ckoresko 2018-12-31 19:50:57 UTC
Oops, mine is a related but different bug: black formula text in the *document* rather than in the *editor*.  I apologize for the error.
Comment 5 Buovjaga 2019-01-01 16:16:05 UTC
With the KDE5 backend, I don't reproduce the problem, but maybe it is because it does not adapt to the theme yet.

Version: 6.3.0.0.alpha0+
Build ID: 2c7b0030b40de00e8c9ab997bdfe83631861968a
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Michael Weghorn 2019-03-28 23:13:14 UTC
Created attachment 150385 [details]
Screenshot with kde5

It seems this is now also reproducible with the new kde5 VCL plugin after going to Plasma system settings -> "Workspace Theme" and setting the "Look and Feel" and "Desktop Theme" to "Breeze Dark".

After logging out and in again, it looks as shown in the attached screenshot.
It's actually black font on grey background, so somewhat readable, but not ideal...

Version: 6.3.0.0.alpha0+
Build ID: 28eab5de358631758315a3581e860d6ef533259a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Side note: It's just fine in the "Help" -> "About" dialog, for example (white font used there).
Comment 7 Ville Aakko 2019-05-10 06:35:28 UTC
I believe this is a duplicate of bug 90297 ? 

That bug is more general, as in applies all desktop environments. I.e. this is not fault of qt/kde5 (correct me if I'm using the library names incorrectly, I find this GTK/QT/KDE/Plasma and related libraries thing sometimes confusing).
Comment 8 Buovjaga 2019-05-10 06:43:33 UTC

*** This bug has been marked as a duplicate of bug 90297 ***