Download it now!
Bug 113139 - EDITING: Applying/undo formatting for a large document is a bit slower as it has been before
Summary: EDITING: Applying/undo formatting for a large document is a bit slower as it ...
Status: RESOLVED DUPLICATE of bug 112989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-15 17:47 UTC by Telesto
Modified: 2017-11-22 11:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (6.42 KB, text/plain)
2017-10-15 17:49 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-10-15 17:47:51 UTC
Description:
Applying/undo formatting for a large document is a bit slower as it has been before



Steps to Reproduce:
1. Open Writer
2. Disable automatic spell checking
3. Open attachment 136963 [details]
4. Press CTRL+A and wait until loading is complete (CPU usage drops to +/-0)
5. Press CTRL+B and monitor the time until the CPU usage drops from max to 0 (for me 5 sec with LibO6 and 3 sec with a good build: for example commit f8f8bdf24f7fc2f76810d36c4e1ce0e808c9509e)
6. Undo the change (CTRL+Z) With LibO6 6 seconds at max. With the good build 4)

Actual Results:  
Bold takes 5 sec with LibO6 
Undo takes 6 sec with LibO6

Expected Results:
Same as in f8f8bdf24f7fc2f76810d36c4e1ce0e808c9509e (or other previous versions)
Bold in 3 sec
Undo in 4 sec


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 6.0.0.0.alpha0+
Build ID: c5a93cad149618bbd43632f1660a558c34bdbf7e
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-07_01:04:25
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-10-15 17:49:05 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2017-10-18 10:32:12 UTC
In my case, it takes 3 seconds in each case.

@Tor, Would you like to comment about this issue? Personally I would say NOTABUG. A difference of 2 seconds in a 1486 pages file is irrelevant to me.
Comment 3 Xisco Faulí 2017-10-26 23:08:54 UTC
Could you please try with LibreOffice 6.0 alpha1 http://dev-builds.libreoffice.org/pre-releases/?
Comment 4 Telesto 2017-10-29 17:04:28 UTC
(In reply to Xisco Faulí from comment #3)
I was looking way to far back:

Repro with:
Versie: 5.3.7.2 
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL

No repro with
Versie: 5.3.7.2 
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: oud; 
Locale: nl-NL (nl_NL); Calc: CL


Tools -> Options -> Advanced: Expert Configuration search for "TextLayoutEngine" and edit to change "new|old" as needed. (Source: bug 89870 comment 32)

So this bug, bug 113350, bug 112979 and bug 112989 are most likely dupes.

*** This bug has been marked as a duplicate of bug 112989 ***
Comment 5 Telesto 2017-11-22 11:09:49 UTC
*** Bug 108513 has been marked as a duplicate of this bug. ***