Bug Hunting Session
Bug 113711 - Roundtripping flipped group drawing in .docx results in shifted image in Word (but not Writer)
Summary: Roundtripping flipped group drawing in .docx results in shifted image in Word...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on: 91999
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-08 04:40 UTC by Luke
Modified: 2018-08-15 14:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of shape shifted (21.25 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-11-08 04:42 UTC, Luke
Details
Comparison of test doc saved with 10-06 vs 11-06 (60.34 KB, image/png)
2017-11-08 05:01 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2017-11-08 04:40:27 UTC
Steps to reproduce:
1. Open GroupRotateBug.docx in Writer
2. Save
3. Open in Word

This is a follow up to Bug 91850. There are 2 test cases in this attachment, 180 rotation(top) and 350 deg rotation(bottom). The 180 case was fixed in Bug 91850 and recently regressed. 

Hopefull the 350 will be fixed with the 180, if not, I'll file a new bug report.
Comment 1 Luke 2017-11-08 04:42:21 UTC
Created attachment 137613 [details]
Example of shape shifted
Comment 2 Luke 2017-11-08 05:01:07 UTC
Created attachment 137614 [details]
Comparison of test doc saved with 10-06 vs 11-06

Version: 6.0.0.0.alpha0+ Build ID: b567cfb980435df131d776915bce9152135bdf0f
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-06_05:43:17
was good
Comment 3 Luke 2017-11-08 09:51:05 UTC
Version: 6.0.0.0.alpha1+
Build ID: 7e03c4eed72452fdfb87341214a21956c08ba969
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-25_23:46:13
Good

Version: 6.0.0.0.alpha1+
Build ID: ba9f44d6ee560bbba09834b1070d19ec62d35783
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-27_01:02:01
Bad
Comment 4 Buovjaga 2017-11-16 06:59:15 UTC
Repro

Win 8.1 32-bit
LibO Version: 6.0.0.0.alpha1+
Build ID: a5af0fd9f27af42cf2e8571f659cdad6e606215b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-11-06_23:18:19
Locale: fi-FI (fi_FI); Calc: group
MSO 2013
Comment 5 Luke 2017-11-17 20:22:13 UTC
Szymon Kłos,
https://cgit.freedesktop.org/libreoffice/core/commit/?id=9ae1e094d5a8a5b4432c88ebea0ca9fc1c79f602

Is in that range. Like Bug 91850 it looks like we're dealing with an export bug begin masked by an import bug. 

Are you two 100% sure collapsing all of the rotations instead of preserving them, is the right way to handle rotations in group shapes?
Comment 6 Luke 2017-11-19 04:28:42 UTC
Confirmed, this issue was introduced by 9ae1e094d5a8a5b4432c88ebea0ca9fc1c79f602.
Comment 7 Xisco Faulí 2017-12-04 13:54:34 UTC
Adding Cc: to Szymon Kłos
Comment 8 Justin L 2018-08-01 16:46:36 UTC
The bug fix for 91999 will also fix this regression. https://gerrit.libreoffice.org/58434 tdf#91999 export/drawingml: shape rotate 180 is not special
Comment 9 Justin L 2018-08-10 15:45:55 UTC
fixed in LO 6.2 with commit ab296726263655bd3a722c125dd9cec2d507aaa5
Comment 10 Xisco Faulí 2018-08-15 14:45:54 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 5779b4966954d845f3c526c340bdee8c6a92ef95
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded