Download it now!
Bug 115630 - FILEOPEN .docx : Chart is distorted and legend overlaps with the chart
Summary: FILEOPEN .docx : Chart is distorted and legend overlaps with the chart
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.5
Keywords: filter:ooxml, implementationError
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2018-02-11 14:53 UTC by Gerry
Modified: 2020-05-11 15:13 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
.docx file with chart (66.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-02-11 14:54 UTC, Gerry
Details
PDF, document with chart exported from MS Word 2010 (that's how the chart should look like) (1018.31 KB, application/pdf)
2018-02-11 14:56 UTC, Gerry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2018-02-11 14:53:39 UTC
Description:
The chart in attached .docx file (from MS Word 2010) is distorted when opening it in LibreOffice Writer



Steps to Reproduce:
1. Open attached .docx file in LO Writer
2. Compare the result with attached PDF (PDF export from MS Word 2010)

Actual Results:  
The chart is distorted. The width of the chart is larger than in the original and therefore the legend overlaps with the chart.

Expected Results:
The chart in the imported .docx should look exactly like in MS Word


Reproducible: Always


User Profile Reset: No



Additional Info:

System:

Version: 6.0.1.1
Build ID: 1:6.0.1~rc1-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.4; UI render: GL; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8);


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Gerry 2018-02-11 14:54:27 UTC
Created attachment 139785 [details]
.docx file with chart
Comment 2 Gerry 2018-02-11 14:56:09 UTC
Created attachment 139786 [details]
PDF, document with chart exported from MS Word 2010 (that's how the chart should look like)
Comment 3 raal 2018-02-12 18:22:09 UTC
Confirm with LO 6.1, Linux

when the docx is opened, this is shown in the console 4 times:
E: lt_string_value: assertion `string != ((void *)0)' failed
Comment 4 Aron Budea 2019-04-17 19:47:03 UTC
Chart impoty started in 4.2.0.4, and it's already bad there, adjusting earliest version. Still buggy in 6.3.0.0.alpha0+ (26e85974a0287ab5869e7ff0145a66b853d66a02).
Comment 5 Commit Notification 2019-11-27 11:04:03 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/739ed2c29f49ea5e83bcd1352b2644c2e2d09f7b

tdf#115630 tdf#88922 Chart: fix custom legend position and size

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Timur 2019-11-29 20:38:42 UTC
Legend overlap is fixed, great.
But there seems to be another issue, horizontal axis.
LO starts from 1 instead from 0. That's also from 4.2.
Comment 7 NISZ LibreOffice Team 2019-12-02 09:56:49 UTC
(In reply to Timur from comment #6)
> Legend overlap is fixed, great.
> But there seems to be another issue, horizontal axis.
> LO starts from 1 instead from 0. That's also from 4.2.

Interesting, thanks for spotting.

bug#127393 was about that problem, but that fix works only for XLSX/PPTX. For DOCX import we would need an ODF property to map this CrossBetween setting of OOXML (since DOCX import works via an intermediate ODF export/import), and bug#127792 is about creating one.
Comment 8 Timur 2019-12-02 10:48:34 UTC
Since I understand that other issue has a separate (non-trivial) bug, I set this one as Verified.
Comment 9 Commit Notification 2019-12-02 15:16:39 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/1903d0275b09d88eec6e57303a8a7d34246cb230

tdf#115630 tdf#88922 Chart: fix custom legend position and size

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-12-09 12:42:39 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/8c39a4ea777c0afa1dbea9a3399436d22c2e6e70

tdf#115630 tdf#88922 Chart: fix custom legend position and size

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.