Bug 127792 - No support in ODF for Axis position type chart axis property
Summary: No support in ODF for Axis position type chart axis property
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Tünde Tóth
URL:
Whiteboard: target:7.0.0
Keywords: implementationError
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2019-09-26 13:50 UTC by NISZ LibreOffice Team
Modified: 2020-05-06 09:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Word (42.64 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-09-26 13:50 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer. (121.92 KB, image/png)
2019-09-26 13:51 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-09-26 13:50:13 UTC
Description:
In MSO it is possible to set a custom axis position to be On tick marks / Between tick marks. Some chart types are using Between tick marks as default (such as column, bar, line) while others use On tick marks, such as area.

Currently it is not possible to read/write a similar property of chart axes to ODF, or set on the UI.
For better MSO interoperability / feature parity it would be nice to support this property of chart axes when dealing with ODF.


Steps to Reproduce:
1.	Open attached docx file

Actual Results:
The line and area chart lines jump close to the vertical axis instead of staying between the tickmarks, despite the fix in bug #127393. This is due to the nature of docx import, which includes an ODF conversion.

Expected Results:
The axis position setting appears the same as in Word. 
Also adding support for this option in ODF should open the possibility to add a currently missing UI option to modify it, like MSO does.



Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 5440274a2a295fb2662ea415f25b89fc298930c8
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-09-26_01:04:59
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2019-09-26 13:50:47 UTC
Created attachment 154549 [details]
Example file from Word
Comment 2 NISZ LibreOffice Team 2019-09-26 13:51:04 UTC
Created attachment 154550 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 3 Dieter 2019-09-29 19:58:34 UTC
I confirm it with

Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 4 Regina Henschel 2020-03-20 13:59:12 UTC
Please follow the way it will be defined in ODF 1.4
https://issues.oasis-open.org/browse/OFFICE-3936
Comment 5 Commit Notification 2020-04-09 09:13:32 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/40d83914d43f60a196dfabddea0b52e2046b333a

tdf#127792 implement UNO chart attribute MajorOrigin

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 BogdanB 2020-05-02 21:07:50 UTC
Great! Solved!
Verified in 
Version: 7.0.0.0.alpha0+
Build ID: 05b87ae66ebccd06995cf530b860443ad9503b31
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-02_10:14:58
Calc: threaded