Download it now!
Bug 117466 - [vclplug_kde4] Minimize Presentation for Impress on Kubuntu crashes, works ok on Ubuntu
Summary: [vclplug_kde4] Minimize Presentation for Impress on Kubuntu crashes, works ok...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: kde4
Keywords: haveBacktrace
: 116294 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-05-07 02:25 UTC by daviding
Modified: 2018-12-21 18:12 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Impress file for reduction to 150dpi (5.76 MB, application/vnd.oasis.opendocument.presentation)
2018-05-07 13:04 UTC, daviding
Details
Minimize Presentation crash backtrace (20.64 KB, text/plain)
2018-05-07 13:50 UTC, daviding
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daviding 2018-05-07 02:25:56 UTC
I have a triple-boot Thinkpad, so it's easy for me to test LibreOffice on multiple platforms.  I've upgraded to Kubuntu 18.04 and Ubuntu 18.04.  Tools ... Minimize Presentation ... crashes on Kubuntu 18.04, but doesn't on Ubuntu 18.04.  

Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-CA (en_CA.UTF-8); Calc: group 

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04 LTS
Release:        18.04
Codename:       bionic

$ plasmashell --version
plasmashell 5.12.4

$ kf5-config --version
Qt: 5.9.5
KDE Frameworks: 5.44.0
kf5-config: 1.0
Comment 1 Julien Nabet 2018-05-07 09:29:09 UTC
Would it be possible you attach the file to minimize?
Indeed, I created a brand new odp with just 1 slide containing "test" and I don't reproduce this.

Please don't forget to remove any confidential/private part from it since it'll automatically made public.
Comment 2 daviding 2018-05-07 13:04:44 UTC
Created attachment 141955 [details]
Impress file for reduction to 150dpi

Here is a presentation that I did last month, 5.8 MB, that causes the crash.  (The more recent culprit, at 14.8 MB, was based on this one).  

This 5.8 MB file went through Minimize Presentation under LibreOffice in Kubuntu 17.10 fine.  Now, retesting under LibreOffice 6 in Kubuntu 18.04 crashes.

One other error message that I was getting was from LanguageTool extension, about a Java version problem.  I disabled that plugin in LO 6, so it doesn't show up any more.  

Under Options ... LibreOffice ... Advanced ..., I'm showing the JRE of Oracle Corporation 10.0.1 (if that makes a difference).
Comment 3 Julien Nabet 2018-05-07 13:23:08 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce this.

Would it be possible you attach a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 4 Julien Nabet 2018-05-07 13:28:20 UTC
Also, I'm not sure LO is compatible with Java 10 but I may be wrong.
Stephan: any thoughts about this point specifically?
Comment 5 Stephan Bergmann 2018-05-07 13:34:54 UTC
(In reply to Julien Nabet from comment #4)
> Also, I'm not sure LO is compatible with Java 10 but I may be wrong.
> Stephan: any thoughts about this point specifically?

I at least am not aware of any issues (myself using Java 10 with my LO Windows build at least, and not encountered any issue there yet).
Comment 6 Julien Nabet 2018-05-07 13:37:07 UTC
(In reply to Stephan Bergmann from comment #5)
> (In reply to Julien Nabet from comment #4)
> > Also, I'm not sure LO is compatible with Java 10 but I may be wrong.
> > Stephan: any thoughts about this point specifically?
> 
> I at least am not aware of any issues (myself using Java 10 with my LO
> Windows build at least, and not encountered any issue there yet).

Thank you for your quick feedback! I thought this Java version may be too recent for being taken into account by LO. I was wrong then! :-)
Comment 7 daviding 2018-05-07 13:50:52 UTC
Created attachment 141957 [details]
Minimize Presentation crash backtrace

Here's the backtrace.  Thanks for directing me on how to create that.
Comment 8 Julien Nabet 2018-05-07 14:06:47 UTC
I noticed these lines on your bt:
#10 0x00007fb4f5e094f9 in KIO::NetAccess::enter_loop() () from /usr/lib/libkio.so.5
#11 0x00007fb4f5e0a3aa in KIO::NetAccess::synchronousRunInternal(KIO::Job*, QWidget*, QByteArray*, KUrl*, QMap<QString, QString>*) () from /usr/lib/libkio.so.5
#12 0x00007fb4f5e0a47d in KIO::NetAccess::synchronousRun(KIO::Job*, QWidget*, QByteArray*, KUrl*, QMap<QString, QString>*) () from /usr/lib/libkio.so.5

Is the file you want to minimize on network share or something?
If yes, could you copy it locally and give a try?
Comment 9 daviding 2018-05-07 14:36:57 UTC
I have two physical disks on my Thinkpad.

-- begin paste --

$sudo lshw -class disk -short 
H/W path         Device      Class          Description
=======================================================
/0/0/0.0.0       /dev/sda    disk           1TB WDC WD10SPCX-22H
/0/3/0.0.0       /dev/cdrom  disk           DVDRAM GU70N
/0/4/0.0.0       /dev/sdb    disk           240GB Crucial_CT240M50

-- end paste --

The relevant disks are:

sdb1 Kubuntu 18.04
sdb3 Ubuntu 18.04
sdb4 Deepin Linux

sdb5 home (EXT4)

sda2 mounted as /dos (NTFS)

So, the bug report comes from sdb1 Kubuntu 18.04 , and the ODP file on sda2.

Is this a real problem for LO 6 under Kubuntu 18.04 but not Ubuntu 18.04?  This wasn't a problem for L0 5 under Kubuntu 17.10.

-- begin paste --

$ sudo fdisk -l
Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xf9d1777a

Device     Boot      Start        End    Sectors  Size Id Type
/dev/sda1  *          2048    3071999    3069952  1.5G  7 HPFS/NTFS/exFAT
/dev/sda2          3072000 1919903743 1916831744  914G  7 HPFS/NTFS/exFAT
/dev/sda3       1919903744 1953521663   33617920   16G  7 HPFS/NTFS/exFAT


Disk /dev/sdb: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x000efb7b

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sdb1            2048 102398309 102396262 48.8G 83 Linux
/dev/sdb2       287467108 468860927 181393820 86.5G  5 Extended
/dev/sdb3       102398310 195302606  92904297 44.3G 83 Linux
/dev/sdb4  *    195318270 287451044  92132775   44G 83 Linux
/dev/sdb5       287467110 436759154 149292045 71.2G 83 Linux
/dev/sdb6       436766720 468860927  32094208 15.3G 82 Linux swap / Solaris

Partition 2 does not start on physical sector boundary.
Partition 3 does not start on physical sector boundary.
Partition 4 does not start on physical sector boundary.
Partition 5 does not start on physical sector boundary.
Partition table entries are not in disk order.

-- end paste --
Comment 10 Stephan Bergmann 2018-05-07 14:57:19 UTC
(In reply to daviding from comment #7)
> Created attachment 141957 [details]
> Minimize Presentation crash backtrace

abort called from GenericSolarMutex::doRelease when using vclplug_kde4, whoever wants to fix that
Comment 11 Julien Nabet 2018-05-07 15:45:16 UTC
Since I don't have more questions and there's a bt, let's put this one to NEW.
Comment 12 Xisco Faulí 2018-05-08 09:29:07 UTC
I can't reproduce it in

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group

Does it crash if you delete LibreOffice and you install it from https://www.libreoffice.org/download/libreoffice-fresh ?

I'm asking because we had a crash in Kubuntu ( bug 98776 ) and it was only reproducible with the ppa releases but not with the TDF ones -> https://bugs.documentfoundation.org/show_bug.cgi?id=98776#c29

Adding Olivier Tilloy to the loop as well
Comment 13 daviding 2018-05-23 07:32:19 UTC
Just to be complete ...  I've now got my Thinkpad X200 installed with Manjaro KDE, and the crash still happens.  

Version: 6.0.4.2
Build ID: 6.0.4-1
CPU threads: 2; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: en-CA (en_CA.UTF-8); Calc: group

$ lsb_release -a
LSB Version:    n/a
Distributor ID: ManjaroLinux
Description:    Manjaro Linux
Release:        17.1.10
Codename:       Hakoila

$ plasmashell --version
plasmashell 5.12.5

$ kf5-config --version
Qt: 5.10.1
KDE Frameworks: 5.46.0
kf5-config: 1.0

So, my assessment is that the problem that was in LO Version 6.0.3.2 is still there with 6.0.4.2 (and this has to do with KDE and not the underlying Ubuntu or Manjaro).
Comment 14 Xisco Faulí 2018-05-28 10:48:58 UTC Comment hidden (obsolete)
Comment 15 Xisco Faulí 2018-05-28 10:51:30 UTC
Better to close the other one and follow up on this one as there's more information... Sorry for the noise...
Comment 16 Xisco Faulí 2018-05-28 10:51:56 UTC
*** Bug 116294 has been marked as a duplicate of this bug. ***
Comment 17 Ysabeau 2018-09-07 09:11:04 UTC
Still in 6.1.0.3 with my computer under Mageia that works with KDE 5 but not in the other under Mageia with LXDE.

I think it is something relating to KDE: LibreOffice KDE4/desktop KDE5.
Comment 18 Xisco Faulí 2018-12-21 18:12:55 UTC
KDE4 support was removed in master in the following commit:

author	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-09-05 02:53:07 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-12-17 18:33:13 +0100
commit	410bf59de02192c2daf1158b9de76ec0ebab4c56 (patch)
tree	be010e92b862f169076de979796075c925c3e576
parent	6a53832080cf201e960113de8e1887d99e857606 (diff)
kde5: remove older kde/tde plugins, and references to that
KDE4 is out of maintenance upstream since Nov. 2014, and binaries
provided by TDF have switched to KDE5 as the official backend.

Closing as RESOLVED WONTFIX