Bug 98776 - file dialog crashes LibreOffice if libreoffice-kde4 installed ( Kubuntu 17.10 ) (workaround in comment 32)
Summary: file dialog crashes LibreOffice if libreoffice-kde4 installed ( Kubuntu 17.10...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: wantBacktrace
: 115927 115971 115978 116064 116151 116276 116508 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2016-03-19 18:52 UTC by SecUpwN
Modified: 2019-09-16 17:30 UTC (History)
18 users (show)

See Also:
Crash report or crash signature:


Attachments
First gdbtrace of crash (634 bytes, application/x-gzip)
2016-03-20 15:48 UTC, SecUpwN
Details
Second gbtrace of crash (889 bytes, application/x-gzip)
2016-03-31 09:07 UTC, SecUpwN
Details
Third gbtrace of crash (1012 bytes, application/x-gzip)
2016-04-12 11:55 UTC, SecUpwN
Details
crash backtrace on kubuntu 17.10 (12.86 KB, text/plain)
2018-02-25 18:19 UTC, simhnna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SecUpwN 2016-03-19 18:52:07 UTC
LibreOffice Writer instantly crashes when wanting to export a document to PDF, leaving multiple recovery information (.~lock.*#) behind. When wanting to open the same document again, LibreOffice asks if the file shall be recovered.

System: OpenSUSE Tumbleweed
Tested: LibreOffice 5.1.0.3 release and current LibreOffice Fresh

Since I am using the rolling release Tumbleweed, I suspected this to be a bug caused by an incompatibility, but even a fresh reinstall of LibreOffice did not resolve the bug. Please tell me the best way to grab the stacktrace for fixing.
Comment 1 raal 2016-03-19 23:03:12 UTC
Please follow the instructions provided at this link < https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux >. and submit a backtrace. 
Please attach test file for reproduce the bug. Thanks.
Comment 2 SecUpwN 2016-03-20 15:48:00 UTC
Created attachment 123734 [details]
First gdbtrace of crash

Seems like not all necessary debugging symbols have been installed. Please let me know the appropriate source of the debugging symbols for openSUSE is needed. Thanks.
Comment 3 SecUpwN 2016-03-31 08:59:35 UTC
This bug appears to be still present in LibreOffice 5.1.1.3 10m0(Build:3).
Please tell me how to further proceed in order to find the real cause!
Comment 4 SecUpwN 2016-03-31 09:07:36 UTC
Created attachment 123981 [details]
Second gbtrace of crash
Comment 5 Buovjaga 2016-04-04 11:10:26 UTC
(In reply to SecUpwN from comment #4)
> Created attachment 123981 [details]
> Second gbtrace of crash

Note this error message:
Missing separate debuginfos, use: zypper install libreoffice-debuginfo-5.1.1.3-2.1.x86_64
Comment 6 SecUpwN 2016-04-05 19:48:57 UTC
(In reply to Buovjaga from comment #5)
> (In reply to SecUpwN from comment #4)
> > Created attachment 123981 [details]
> > Second gbtrace of crash
> 
> Note this error message:
> Missing separate debuginfos, use: zypper install
> libreoffice-debuginfo-5.1.1.3-2.1.x86_64

Zypper cannot find that package. Which repo to add for Tumbleweed?
Comment 7 Buovjaga 2016-04-07 05:42:57 UTC
(In reply to SecUpwN from comment #6)
> Zypper cannot find that package. Which repo to add for Tumbleweed?

It seems there is only a debuginfo repo for Leap: https://en.opensuse.org/Package_repositories

Debuginfo packages. Advanced users only.
Version: Leap 42.1 http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/
Comment 8 SecUpwN 2016-04-12 11:55:22 UTC
Created attachment 124277 [details]
Third gbtrace of crash

Installed http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/suse/x86_64/libreoffice-writer-debuginfo-5.0.2.2-1.2.x86_64.rpm but as it seems, the debugging info is still not getting found as I am on Tumbleweed. What to do now?
Comment 9 Buovjaga 2016-04-12 11:59:59 UTC
(In reply to SecUpwN from comment #8)
> Created attachment 124277 [details]
> Third gbtrace of crash
> 
> Installed
> http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/suse/
> x86_64/libreoffice-writer-debuginfo-5.0.2.2-1.2.x86_64.rpm but as it seems,
> the debugging info is still not getting found as I am on Tumbleweed. What to
> do now?

Perhaps best move would be to contact the person(s) responsible for packaging the debug stuff in openSUSE.
Comment 10 SecUpwN 2016-04-30 19:04:46 UTC
Recently did another upgrade and this bug seems to be resolved with LibreOffice 5.1.2.2.0 10m0(Build:2). Thank you to everyone who helped me here!
Comment 11 SecUpwN 2016-05-14 16:48:09 UTC
Re-opening this bug after having identified the real cause of the crashes: It seems to be the package libreoffice-kde4. If it is NOT installed, I can finally save PDFs and other documents. If it IS installed, LibreOffice crashes on saving.

Unfortunately, I cannot further investigate this Issue without the necessary debug packages installed. Please have a specific look at the libreoffice-kde4 package which causes the crashes and see if you can enhance it. Thank you.
Comment 12 Buovjaga 2016-05-14 19:29:42 UTC
Please contact the openSUSE LibreOffice packager to find out how to get the debug packages.
Comment 13 Ferry Toth 2017-01-26 13:13:30 UTC
I have found this in 5.2.4-rc2 (Ubuntu  PPA). I believe this has been fixed before, but has now regressed.

Actually the problem is not related to installing libreoffice-kde, but to using native file dialogs (i.e. in settings <General><Libreoffice dialogs> turned off with libreoffice-kde installed.

Unfortunately the problem does not happen with every document, making more difficult to reproduce.
Comment 14 Buovjaga 2017-01-26 15:06:38 UTC
Ferry: you are on Ubuntu, so you should be able to install the debug packages and get a backtrace of the crash https://wiki.documentfoundation.org/QA/BugReport/Debug_Information
Comment 15 Ferry Toth 2017-01-27 23:33:17 UTC
I had disabled native dialogs because of this. Now reenabled. I'll first try to find a doc that hit's this bug reproducibly hits this bug.
Comment 16 Julien Nabet 2018-01-29 16:49:46 UTC
Does it still happen with last stable LO version 5.4.4?
If yes, we need a step by step process to reproduce this.
Of course, a stacktrace would be useful.
Comment 17 Buovjaga 2018-01-29 17:04:19 UTC
Reverting status change as Xisco's automation would find it anyway.
Comment 18 Xisco Faulí 2018-02-23 18:39:33 UTC
*** Bug 115927 has been marked as a duplicate of this bug. ***
Comment 19 Katarina Behrens (CIB) 2018-02-23 22:56:06 UTC
No way I can reproduce this, export to PDF and every other filepicker WFM. I mean, I see where it is crashing but w/o hands-on debugging I can only guess why.

Is it specific to openSUSE, perhaps? KDE4 possibly? (I'm on KDE5)
Comment 20 Ferry Toth 2018-02-23 23:06:58 UTC
Nope. Kubuntu Artful (17.10) here. With LibO 5.4.5 (now in Artful) it seems to be even worse, just clicking file open button is enough.
Comment 21 Julien Nabet 2018-02-24 08:19:44 UTC
I got no proof but I'm not sure it's a dup.
There are more and more bugs related to kde
(see brand new tdf#115985 and tdf#115978)
Comment 22 Julien Nabet 2018-02-24 08:22:53 UTC
Sorry I hadn't finished..
What I meant is it's quite weird to see these kde-related bugs appearing all of the sudden.
Comment 23 Buovjaga 2018-02-24 09:02:50 UTC
(In reply to Ferry Toth from comment #20)
> Nope. Kubuntu Artful (17.10) here. With LibO 5.4.5 (now in Artful) it seems
> to be even worse, just clicking file open button is enough.

Please try to get a backtrace with the debug packages like I asked in comment 14. Otherwise it looks like this cannot be solved.
Comment 24 Xisco Faulí 2018-02-24 10:13:53 UTC
It seems all the crashes are happening on Kubuntu 17.10 ... Downloading Kubuntu...
Comment 25 Xisco Faulí 2018-02-24 11:10:00 UTC
I've downloaded Kubuntu 17.10 and LibreOffice crashes just trying to save the document.

Version: 5.4.5.1
Build ID: 1:5.4.5-0ubuntu0.17.10.1
CPU threads: 1; OS: unknown; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group

However, it doesn't crash with a debug build

Version: 6.1.0.0.alpha0+
Build ID: 4469c1d4061e8cb463469e60e5d87af5f9bf9636
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2018-02-12_22:52:26
Locale: en-US (en_US.UTF-8); Calc: group

nor in a daily build from today

Version: 6.1.0.0.alpha0+
Build ID: 0a46237093c1750ee69ddb6a365098dc1d06b758
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-02-21_21:56:55
Locale: en-US (en_US.UTF-8); Calc: group

Maybe the kubuntu packages are damaged ?
Comment 26 Xisco Faulí 2018-02-24 11:12:07 UTC
*** Bug 115971 has been marked as a duplicate of this bug. ***
Comment 27 Xisco Faulí 2018-02-24 11:12:38 UTC
*** Bug 115978 has been marked as a duplicate of this bug. ***
Comment 28 Philippe Hemmel 2018-02-24 11:57:36 UTC
With Kubuntu 17.10, LibreOffice 5.4.4 was ok, with the same ppa.

Using the LibreOffice file dialog boxes is a workaround.
Comment 29 Xisco Faulí 2018-02-25 01:43:57 UTC
I deleted LibreOffice completely using

sudo apt-get remove --purge libreoffice*

then, I downloaded and installed the latest version of LibreOffice from

https://www.libreoffice.org/download/download/

using

sudo dpkg -i *.deb

and it no longer crashes

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group

Could someone verify this ?
Comment 30 Xisco Faulí 2018-02-25 02:10:55 UTC
The problem is definitely related to libreoffice-kde and the file dialog. Clicking on Open or Save dialog crashes libreoffice.
OTOH, if the LibreOffice dialog are used ( Tools - Options - General - Use LibreOffice Dialogs ), it doesn't crash
Comment 31 Xisco Faulí 2018-02-25 02:24:37 UTC
Error in console:

Couldn't open /usr/share/kde4/config/kdebug.areas
LibreOffice(2968)/KSharedDataCache KSharedDataCache::Private::mapSharedMemory: Failed to establish shared memory mapping, will fallback to private memory -- memory usage will increase 
Couldn't open /usr/share/kde4/config/kdebug.areas
LibreOffice(2974)/KSharedDataCache KSharedDataCache::Private::mapSharedMemory: Failed to establish shared memory mapping, will fallback to private memory -- memory usage will increase 
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x4a01f2a
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x4a01f2a
LibreOffice(2974): Couldn't open "/home/xisco/.kde/cache-xisco-VirtualBox/ksycoca4" even though it is readable? Impossible. 
QFile::seek: IODevice is not open
LibreOffice(2974) KSycocaPrivate::checkVersion: Found version 0 , expecting version 243 or higher. 
QFile::seek: IODevice is not open
LibreOffice(2974) KSycocaPrivate::checkVersion: Found version 0 , expecting version 243 or higher. 
ERROR: Running KSycoca failed.
LibreOffice(2974): Couldn't open "/home/xisco/.kde/cache-xisco-VirtualBox/ksycoca4" even though it is readable? Impossible. 
QFile::seek: IODevice is not open
LibreOffice(2974) KSycocaPrivate::checkVersion: Found version 0 , expecting version 243 or higher. 
QFile::seek: IODevice is not open
LibreOffice(2974) KSycocaPrivate::checkVersion: Found version 0 , expecting version 243 or higher. 
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x4a03bdf
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x4a03bdf
Couldn't open /usr/share/kde4/config/kdebug.areas
LibreOffice(3006)/KSharedDataCache KSharedDataCache::Private::mapSharedMemory: Failed to establish shared memory mapping, will fallback to private memory -- memory usage will increase
Comment 32 Xisco Faulí 2018-02-25 02:33:39 UTC
WORKAROUND:
Go to Tools - Options - General and select enable 'LibreOffice Dialogs'
In LibreOffice 6.0, you need to be in experimental mode to see the option ( Tools - Options- Advanced - Enable experimental feature
Comment 33 Xisco Faulí 2018-02-25 02:42:41 UTC
@Olivier, I thought you might be interested in this one...
Comment 34 simhnna 2018-02-25 18:19:53 UTC
Created attachment 140137 [details]
crash backtrace on kubuntu 17.10

This happens on the notebook of my wife. Fully updated, with clean profile, workaround confirmed and libreoffice-kde installed.

Hope it helps
Comment 35 Xisco Faulí 2018-02-27 14:46:29 UTC
*** Bug 116064 has been marked as a duplicate of this bug. ***
Comment 36 Philippe Hemmel 2018-03-01 02:23:37 UTC
For me the latest update of the ppa (yesterday) fixes the crash with the kde files dialog box. 
Kubuntu 17.10
Version: 5.4.5.1
Build ID: 1:5.4.5-0ubuntu0.17.10.4
Threads CPU : 4; OS : Linux 4.13; UI Render : par défaut; VCL : kde4; 
Locale : fr-FR (fr_FR.UTF-8); Calc: single

Thanks !
Comment 37 xghost 2018-03-01 03:22:55 UTC
I updated yesterday and the issue I originally reported[1] appears to have been fixed. Version information is below:


  Version: 5.4.5.1
  Build ID: 1:5.4.5-0ubuntu0.17.10.4
  CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
  Locale: en-US (en_US.UTF-8); Calc: group


Hope future testing is able to catch things like these before they get released. Thanks a lot, everyone!



[1] https://bugs.documentfoundation.org/show_bug.cgi?id=115927
Comment 38 Buovjaga 2018-03-01 08:35:41 UTC
Great to hear! Closing.
Comment 39 Xisco Faulí 2018-03-01 08:59:29 UTC
Confirm it's fixed in

Version: 5.4.5.1
Build ID: 1:5.4.5-0ubuntu0.17.10.4
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group

Looking at the changelog ( https://wiki.documentfoundation.org/Releases/5.4.5/RC1 ) nothing is related to KDE at first glance.
I believe the issue was on KDE's side rather than on our side... anyway, happy to hear it's fixed.
Comment 40 Olivier Tilloy 2018-03-01 09:26:48 UTC
The issue was not in KDE, but in the apparmor profiles blocking the opening of the KDE file dialog box. Those profiles were accidentally enabled in 1:5.4.5-0ubuntu0.17.10.1, and were disabled again in 1:5.4.5-0ubuntu0.17.10.4. See https://launchpad.net/bugs/1750087 for details.
Comment 42 Buovjaga 2018-03-01 09:28:32 UTC
Thanks, Olivier. Tweaking status accordingly.
Comment 43 Julien Nabet 2018-03-03 08:04:56 UTC
*** Bug 116151 has been marked as a duplicate of this bug. ***
Comment 44 Aron Budea 2018-03-07 17:39:10 UTC
*** Bug 116276 has been marked as a duplicate of this bug. ***
Comment 45 Xisco Faulí 2018-03-21 12:43:41 UTC
*** Bug 116508 has been marked as a duplicate of this bug. ***