Bug 118034 - Import of xslx chart has wrong position and wrong precision of trendline equation
Summary: Import of xslx chart has wrong position and wrong precision of trendline equa...
Status: RESOLVED DUPLICATE of bug 55204
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2018-06-06 13:20 UTC by Regina Henschel
Modified: 2021-05-12 09:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original file (22.86 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-06-06 13:20 UTC, Regina Henschel
Details
Screenshot of chart in Excel (19.77 KB, image/png)
2018-06-06 13:20 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-06-06 13:20:20 UTC
Created attachment 142562 [details]
Original file

Open attached document. Refresh chart, in case it is not done automatically for you. Compare it with the screenshot of Excel 365. Notice, that the position of the trendline equation box is wrong and that the numbers inside the equation have wrong precision. Position and number format has been set explicitly in Excel.
Comment 1 Regina Henschel 2018-06-06 13:20:49 UTC
Created attachment 142563 [details]
Screenshot of chart in Excel
Comment 2 Jacques Guilleron 2018-06-07 05:27:41 UTC
Hi Regina,

I reproduce with
LO 6.0.4.2 Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
and
LO 6.2.0.0.alpha0+ Build ID: 7530424771c84d50f1e7e9ec5eba0bffc91d655a
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-06_05:38:42
Locale: fr-FR (fr_FR); Calc: CL
Comment 3 Xisco Faulí 2018-06-08 11:08:06 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 himajin100000 2018-06-12 22:09:42 UTC
Reproduced.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 951e7a43e62c22d4c7f7fb18de738d86ab3c2251
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-04_04:31:29
Locale: ja-JP (ja_JP); Calc: CL
====
https://opengrok.libreoffice.org/xref/core/chart2/source/view/charttypes/VSeriesPlotter.cxx?r=0c195667#1321

1. With which UI should I use to change this property like 2(= ZF_STANDARD + 2)?

cf:
https://opengrok.libreoffice.org/xref/core/svl/source/numbers/zforlist.cxx?r=8d77bc56#97

2. With which UI should I use to change these property?

https://opengrok.libreoffice.org/xref/core/chart2/source/view/main/VLegend.cxx?r=bdf5a7b5#1026

https://opengrok.libreoffice.org/xref/core/chart2/source/view/main/VLegend.cxx?r=bdf5a7b5#1030

if these property are true , and LegendPosition_LINE_END, for example ,
rOutAvailableSpace will be passed to lcl_calculatePositionAndRemainingSpace as reference and will be changed inside the function. This rOutAvailableSpace will be used to decide where to place plot-area.

honestly, this is what I came out of my brain when I was thinking about tdf#115630

3. For these properties, what xml elements or attributes should we use in ODF?
Comment 5 himajin100000 2018-06-12 22:11:00 UTC
typo:

what I came out => what came out
Comment 6 himajin100000 2018-06-12 23:48:53 UTC
I was writing about legend, but for equations, I think I needed to look at  aDefaultPos

https://opengrok.libreoffice.org/xref/core/chart2/source/view/charttypes/VSeriesPlotter.cxx?r=0c195667#1275
Comment 7 himajin100000 2018-06-13 11:25:28 UTC
https://opengrok.libreoffice.org/xref/core/chart2/source/view/main/VLegend.cxx#700

Oops, forgot to note:
https://opengrok.libreoffice.org/xref/core/chart2/source/view/main/VLegend.cxx?r=bdf5a7b5#702

in this switch statement, aResult needs to be modified to position the legend as expected.

Another typo:
With which UI => Which UI
Comment 8 Timur 2021-05-12 09:18:03 UTC
I don't know why it's only See Also, but looks duplicate to me.

*** This bug has been marked as a duplicate of bug 55204 ***