Bug 119185 - FILEOPEN: the second page overlaps the first page
Summary: FILEOPEN: the second page overlaps the first page
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2018-08-09 20:32 UTC by Xisco Faulí
Modified: 2019-10-08 16:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the document in Writer (223.91 KB, image/png)
2019-10-08 11:44 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-08-09 20:32:25 UTC
Steps to reproduce:
1. Open 97410 from bug 77486

->Observed behaviour: The second page is displayed on the first page

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: c86a47a9d3debbc7e8ee6247f573e7f98c611f19
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-08-09 20:32:39 UTC
Steps to reproduce:
1. Open attachment 97410 [details] from bug 77486
Comment 2 Xisco Faulí 2018-08-09 20:35:10 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=49ddaad2f3ba4e17e1e41e94824fb94468d2b680

author	Justin Luth <justin_luth@sil.org>	2018-07-25 16:33:47 +0300
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-07-27 09:45:54 +0200
commit	49ddaad2f3ba4e17e1e41e94824fb94468d2b680 (patch)
tree	6f55c641dbf0b04d91cd8d4e4eeff1a312462116
parent	8af5cb7870032fbdb50f0b3ad6d855e488af4b99 (diff)
tdf#117988 writerfilter: IgnoreTabsAndBlanksForLineCalculation

Bisected with: bibisect-linux64-6.2

Adding Cc: to Justin Luth
Comment 3 Justin L 2018-08-10 16:23:27 UTC
The second page - which is one huge textbox - is displayed overtop of the first page. The same thing can be achieved interactively in 6.0.6 by reducing the size of the frame.

This is not good enough evidence that the identified patch is problematic. It looks like this has just exposed other existing problems with anchoring or wrapping.
Comment 4 Justin L 2018-09-04 08:51:39 UTC
Probably not related to floating frame bug 78671, but the result sounds very similar. Same thing with floating table bug 118794.
Comment 5 NISZ LibreOffice Team 2019-10-08 11:44:03 UTC
Created attachment 154829 [details]
Screenshot of the document in Writer

Looks good in: 

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 25ca657f8d0f1febaf0d5984bc862f3072ad197b
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

Reverting the bibisected commit probably solved this:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=202bee1a819de7b1e8c75dd863c4154f66419400
Comment 6 NISZ LibreOffice Team 2019-10-08 15:04:19 UTC
(In reply to NISZ LibreOffice Team from comment #5)
> Created attachment 154829 [details]
> Screenshot of the document in Writer
> 
> Looks good in: 
> 
> Version: 6.4.0.0.alpha0+ (x64)
> Build ID: 25ca657f8d0f1febaf0d5984bc862f3072ad197b
> CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
> Locale: hu-HU (hu_HU); UI-Language: en-US
> Calc: threaded
> 
> Reverting the bibisected commit probably solved this:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=202bee1a819de7b1e8c75dd863c4154f66419400

Verified with bibisect-win64-6.4 indeed this commit solved it. 
Let's mark this as fixed, thanks Justin!
Comment 7 Justin L 2019-10-08 16:08:57 UTC
(In reply to NISZ LibreOffice Team from comment #6)
> Verified with bibisect-win64-6.4 indeed this commit solved it. 
It is not fixed, the real problem is just hidden again.