Download it now!
Bug 119571 - When tracking changes, paragraph joining does not update the style of the text after the deleted paragraph break until show changes is toggled (also it doesn't update the style of the deleted paragraphs)
Summary: When tracking changes, paragraph joining does not update the style of the tex...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.4.0
Keywords:
: 89732 103638 (view as bug list)
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2018-08-28 17:55 UTC by László Németh
Modified: 2019-06-24 20:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
simple test file with two paragraphs (8.56 KB, application/vnd.oasis.opendocument.text)
2018-08-28 17:58 UTC, László Németh
Details
comparison of style update of the deleted paragraphs (44.03 KB, image/png)
2018-11-23 10:30 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description László Németh 2018-08-28 17:55:49 UTC
Description:
Partial paragraph deletion at end of a paragraph including the paragraph break results paragraph joining, when the text of the next paragraph changes its style to the style of the partially deleted paragraph, except in the case of change tracking with 'Show changes' mode, when the style changes is invisible after extra text addition, too. Only document saving or switching to the "don't show changes" updates the view of the paragraph text.

Steps to Reproduce:
Delete the end of the first paragraph of the attached text document in Show changes.

Actual Results:
Missing style update of the joined text after the deleted paragraph break.

Expected Results:
Heading 1 style on the text of the (originally second) paragraph.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 László Németh 2018-08-28 17:58:46 UTC
Created attachment 144521 [details]
simple test file with two paragraphs
Comment 2 Commit Notification 2018-09-05 05:49:38 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1bbbe57dfc0b43d6b5444798d77dcdf5e4e76e49

tdf#119571 change tracking: show layout changes at paragraph join

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 László Németh 2018-11-23 10:30:04 UTC
Created attachment 146965 [details]
comparison of style update of the deleted paragraphs
Comment 4 László Németh 2019-01-30 10:11:10 UTC
*** Bug 103638 has been marked as a duplicate of this bug. ***
Comment 5 László Németh 2019-05-15 07:58:46 UTC
*** Bug 89732 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2019-06-24 20:22:06 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/705b728d26b4480ec6b51d9fe1362a0154ea9bf9%5E%21

tdf#119571 fix style & numbering at tracked deletion

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.