Bug 120297 - FILESAVE PPTX: Borders Added to Textbox with multiple columns on Roundtrip
Summary: FILESAVE PPTX: Borders Added to Textbox with multiple columns on Roundtrip
Status: VERIFIED DUPLICATE of bug 118458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pptx
Depends on:
Blocks: PPTX-Tables
  Show dependency treegraph
 
Reported: 2018-10-04 01:57 UTC by Luke
Modified: 2021-06-10 12:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How a multi column textbox roundtriped in Impress looks in PowerPoint (135.25 KB, image/png)
2018-10-04 01:57 UTC, Luke
Details
The example file and its Impress-saved version in PP (72.44 KB, image/png)
2021-06-09 12:05 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2018-10-04 01:57:19 UTC
Created attachment 145363 [details]
How a multi column textbox roundtriped in Impress looks in PowerPoint

Textbox with PPTX with columns are now converted to tables. When those tables are saved, they are not borderless, so lines appear around your text when opened in PowerPoint, but not Impress.

Steps to reproduce:

1. Open a PPTX with multiple columns in Impress, such as attachment 114222 [details]
2. Save as PPTX
3. Open in PowerPoint 

Expected results:
No borders like Impress

Actual Results
There are borders around the columns
Comment 1 Timur 2018-10-04 07:48:08 UTC Comment hidden (obsolete)
Comment 2 Luke 2018-10-04 16:53:16 UTC
Previous comment should read: 
Note: due to Bug 120028 this can only be tested after that change.
Comment 3 Xisco Faulí 2018-10-16 17:19:50 UTC
So, the borders were introduced after http://cgit.freedesktop.org/libreoffice/core/commit/?id=aef569ed83a3ccc02639e5b2a1c7cc131ba262fc, before that, the two columns were displayed on the same columns without border. I don't know if we should consider this a regression... Miklos ?
Comment 4 Miklos Vajna 2018-10-17 07:33:04 UTC
Nah, it's just a bug. :-) Before: table borders were missing as the whole table was missing. After: formatting of the border needs fixing.

But sure, it needs fixing, I'm not arguing there.
Comment 5 QA Administrators 2021-01-08 04:19:18 UTC Comment hidden (obsolete)
Comment 6 Timur 2021-05-27 10:54:33 UTC
Repro 7.2+ for PPTX. PPT is OK.
Comment 7 NISZ LibreOffice Team 2021-06-09 12:05:42 UTC
Created attachment 172731 [details]
The example file and its Impress-saved version in PP

Looks good now when saved with todays nightly:

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 31ed81ea71a20ec119805f66a42f99b3f80d2dc5
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: el-GR (hu_HU); UI: en-US
Calc: CL

Table is gone with its border after bug 118458 was fixed.
Comment 8 NISZ LibreOffice Team 2021-06-09 12:05:59 UTC

*** This bug has been marked as a duplicate of bug 118458 ***
Comment 9 NISZ LibreOffice Team 2021-06-10 12:48:42 UTC
Verified in:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: aa9cb8e14749e7fb7a83b55a2bb095501f731a18
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded