Bug 121607 - Crash when closing a document (being the only active) while being prompted for data source password
Summary: Crash when closing a document (being the only active) while being prompted fo...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: All All
: highest critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0.1 target:6.3.0 target:6.1.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-11-21 21:01 UTC by Cor Nouws
Modified: 2018-11-27 11:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["SfxBindings::NextJob_Impl(Timer const *)","SfxApplication::GetFilterMatcher()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2018-11-21 21:01:00 UTC
use the test kit from bug 121606

1. place a and b in same location
2. add b as data source (Tools > Options etc )
3. open c. - make sure that is the only active document.
  ( prompt for password pops up immediately )
4. put focus in document and click Ctrl+W to close
  > Crash - obviously a handle misses/link gets broken?
Comment 1 Cor Nouws 2018-11-21 21:02:30 UTC
two crash report signatures:
 cbb02290-07ff-4a51-8517-f234a5f18550
 6142fdfe-a456-4dc6-962e-d9f7deee5d77
Comment 2 Xisco Faulí 2018-11-21 23:22:11 UTC
I assume the problem comes when the user can interact with other dialogs different than the login dialog while it's displayed.

Steps to reproduce:
1. Open Writer
2. Register the database
3. Open the .ODT document
4. Once the login dialog is prompted, close LibreOffice
> Crash

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9c0684c9efca25ab9a39002b34328fafc30cc8bd

author	Caolán McNamara <caolanm@redhat.com>	2018-04-11 15:24:46 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-04-11 17:43:26 +0200
commit	9c0684c9efca25ab9a39002b34328fafc30cc8bd (patch)
tree	42b0ff4a8b34bd9464e8bc8beea25b05c16e14eb
parent	2ca4b505b25e13c9f422c28252f5b7533b8e3270 (diff)
weld LoginDialog

Bisected with: bibisect-linux64-6.1

Adding Cc: to Caolán McNamara
Comment 3 Caolán McNamara 2018-11-22 09:52:10 UTC
seems to boil down to missing explicit parent dialog
Comment 4 Caolán McNamara 2018-11-22 11:18:57 UTC
though there is the other preexisting problem that there are multiple timers which kick in while the password dialog is open which trigger other password dialogs so you get dialog on top of dialog
Comment 5 Xisco Faulí 2018-11-22 12:21:44 UTC
(In reply to Caolán McNamara from comment #4)
> though there is the other preexisting problem that there are multiple timers
> which kick in while the password dialog is open which trigger other password
> dialogs so you get dialog on top of dialog

I guess you mean bug 119610
Comment 6 Caolán McNamara 2018-11-22 13:04:40 UTC
not quite, from the UI perspective the problem is that there ends up with multiple password dialogs at the same time, rather than one after another. So that's the bit I want to fix, which probably leaves the bug 119610 unchanged
Comment 7 Commit Notification 2018-11-22 13:31:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/e64fab3fa8f82fc3a0bedbf204a59884e80ecf11%5E%21

Resolves: tdf#121607 set parent for password dialogs

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-11-22 14:50:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/17983e15c468d2153a58a20ad6ad51553d087472%5E%21

tdf#121607 defer other requests until password dialog is dismissed

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-11-22 14:50:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/278a3910fc27f6356bdd6c913fe0717e9c190ad9%5E%21

Resolves: tdf#121607 set parent for password dialogs

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-11-22 15:11:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/205aeffda1a29865576fb865f23dfb6761ebfab1%5E%21

tdf#121607 defer other requests until password dialog is dismissed

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Cor Nouws 2018-11-24 19:35:21 UTC
verified in Version: 6.3.0.0.alpha0+
Build ID: 0742d5d3ec630c5237eb2bee28d926fb90bef706
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded

Unable to make LibreOffice crash - it is impossible to put the focus in the file if the password popup is there.

thanks for fixing!
Comment 12 Commit Notification 2018-11-27 11:44:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/cbf3e0d241f9fa3a9ffddd52acdbe03958be83da%5E%21

tdf#121607 defer other requests until password dialog is dismissed

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-11-27 11:44:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/eb99f1174950e7a9752830264fc393d533d61891%5E%21

Resolves: tdf#121607 set parent for password dialogs

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.