Download it now!
Bug 121932 - Please make default numbering to be user-definable!
Summary: Please make default numbering to be user-definable!
Status: RESOLVED DUPLICATE of bug 69724
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2018-12-06 02:20 UTC by Andy
Modified: 2018-12-11 13:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2018-12-06 02:20:49 UTC
Description:
Would you please allow users to set the default style for numbering / bullets? - especially under the positioning tab. As it is now, I have to redefine every instance of numbering that I create. I wish I could just highlight a list, click on numbering, and it would be formatted the way I want.

Steps to Reproduce:
1. Create a recipe with a set of directions. 
2. Highlight the set of directions, and click on Numbering.
3. Proceed to re-position the numbering.

Actual Results:
The numbering, as set by default and as it appears when the Numbering button is clicked, is not formatted nor positioned as I would wish.

Expected Results:
I wish I could set the default numbering in LO, so that whenever I click on the Numbering button, the format and position that I want is applied.


Reproducible: Always


User Profile Reset: No



Additional Info:
An opportunity to set / reset / change the default numbering should be provided. This could be accessed through the Bullets/Numbering dialogue, or through the Options menu item, or through Format/Bullets&Numbering.
Comment 1 Dieter 2018-12-06 08:57:18 UTC
Thank you for reporting the bug. I assume you are familiar with customizing list styles. So your proposal is, that the "Toggle Numbered List" button and the "Toggle Bulleted List" button are connectd with such a default style?

AFIK liste created with these buttons don't have a certain style also "List 1" style in highlighted in the list style at the sidebar (see bug 120802).

There are some other bugs with this topic (bug 57337, bug 69724, bug 92619 and many more.
Comment 2 Heiko Tietze 2018-12-10 15:31:24 UTC
Andy, please comment on c2. I think your request is a duplicate. Besides that we made a proposal for the dialog at https://design.blog.documentfoundation.org/2017/10/28/impress-lists/ that is tracked in bug 120905 and bug 56480 (sorry for the bunch of references).
Comment 3 Andy 2018-12-10 16:49:41 UTC
Hello Heiko,
My suggestion is not addressed in any of the three references you listed.
If I may, I would like to describe my idea again.

=> Current Process:
1- Open a new Writer document.
2- Type a few lines of text, such as a list.
3- Highlight all text.
4- Click on the Numbering button in the toolbar.

Somewhere in the LO programming there is a default style for numbering which is applied when the Numbering button is clicked. If I want the numbering style to be different, I have to click on the Numbering down arrow, click on More Numbering, and manually define the numbering style I want for this document.

After I've done that, for any other new documents:
5- Open a new Writer document.
6- Type a few lines of text, such as a list.
7- Highlight all text.
8- Click on the Numbering button on the toolbar.

In this new document, the same original default numbering style that came with the LO download, is applied to the second document (and any others to follow).Again, if I want the numbering style to be different for this new document, I have to manually set the numbering style. I have to change this numbering style away from the system default every time I apply it to a new document.

=> My Suggestion:
1- Open LO Writer.
2- Click on Tools, then Options (or click on Format, then Bullets/Numbering).
3- Change the system default numbering style to be what I want, especially the Postion tab (Aligned at, alignment, followed by, tab stop at, indent at). 
4- Save this as the new system default.

5- Open a new Writer document.
6- Type a few lines of text, such as a list.
7- Highlight all text.
8- Click on the Numbering button on the toolbar.

Viola! The default numbering style (including position) is the one I want! - and it's the one I want for every new document after that too. There's no need to change the numbering style every time I'm working in a new document, because I am able to change the system default, and so it puts the style I want into every document.

I hope this helps clarify my suggestion.
Thanks for your interest!
Andy
Comment 4 V Stuart Foote 2018-12-10 17:21:16 UTC
Sorry, this is an exact duplicate of bug 69724

As there, currently changes to default number list for reuse requires creation of a new template document.

Enhancement is ability to manipulate default numbering (and outline, list, and bullet) style  without having to go through template creation/modification. 

Would require additions beyond template defaults be written as style stanzas into per user profile, or possibly OS configuration/registry for multi-user.

*** This bug has been marked as a duplicate of bug 69724 ***
Comment 5 Heiko Tietze 2018-12-11 13:09:38 UTC
(In reply to Andy from comment #3)
> If I may, I would like to describe my idea again.

Thanks for the detailed explanation. Let's phrase it like this: "I want to click on the list button and always get a list with Cyrillic letters" (I chose something that is not in the presets).

Changing the default style is a no-go. And as long you cannot add own list styles you have to go via the styles sidebar/menu/dialog etc. On top of the sidebar deck there is a list of toggle buttons where the fifth is for lists. Create your style as known from paragraph or characters and assign it to some paragraph style (use the filter at the bottom of the paragraph styles deck to find lists). If you apply this list style to "List" it will be shown per click on the list on/off button. It's a little bit cumbersome, but that's what the other tickets are meant for.
Comment 6 Dieter 2018-12-11 13:30:38 UTC
(In reply to Heiko Tietze from comment #5)
> Changing the default style is a no-go.

I don't understand this, because you can change - for example - the default paragraph style. I assume, that you get the default bullet style or default list style, if you press the "toggled-numbered-list"-button or "toggled-bulleted-list"-button. But you can't see that default style in the sidebar. this is all very confusing to me.
Comment 7 Heiko Tietze 2018-12-11 13:34:27 UTC
(In reply to Dieter Praas from comment #6)
> (In reply to Heiko Tietze from comment #5)
> > Changing the default style is a no-go.
> 
> I don't understand this...

If we go with a couple of system defaults and a freely defined list of own styles we don't need to think about resetting. Modification of the Default paragraph style is not recommended and should be prevented actually.