Download it now!
Bug 122303 - File>New>Templates... is NOT the same as New > FROM Templates (wording issue)
Summary: File>New>Templates... is NOT the same as New > FROM Templates (wording issue)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 123014 (view as bug list)
Depends on:
Blocks: Main-Menu Templates
  Show dependency treegraph
 
Reported: 2018-12-24 09:58 UTC by Mark Palmos
Modified: 2019-02-07 09:54 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Palmos 2018-12-24 09:58:28 UTC
Hi
I could not find a way to create a new file based on a template because each time I went to FILE>NEW I did not see a way to do this... I did not want to create a NEW TEMPLATE, I wanted to create a new file BASED ON a Template... 

The wording should really say New>From Template
Then it would be clear that you are creating a document FROM the template, and are not wanting to create a "new template"!

Thanks,
Mark.
Comment 1 Roman Kuznetsov 2018-12-24 12:20:08 UTC
There is menu item File->New->Templates, and then you can select any template from existings and create file BASED ON it.

Or may be you mean something else?
Comment 2 V Stuart Foote 2018-12-24 16:42:44 UTC
Changing the menu labeling to read "From templates" would not improve anything and would actually confuse things when translated for localization.

Menu labeling as "Templates..."  brings up the "Templates" dialog, launched anywhere in the UI with the shortcut <Ctrl><Shift>+N.

The same dialog is launched from the StartCenter -> Templates droplist menu "Manage templates"

This dialog is the consistent way we select templates for use in a new document, as well as to manage templates per user profile.
Comment 3 Mark Palmos 2018-12-24 16:59:07 UTC
The current name is confusing.
You are not creating what the menu says you are creating.

You are not creating a New>Template !!!
You are creating a new document FROM a template

How is this not obvious.
The first several times I saw this, when trying to find a way to create a new file from a template, I disregarded it BECAUSE it was clearly for creating a new template.

You know this product already, but people like myself, who are new to it, have one thing you will never have, a fresh set of eyes.

To a newcomer, this is poorly named and is confusing.
Comment 4 V Stuart Foote 2018-12-25 00:35:37 UTC
No, unless you change the template by selection from the Templates dialog (Templates...) you will use the -default- Standard template defined for the module type.

Naming its entry on the New menu anything other than "Templates...", e.g. "From Template", makes no sense as using the Templates dialog is always going to be necessary--the dialog is the only means of changing/selecting template.

Its a dialog, and the dialog name with ellipsis appended is how dialogs are annotated in menus.  

IMHO => NAB and WF
Comment 5 Dieter 2018-12-26 06:50:55 UTC
I agree to Mark. "Template" is misleading, because the selection is about creating new file and not creating new templates (what you - of course - also can do, if you open templates).
I think, the problem is, that "Templates" doesn't shows the option to create a new template or to create a new document from a template, but only opens the dialog called "Templates". But that's not clear from the wording.
Comment 6 Mark Palmos 2018-12-26 21:40:13 UTC
Thanks Dieter.
It is not clear at the moment, and is confusing.
You are not creating a New Template, which is what it seems you are doing.
Mark.
Comment 7 Cor Nouws 2019-01-09 19:10:23 UTC
wfm, IMO
Comment 8 Heiko Tietze 2019-01-10 10:58:34 UTC
We discussed the idea in the design meeting and came to the conclusion that New > From Template wouldn't make the situation more clear. Personally, I would just remove this menu item.
Comment 9 Dieter 2019-01-28 13:04:27 UTC
*** Bug 123014 has been marked as a duplicate of this bug. ***