Bug 123343 - PDF export should ask to save under a new filename if the old file is locked, instead of discarding output
Summary: PDF export should ask to save under a new filename if the old file is locked,...
Status: RESOLVED DUPLICATE of bug 53530
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-11 13:08 UTC by Daniel Grigoras
Modified: 2019-02-13 13:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Grigoras 2019-02-11 13:08:44 UTC
Description:
Whenever I export to PDF and I inadvertently have the older PDF version open, LibreOffice, instead of asking to save under a new name just says that the PDF is locked and produces no PDF.
Can you imagine how frustrating this is when you export a 6000 page PDF and after an hour of waiting it tells you that the older PDF you wanted to overwrite is locked and instead of asking to save under a new name it just discards all that one hour's worth of output work?
If the PDF you want to overwrite is locked/open in another application, LibreOffice should just ask to save the output under a new name.

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 V Stuart Foote 2019-02-11 16:28:03 UTC
It does. In Windows, either the LibreOffice file dialog, or the System file dialog

Only issue, is if you Save-as/Export and then *ignore* the "<filename>.pdf already exists. Do you want to replace it?" and attempt to overwrite the locked file open in another app. But that is expected behavior (what would the other app then do?).

=> WFM & NAB
Comment 2 Daniel Grigoras 2019-02-12 21:01:02 UTC
(In reply to V Stuart Foote from comment #1)
> and attempt to overwrite the locked file open in another app. But that is expected behavior (what would the other app then do?).

What? Are you serious? Sadly, I think you prefer closing an enhancement request rather than admit an improvement needed.

Let me ask you this: why does Writer offer to open a locked file as a copy in order to allow editing of read only files, but does not offer to save a locked file under a different name?
Comment 3 Timur 2019-02-13 12:45:20 UTC
Dupe of Bug 53530. Please search before reporting.

*** This bug has been marked as a duplicate of bug 53530 ***