Download it now!
Bug 123989 - Menus open upward and thus get truncated in ChromeOS
Summary: Menus open upward and thus get truncated in ChromeOS
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 124875 (view as bug list)
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2019-03-11 05:07 UTC by Alex Tatistcheff
Modified: 2019-08-18 18:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of menu (107.24 KB, image/png)
2019-03-11 05:08 UTC, Alex Tatistcheff
Details
Screenshot #2 (83.16 KB, image/png)
2019-03-11 05:09 UTC, Alex Tatistcheff
Details
Screenshot (126.25 KB, image/png)
2019-08-17 15:16 UTC, Alex Tatistcheff
Details
standalone glade menudemo (19.02 KB, application/x-designer)
2019-08-18 18:40 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Tatistcheff 2019-03-11 05:07:09 UTC
Description:
When LibreOffice is installed on a Samsung Chromebook using the built-in Linux subsystem (not crouton), most of the menus do not display correctly.  They appear to be flying up from the menu bar instead of down.  Thus only the last item on most of the drop down menus is available. Only the shorter menus seem to display correctly like Help, Window, etc.

Steps to Reproduce:
1. Install Libreoffice on Chromebook with the command sudo apt install libreoffice libreoffice-gtk3
2. Open any Libreoffice app (Writer, Calc, etc.)
3. Try to use the File, Edit, View, Insert, Format, etc. menus

Actual Results:
Menus do not display correctly (or at all) drop-down menus actually drop up.

Expected Results:
Menus should drop down and be usable


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 5.2.7.2
Build ID: 1:5.2.7-1+deb9u5
CPU Threads: 6; OS Version: Linux 4.19; UI Render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Alex Tatistcheff 2019-03-11 05:08:30 UTC
Created attachment 149871 [details]
Screenshot of menu
Comment 2 Alex Tatistcheff 2019-03-11 05:09:05 UTC
Created attachment 149872 [details]
Screenshot #2
Comment 3 Xisco Faulí 2019-04-16 09:04:13 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 Alex Tatistcheff 2019-04-16 13:56:55 UTC
The behavior is due to the Chromebook's default resolution.  LibreOffice does not respond gracefully when a drop-down menu will not fit on the screen.  Instead of allowing the menu to scroll it simply reverses the items and sends them up off the edge of the screen.  Instead of the menu being mostly visible (with some of it spilling out the bottom of the screen) it is now completely unusable.  

There is a workaround which is to set the display resolution much higher which will allow menus to fit on the screen.  This makes the text on the screen quite small on a laptop display but the menus will display correctly at higher resolution.  

I don't know if it's something with the menu display libraries on the Chromebook Linux version or it's universal.  Basically, if there is a minimum display resolution required by LibreOffice then that would explain this issue.  I'm not sure if there is a minimum or if the capability to scroll within the menu can be implemented.  

As a side note, the issue exacerbating this on LibreOffice is the number of items in each of the drop-down menus.  It seems like LibreOffice has longer drop-down menus than many other comparable apps.  If they could be grouped with sub-menus this would reduce the height and help with this resolution limitation.

If you still want me to confirm this exists in newer versions let me know.  I believe I did try LibreOffice 6 when I first opened this bug and saw the same behavior.

Thanks!
Comment 5 Buovjaga 2019-08-13 11:52:14 UTC
You could try with 6.3 as an appimage: https://libreoffice.soluzioniopen.com/
Comment 6 Buovjaga 2019-08-17 14:59:36 UTC
*** Bug 124875 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2019-08-17 15:01:55 UTC
Please try launching from the command line with
SAL_USE_VCLPLUGIN=gen libreoffice
Comment 8 Alex Tatistcheff 2019-08-17 15:16:32 UTC
Created attachment 153464 [details]
Screenshot
Comment 9 Alex Tatistcheff 2019-08-17 15:29:10 UTC
(In reply to Buovjaga from comment #7)
> Please try launching from the command line with
> SAL_USE_VCLPLUGIN=gen libreoffice

Using the recommended command line the app now loads and the menus are visible - which is good.  The menu text and buttons are very small however even on the 14 inch laptop screen.  I attached a screenshot showing that the longest menus now go about half way down the screen.  I think the button and menu sizes could be increased a bit to make them more readable and still fit the menus on the screen.  The workaround of manually setting the display resolution to allow the menus to work still seems like the best route.  It looks to me like 1920x1080 is the sweet spot.  Going much lower than that will cause menus to start displaying incorrectly.

The native resolution of my HP Chromebook is 1536x864.  In my perfect world, Libreoffice would function normally at that resolution.
Comment 10 Buovjaga 2019-08-17 15:35:19 UTC
(In reply to Alex Tatistcheff from comment #8)
> Created attachment 153464 [details]
> Screenshot

So it works beautifully with generic vcl backend. This seems like a variant of bug 113713 (behaviour that is out of our control), but more problematic.

Caolán: should this be closed?
Comment 11 Caolán McNamara 2019-08-18 18:40:10 UTC
Created attachment 153491 [details]
standalone glade menudemo

execute as...

glade-previewer -f menudemo.ui
Comment 12 Caolán McNamara 2019-08-18 18:41:24 UTC
I imagine that attached .ui shows a similar problem under the same circumstances and its just how the native gtk menus work. Not saying there isn't a bug there, just that its not our bug