Bug Hunting Session
Bug 125409 - Image mode not properly set when exporting ODP to PPTX
Summary: Image mode not properly set when exporting ODP to PPTX
Status: RESOLVED DUPLICATE of bug 127901
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-21 07:58 UTC by Nicolas Christener
Modified: 2019-10-01 15:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Image mode works in ODP version of the file (79.47 KB, application/vnd.oasis.opendocument.presentation)
2019-05-21 07:59 UTC, Nicolas Christener
Details
Image mode doesn't works in PPTX version of the file (87.50 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-05-21 07:59 UTC, Nicolas Christener
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Christener 2019-05-21 07:58:40 UTC
Description:
LibreOffice has a function to set "Color modes" on pictures such as "Grayscale" or "Black/White", etc.

Using "Grayscale" on a picture and saving it as PPTX then open the PPTX in LibreOffice again seems not to work. I can't say if it's the export or the import which does not work.

Steps to Reproduce:
1. Create a presentation with a picture in Impress
2. Set the "Color mode" option of the picture to "Grayscale"
3. Save the presentation as PPTX
4. Open the presentation in LibreOffice

Actual Results:
The picture is shown with all colors.

Expected Results:
The picture should be displayed in "Grayscale" mode.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Nicolas Christener 2019-05-21 07:59:20 UTC
Created attachment 151547 [details]
Image mode works in ODP version of the file
Comment 2 Nicolas Christener 2019-05-21 07:59:45 UTC
Created attachment 151548 [details]
Image mode doesn't works in PPTX version of the file
Comment 3 Xisco Faulí 2019-05-21 08:43:08 UTC
Reproduced in

Version: 6.3.0.0.alpha1+
Build ID: 9c7fac47aacb0877c7d212217089a680400c1377
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

@Tamás, since you fixed bug 125346 and bug 125360 recently, I thought you might be interested in this issue...
Comment 4 Xisco Faulí 2019-10-01 15:40:33 UTC
Working on it.
Closing as duplicate of bug 127901

*** This bug has been marked as a duplicate of bug 127901 ***