Download it now!
Bug 125673 - KDE5: Calc sheet tab's context menu has unexpected highlighting
Summary: KDE5: Calc sheet tab's context menu has unexpected highlighting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords:
: 125745 125927 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-06-04 06:05 UTC by Roman Kuznetsov
Modified: 2019-06-26 08:48 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot for Writer (63.05 KB, image/png)
2019-06-04 07:28 UTC, Michael Weghorn
Details
Video showing slow highlighting. (173.76 KB, video/mp4)
2019-06-19 00:07 UTC, Ongun Kanat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-06-04 06:05:35 UTC
Description:
Calc sheet tab's context menu has unexpected highlighting 

Steps to Reproduce:
1. Open Calc
2. Right click on sheet tab
3. Move mouse point on the context menu
4. It will have unexpected highlighting

Actual Results:
Calc sheet tab's context menu has unexpected highlighting 

Expected Results:
Calc sheet tab's context menu doesn't have unexpected highlighting 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha1+
Build ID: 77ae0abe21f672cf4b7d2e069f1d40d20edc49a7
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-31_15:33:33
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Vera Blagoveschenskaya 2019-06-04 06:28:57 UTC
Reproduced for 

Version: 6.3.0.0.alpha1+
Build ID: 77ae0abe21f672cf4b7d2e069f1d40d20edc49a7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-31_15:33:33
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Michael Weghorn 2019-06-04 07:28:44 UTC
Created attachment 151897 [details]
Screenshot for Writer

Same in Writer, s. attached screenshot.
I'm pretty sure that this hasn't been like that forever, so seems to be a regression.
Comment 3 Michael Weghorn 2019-06-06 06:15:39 UTC
Unfortunately, TDF bibisect repos don't have kde5 enabled yet (it's being worked on, though: https://gerrit.libreoffice.org/#/c/72720/ )
Comment 4 Jan-Marek Glogowski 2019-06-06 16:15:07 UTC
*** Bug 125745 has been marked as a duplicate of this bug. ***
Comment 5 Jan-Marek Glogowski 2019-06-07 10:47:45 UTC
So reading the "git log vcl/" I found a suspicious commit:

commit c04169c586ef1d55b1d0ac469bb4fbd4f50bd08a
Author: Miklos Vajna <vmiklos@collabora.com>
Date:   Tue May 21 17:45:05 2019 +0200

    tdf#125415 vcl menu floating window: avoid flicker

Reverting that solves the bug.

Now the whole PopupMenu drawing in Qt is completely different then in LO. It draws it in a different order, which normally needs some crazy clipping.

Eventually we'll just include a new ImplSVNWFData value to use the old behavior. The patch itself looks sane to buffer the whole menu before copying it.
Comment 6 Roman Kuznetsov 2019-06-07 11:52:22 UTC
Miklos, can you look at it?
Comment 7 Miklos Vajna 2019-06-07 11:57:23 UTC
Jan-Marked already mentioned that he plans to look at it, let's avoid a duplicated effort.
Comment 8 Commit Notification 2019-06-08 01:31:44 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2cb6a591b643a0f65dc58f060f60cc707ad3589c%5E%21

tdf#125673 KDE5 implement a KDE5SalVirtualDevice

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-06-08 20:01:20 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/bc799f2c426d56d2139f476dcad98b33d9d560c7%5E%21

tdf#125673 KDE5 implement a KDE5SalVirtualDevice

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-06-14 04:10:25 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/5ee408eb4c9f55d3438426290e91ac31d04821de%5E%21

tdf#125673 KDE5 implement a KDE5SalVirtualDevice

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Jan-Marek Glogowski 2019-06-15 21:01:31 UTC
*** Bug 125927 has been marked as a duplicate of this bug. ***
Comment 12 Ongun Kanat 2019-06-16 18:28:23 UTC
I tested the build below today:

Version: 6.4.0.0.alpha0+
Build ID: b674d3c12a5819fbcb551e83bf6862afc85ef7f3
CPU threads: 8; OS: Linux 5.1; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF-dbg, Branch:master, Time: 2019-06-15_21:06:59
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

The highlighting is solved but it is really slow.
Comment 13 Michael Weghorn 2019-06-17 06:40:42 UTC
(In reply to Ongun Kanat from comment #12)
> I tested the build below today:
> 
> Version: 6.4.0.0.alpha0+
> Build ID: b674d3c12a5819fbcb551e83bf6862afc85ef7f3
> CPU threads: 8; OS: Linux 5.1; UI render: default; VCL: kde5; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF-dbg, Branch:master, Time:
> 2019-06-15_21:06:59
> Locale: en-US (en_US.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> The highlighting is solved but it is really slow.

Since debug builds are always slower: Can you retest with a release (i.e. non-debug) build? I've updated [1] to mention how to extract debs without 'dpkg-deb', so this will hopefully work for you on Arch as well.

[1] https://wiki.documentfoundation.org/Installing_in_parallel/Linux#Step_3:_Tweaking_the_Install_Destination
Comment 14 Roman Kuznetsov 2019-06-17 16:15:53 UTC
verified in 6.4 build from 15.06.2019
Comment 15 Ongun Kanat 2019-06-19 00:07:52 UTC
Created attachment 152282 [details]
Video showing slow highlighting.

(In reply to Michael Weghorn from comment #13)
> (In reply to Ongun Kanat from comment #12)
> > I tested the build below today:
> > 
> > Version: 6.4.0.0.alpha0+
> > Build ID: b674d3c12a5819fbcb551e83bf6862afc85ef7f3
> > CPU threads: 8; OS: Linux 5.1; UI render: default; VCL: kde5; 
> > TinderBox: Linux-rpm_deb-x86_64@86-TDF-dbg, Branch:master, Time:
> > 2019-06-15_21:06:59
> > Locale: en-US (en_US.UTF-8); UI-Language: en-US
> > Calc: threaded
> > 
> > The highlighting is solved but it is really slow.
> 
> Since debug builds are always slower: Can you retest with a release (i.e.
> non-debug) build? I've updated [1] to mention how to extract debs without
> 'dpkg-deb', so this will hopefully work for you on Arch as well.
> 
> [1]
> https://wiki.documentfoundation.org/Installing_in_parallel/Linux#Step_3:
> _Tweaking_the_Install_Destination


It is still slow. Highlighting happens instantly on other Qt / GTK programs.
Comment 16 Ongun Kanat 2019-06-19 00:08:44 UTC
(In reply to Ongun Kanat from comment #15)
> Created attachment 152282 [details]
> Video showing slow highlighting.
> 
> (In reply to Michael Weghorn from comment #13)
> > (In reply to Ongun Kanat from comment #12)
> > > I tested the build below today:
> > > 
> > > Version: 6.4.0.0.alpha0+
> > > Build ID: b674d3c12a5819fbcb551e83bf6862afc85ef7f3
> > > CPU threads: 8; OS: Linux 5.1; UI render: default; VCL: kde5; 
> > > TinderBox: Linux-rpm_deb-x86_64@86-TDF-dbg, Branch:master, Time:
> > > 2019-06-15_21:06:59
> > > Locale: en-US (en_US.UTF-8); UI-Language: en-US
> > > Calc: threaded
> > > 
> > > The highlighting is solved but it is really slow.
> > 
> > Since debug builds are always slower: Can you retest with a release (i.e.
> > non-debug) build? I've updated [1] to mention how to extract debs without
> > 'dpkg-deb', so this will hopefully work for you on Arch as well.
> > 
> > [1]
> > https://wiki.documentfoundation.org/Installing_in_parallel/Linux#Step_3:
> > _Tweaking_the_Install_Destination
> 
> 
> It is still slow. Highlighting happens instantly on other Qt / GTK programs.


Version: 6.4.0.0.alpha0+
Build ID: f75c2b04785aa05cff3bcd52689feb7400a14e8e
CPU threads: 8; OS: Linux 5.1; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-06-15_11:49:26
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded