Download it now!
Bug 128222 - Delete a chapter in navigator (feature request)
Summary: Delete a chapter in navigator (feature request)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 129474 (view as bug list)
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2019-10-17 21:02 UTC by Sebők Gábor
Modified: 2020-02-02 17:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebők Gábor 2019-10-17 21:02:54 UTC
Description:
If I open the navigator and see the list of chapters, I should be able easily a whole chapter.

If this feature exists, please forgive me, I don't find it!

Actual Results:
The chapter remains on its place.

Expected Results:
Delete a chapter easily.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Dieter 2019-10-18 07:59:14 UTC
I support this, but let's ask design team. Tere is a similar request in bug 114370.

cc: Design Team
Comment 2 Sebők Gábor 2019-10-18 08:09:00 UTC
Thanks for supporting!
Comment 3 Heiko Tietze 2019-10-18 08:53:03 UTC
I do have concerns when it comes to destructive functions. Though undo works (hopefully) well after, for example, clicking Delete Chapter at the context menu. But you may unintentionally click it and forget to restore. 

But that's just one opinion. More input please.
Comment 4 Sebők Gábor 2019-10-18 11:51:45 UTC
Look at the MS Word! It works very well.
Comment 5 Dieter 2019-12-18 14:41:01 UTC
*** Bug 129474 has been marked as a duplicate of this bug. ***
Comment 6 Jim Raykowski 2020-01-14 07:08:50 UTC
Hi All,

Here is patch that adds the ability to delete chapters in Navigator through the  content context menu, Headings sub menu, Delete menu item.

https://gerrit.libreoffice.org/c/core/+/86734

Testing and code review appreciated.
Comment 7 Roman Kuznetsov 2020-02-02 17:54:20 UTC
FIXED by Jim Raykowski in https://gerrit.libreoffice.org/c/core/+/87053

Thanks Jim!
Comment 8 Roman Kuznetsov 2020-02-02 17:55:04 UTC
verified in

Версия: 7.0.0.0.alpha0+ (x64)
ID сборки: e8ac78d3afdeb0302eaea34a50f1ca912d5fe897
Потоков ЦП: 4; ОС:Windows 10.0 Build 17763; Отрисовка ИП: Skia/Vulkan; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded