Download it now!
Bug 128624 - Navigator: provide additional 'context menu' actions for manipulating Headings
Summary: Navigator: provide additional 'context menu' actions for manipulating Headings
Status: RESOLVED DUPLICATE of bug 107670
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2019-11-06 10:06 UTC by ricky.tigg
Modified: 2020-01-06 13:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Navigator – options related to Headers [x] (22.23 KB, image/png)
2019-11-06 10:08 UTC, ricky.tigg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ricky.tigg 2019-11-06 10:06:30 UTC
Description:
Features request – Currently available textual options dealing with headers forfill their missions as intended. Practical limitations to an effective work are mainly encountered due to the poverty of available built-in features set,  that do not include options that would cover means to achieve common tasks here depicted.

Steps to Reproduce:
1. Open a new document;
2. Show Styles (F11), expand Headings group, apply any Heading [X].
3. Switch to Navigator view then right-click empty title.

==================================================================

Tasks interacting with Headers in Navigator area

1. Renaming – amount of headers' titles to be renamed has to be consequent enough to be interpreted by user as vast in order the task to be pertinent.
2. Copy an header and thus its content – content included in header to be copied has to be consequent enough to be interpreted by user as vast.
3. Paste an header and thus its content – that content was then interpreted by user as vast! that Header is meant to be past whithin the Headings' tree thus remaining whithin Navigator's area.
4. Delete an header and thus its content – content included in hheader to be deleted has to be consequent enough to be interpreted by user as vast.
5. Paste contents previously copied from a source – source could be within working ODT document, HTML page, and so on. Content to be pasted would be added ether to the beginning or end of the header's existing content, separated visualy from it by an empy row. Sub-options would be [Paste before ..., Paste after...].wri

Actual Results:
Currently available main options are displayed; see LibreOffice_Writer_v.6.3.3.2.0+_Navigator_Headings_menu.png

==================================================================

General observations regarding all tasks when achieved relying on current available means – Slow and challenging. Thus time wasted, not optimized means.

Expected Results:
Adequate means made available. Options-menu model:

Outline level ►
Drag mode ►
Display ►
---------------
Rename
Copy
Paste
Delete
Paste content ► [Paste before ..., Paste after...]


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.3.2.0+; Build ID: 6.3.3.2-2.fc31; CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US; Calc: threaded
Comment 1 ricky.tigg 2019-11-06 10:08:10 UTC
Created attachment 155568 [details]
Navigator – options related to Headers [x]
Comment 2 Dieter 2019-11-10 15:26:56 UTC
(In reply to ricky.tigg from comment #0)
> 3. Switch to Navigator view then right-click empty title.

Titel is displayed. Please try with a fresh user profile.

> 1. Renaming – amount of headers' titles to be renamed has to be consequent
> enough to be interpreted by user as vast in order the task to be pertinent.

Duplicate of bug 91705

> 2. Copy an header and thus its content – content included in header to be
> copied has to be consequent enough to be interpreted by user as vast.

Could be a duplicate of 58191

> 3. Paste an header and thus its content – that content was then interpreted
> by user as vast! that Header is meant to be past whithin the Headings' tree
> thus remaining whithin Navigator's area.
> 4. Delete an header and thus its content – content included in hheader to be
> deleted has to be consequent enough to be interpreted by user as vast.

Duplicate of bug 107670

> 5. Paste contents previously copied from a source – source could be within
> working ODT document, HTML page, and so on. Content to be pasted would be
> added ether to the beginning or end of the header's existing content,
> separated visualy from it by an empy row. Sub-options would be [Paste before
> ..., Paste after...].wri

I won't support this idea.


cc: Design-Team for further input.
Comment 3 ricky.tigg 2019-11-11 08:48:08 UTC
Comment "amount of headers' titles to be renamed has to be consequent enough to be interpreted by user as vast in order the task to be pertinent." made no sense. No batch was involved. Renaming had to focused of course on an header alone.

"Titel is displayed. ". So you would ave managed to see something that is not in sample. I see a blue area as it is, a blue area. Not sure what you might have tried.

"> 3. Paste an header and thus its content – that content was then interpreted
> by user as vast! that Header is meant to be past whithin the Headings' tree
> thus remaining whithin Navigator's area.

Duplicate of bug 107670". Not that one quoted.

"I won't support this idea."No need to guess. Use donations your way.
Comment 4 Heiko Tietze 2019-11-11 11:03:58 UTC
Another ticket on #2 is bug 105600. You copy/paste usually with the intention to move sections within the document, which is possible via Navigator (Promote/Demote Level/Chapter) admittedly it feels like a workaround.

The idea is actually to introduce a standard context menu, which I fully support. Mockup is here https://design.blog.documentfoundation.org/2016/07/31/how-the-navigator-may-support-object-handling-in-libreoffice-draw/

But I would close the ticket as duplicate.
Comment 5 Dieter 2019-12-29 13:26:08 UTC
(In reply to Heiko Tietze from comment #4)
> But I would close the ticket as duplicate.

Heiko, any further input needed from someone else?
Comment 6 Heiko Tietze 2020-01-06 13:54:01 UTC

*** This bug has been marked as a duplicate of bug 107670 ***