Bug 129030 - PDF export with GPG sign always failed
Summary: PDF export with GPG sign always failed
Status: RESOLVED DUPLICATE of bug 113278
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export Digital-Signatures
  Show dependency treegraph
 
Reported: 2019-11-26 05:54 UTC by Anton Shevtsov
Modified: 2020-05-22 05:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
first error window (10.29 KB, image/png)
2019-11-26 05:54 UTC, Anton Shevtsov
Details
second error window (11.50 KB, image/png)
2019-11-26 05:55 UTC, Anton Shevtsov
Details
Certificate in Seahorse (55.66 KB, image/png)
2020-04-15 12:17 UTC, Stefan Knorr (astron)
Details
certificate in LibO (29.05 KB, image/png)
2020-04-15 12:19 UTC, Stefan Knorr (astron)
Details
Additional error window (5.64 KB, image/png)
2020-04-15 12:21 UTC, Stefan Knorr (astron)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Shevtsov 2019-11-26 05:54:07 UTC
Description:
Export to PDF with gpg key sign = failed.


Steps to Reproduce:
1. open odt file
2. File/Export as / PDF
3. go to Digital signatures tab
4. Choose my ggp key (select)
5. Input password to Certificate password field
6. Click - Export
7. Failed 



Actual Results:
I get 2 error windows
1. PDF export aborted. Signature generation failed.
2. General Error. General input/output error

Expected Results:
signed document


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Anton Shevtsov 2019-11-26 05:54:39 UTC
Created attachment 156117 [details]
first error window
Comment 2 Anton Shevtsov 2019-11-26 05:55:05 UTC
Created attachment 156118 [details]
second error window
Comment 3 Roman Kuznetsov 2019-11-26 10:54:03 UTC
Anton, please add info from Help->About dialog
Comment 4 Dieter 2020-02-27 12:06:05 UTC
(In reply to Roman Kuznetsov from comment #3)
> Anton, please add info from Help->About dialog

=> NEEDINFO
Comment 5 Stefan Knorr (astron) 2020-04-15 12:10:50 UTC
I have the same issue here. I tried with current versions of LibreOffice 6.4.2.2 from openSUSE Leap 15.1 and with the version from Flathub. Both show this issue. (FTR: "libreoffice --version" gives "LibreOffice 6.4.2.2 40(Build:2)"; "flatpak run org.libreoffice.LibreOffice --version" gives "LibreOffice 6.4.2.2 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3")

I'll upload a few screenshots to show what my certificate looks like in Seahorse & LibO, in case that's helpful.
Comment 6 Stefan Knorr (astron) 2020-04-15 12:17:58 UTC
Created attachment 159579 [details]
Certificate in Seahorse
Comment 7 Stefan Knorr (astron) 2020-04-15 12:19:23 UTC
Created attachment 159580 [details]
certificate in LibO
Comment 8 Stefan Knorr (astron) 2020-04-15 12:21:14 UTC
Created attachment 159581 [details]
Additional error window

Notably, I sometimes get these types of errors as well.
Comment 9 Timur 2020-05-20 13:51:26 UTC
AFAIK, since I used that a long ago, PDF sign works with X509 and not with GPG/OpenPGP. Bug 113278 and Bug 115884. 
Either I miss something or you reported and confirmed a duplicate.
Comment 10 alan_aversa 2020-05-21 21:12:46 UTC
I can confirm this bug on LibreOffice 6.4.3.2 40(Build:2) on slackware-current, Linux kernel 5.4.42.

I get the
 • "Signature generation failed" "PDF export aborted" (attachment: "first error window")
 • "Error saving the document" "General Error." "General input/output error." (attachment: "second error window")
errors, too, when trying to export to a PGP-signed PDF.

I also get the
 • "lu*.tmp does not exist" (attachment: "Additional error window")
when trying to sign with a PGP key an already existing PDF.

I can sign ODT documents with PGP keys with no problems.
Comment 11 Timur 2020-05-22 05:27:07 UTC
OK, I asked :)
I mark as a duplicate, if someone objects please explain.
Only reporter will be cced, others must subscribe thelmselves to the other bug.

*** This bug has been marked as a duplicate of bug 113278 ***