Bug 115884 - PDF signing should mention it only works with x509 certificates
Summary: PDF signing should mention it only works with x509 certificates
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicUI
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2018-02-20 14:32 UTC by Marco A.G.Pinto
Modified: 2021-01-29 08:29 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video of bug happening (2.48 MB, video/x-ms-wmv)
2021-01-27 15:57 UTC, Marco A.G.Pinto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2018-02-20 14:32:40 UTC
Anyway, after weeks or months trying to do it, I was told in the QA channel that it doesn't work with normal PGP keys.

Could someone add a textbox at the bottom of the signing window:
"You can only sign PDFs with x509 certificates."
?

[14:23] <samuel_m> marcoagpinto: gpg signing only works for odf docs
[14:24] <marcoagpinto> samuel_m: Buaaaaaaaaaaaaaa
[14:24] <marcoagpinto> why is there the option then?
[14:24] <marcoagpinto> for weeks/months that I have been at it trying
[14:24] <marcoagpinto> :(
[14:25] <samuel_m> marcoagpinto: you can use x509 certificates to sign pdfs
[14:25] <marcoagpinto> samuel_m: can't there be placed a tip saying that?
[14:25] <marcoagpinto> otherwise, other persons like me will think it is a bug
[14:25] <marcoagpinto> :(
[14:25] <samuel_m> marcoagpinto: feel free to do so
[14:26] <marcoagpinto> me?
[14:26] <marcoagpinto> I am just into linguistic stuff... spellers + autocorrect
[14:27] <marcoagpinto> maybe Áron could do it?
[14:27] <marcoagpinto> where is he?
[14:27] <marcoagpinto> "You can only sign PDFs with x509 certificates."
[14:27] <marcoagpinto> :)
[14:28] <marcoagpinto> you just need to add a TextGadget in the bottom of the signing window with this text
Comment 1 Timur 2018-02-20 15:00:31 UTC
Guess we should update https://help.libreoffice.org/6.1/en-US/text/shared/01/selectcertificate.html and just change "Select Certificate" window to "Select X.509 Certificate".
Comment 2 Marco A.G.Pinto 2018-02-20 19:11:52 UTC
(In reply to Timur from comment #1)
> Guess we should update
> https://help.libreoffice.org/6.1/en-US/text/shared/01/selectcertificate.html
> and just change "Select Certificate" window to "Select X.509 Certificate".

Great idea!

:-)

Thank you!
Comment 3 Timur 2018-02-28 08:53:13 UTC
If Bug 113278 is solved, than this could be a duplicate.
Comment 4 László Károlyi 2020-01-10 16:12:39 UTC
+1, this needs to be specified to save some time for other users who wonder why they can sign Libreoffice documents with PGP, but not PDFs.
Comment 5 Timur 2020-05-30 09:12:49 UTC
Heiko, can you please get this done? 
Looks simple and it's last moment for 7.0.
Comment 7 Commit Notification 2021-01-27 11:14:58 UTC
Vishwas committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a1146fd95022196636f8c41f7322a7257955cef4

tdf#115884 PDF signing should mention it only works with x509 certificates

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Rene Engelhard 2021-01-27 15:48:48 UTC
I just saw the commit

ehm? It clearly said "certificate", not "key", so that it's only working on X.509 *certificates* and not with PGP *keys* should have been completely obvious...
Comment 9 Marco A.G.Pinto 2021-01-27 15:57:12 UTC Comment hidden (obsolete)
Comment 10 Marco A.G.Pinto 2021-01-27 15:59:03 UTC Comment hidden (obsolete)
Comment 11 Heiko Tietze 2021-01-28 14:05:44 UTC
(In reply to Rene Engelhard from comment #8)
> ehm? It clearly said "certificate", not "key", so that it's only working on
> X.509 *certificates* and not with PGP *keys* should have been completely
> obvious...

What do you suggest?

(In reply to Commit Notification from comment #7)
> Vishwas committed a patch related to this issue.

Marco, can we resolve this issue as fixed?
Comment 12 Marco A.G.Pinto 2021-01-28 15:04:50 UTC
(In reply to Heiko Tietze from comment #11)
> 
> Marco, can we resolve this issue as fixed?

No, because in several places people call "certificates" to everything.

Not even I sometimes know if they are referring to keys or other.

The best is to clarify it for the users that it requires a blah blah X something certificate.
Comment 13 Timur 2021-01-29 08:17:58 UTC
I don't understand Comment 12, it needs precision or this bug be closed. 
Because it's clear now with added X. 509, simple "select X.509 certificate".
Comment 14 Timur 2021-01-29 08:22:17 UTC
Help also needs to be improved, or can be done in this bug or another.
Comment 15 Marco A.G.Pinto 2021-01-29 08:27:22 UTC
(In reply to Timur from comment #13)
> I don't understand Comment 12, it needs precision or this bug be closed. 
> Because it's clear now with added X. 509, simple "select X.509 certificate".

Timur, if it now shows "select X.509 certificate" the bug can be closed.

:-)

Thanks!
Comment 16 Buovjaga 2021-01-29 08:29:50 UTC
(In reply to Marco A.G.Pinto from comment #15)
> (In reply to Timur from comment #13)
> > I don't understand Comment 12, it needs precision or this bug be closed. 
> > Because it's clear now with added X. 509, simple "select X.509 certificate".
> 
> Timur, if it now shows "select X.509 certificate" the bug can be closed.

No need to guess, just look at the commit https://git.libreoffice.org/core/commit/a1146fd95022196636f8c41f7322a7257955cef4