Bug 130058 - FILEOPEN PPTX: image shadow that should be invisible shown as extraneous line below
Summary: FILEOPEN PPTX: image shadow that should be invisible shown as extraneous line...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.0.0 target:7.2.0
Keywords: filter:pptx, implementationError
Depends on:
Blocks: Impress-Images PPTX
  Show dependency treegraph
 
Reported: 2020-01-17 15:28 UTC by Gerald Pfeifer
Modified: 2020-11-22 17:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample PPTX document (3.32 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-01-17 15:28 UTC, Gerald Pfeifer
Details
How it looks like (LibreOffice) (152.39 KB, image/png)
2020-01-17 15:30 UTC, Gerald Pfeifer
Details
How it should look like (Office 365) (182.01 KB, image/png)
2020-01-17 15:30 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-01-17 15:28:37 UTC
Created attachment 157228 [details]
Sample PPTX document

Opening the sample document there is an extraneous bold line below the
image both on slides 1 and 2 that shows in LibreOffice, but not Office 365.
Comment 1 Gerald Pfeifer 2020-01-17 15:30:11 UTC
Created attachment 157229 [details]
How it looks like (LibreOffice)
Comment 2 Gerald Pfeifer 2020-01-17 15:30:36 UTC
Created attachment 157230 [details]
How it should look like (Office 365)
Comment 3 Xisco Faulí 2020-01-17 16:00:25 UTC
Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: cc36c115004cb75037b0e4fdadff09035f765cd5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.19; Render: default;
Comment 4 Xisco Faulí 2020-01-17 16:04:49 UTC
Not reproduced in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 Aron Budea 2020-01-25 22:54:31 UTC
The line is a shadow on the image, in PowerPoint it can't be seen (probably because it's configured that way), but in Impress it's shown.

The change could be bisected to the following using repo bibisect-43all (it was already buggy in oldest commit of bibisect-41max):
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=9351d0e4181924c3f72be24081fc7af027aa41f7..fba5febdf60b37be69d2ffc66445d3e324826346

Found two commits in the range that deal with import of shadows on objects:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=f0efecfb69b336e064e7c8dd2597655eff07944f
https://cgit.freedesktop.org/libreoffice/core/commit/?id=e1a509f4a362d21248b439c99e3b55f4fa9ba1bd

All in all, it seems like an implementation error rather than a regression, it's just previously the shadow wasn't imported at all (when making the shadow visible in PP, it still can't be seen when imported in an older LO version).
Comment 6 Commit Notification 2020-04-23 08:08:19 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6454b6336b8de9a4c5899adeab552af6f794cdc4

tdf#130058 Import shadow size.

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-11-22 17:52:31 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/736b0709796d96325542b624ce27a7dc83419cfb

tdf#130058: sd_export_ooxml2: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.