Bug 90442 - FILEOPEN DOCX: Drawing with shapes is imported with wrong shades (regression from 7.0)
Summary: FILEOPEN DOCX: Drawing with shapes is imported with wrong shades (regression ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.7.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: OOXML-Shapes DOCX-Textbox
  Show dependency treegraph
 
Reported: 2015-04-03 18:54 UTC by Eugene Savitsky
Modified: 2021-05-10 15:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
file with image (402.25 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-04-03 18:54 UTC, Eugene Savitsky
Details
Microsoft Word 2003- 111111scheme.pdf: how it looks in Word 2003 (346.31 KB, application/pdf)
2020-06-15 17:51 UTC, Justin L
Details
file DOCX compared MSO 2016 LO 7.1+ (226.79 KB, image/png)
2020-10-27 14:44 UTC, Timur
Details
file DOCX compared MSO 2016 LO 7.2+ (271.85 KB, image/png)
2021-02-26 13:34 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Savitsky 2015-04-03 18:54:25 UTC
Created attachment 114591 [details]
file with image

Open document in LO and MSO. On first page you see the wrong opened image.
Comment 1 raal 2015-04-28 19:14:37 UTC
I can confirm with Version: 5.0.0.0.alpha1+
Build ID: 636c5a63d67b52b0d2f9f21a863c45eca6ac9ff7
TinderBox: Win-x86@42, Branch:master, Time: 2015-04-21_23:00:42

and  4.3.7.2
Comment 2 QA Administrators 2016-09-20 09:34:01 UTC Comment hidden (obsolete)
Comment 3 Eugene Savitsky 2016-09-20 10:14:41 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-12-10 16:43:59 UTC Comment hidden (obsolete)
Comment 5 Eugene Savitsky 2017-12-10 22:10:30 UTC
Confirming for 5.4.3.2
Comment 6 QA Administrators 2018-12-11 03:43:56 UTC Comment hidden (obsolete, spam)
Comment 7 Justin L 2020-06-15 17:51:49 UTC
Created attachment 162018 [details]
Microsoft Word  2003- 111111scheme.pdf: how it looks in Word 2003

In comparison, LO's shapes have textboxes that are too small, so the labels wrap. There is also some z-ordering problems.

Repro 7.1+
Comment 8 Timur 2020-10-27 14:44:09 UTC
Created attachment 166781 [details]
file DOCX compared MSO 2016 LO 7.1+

When this bug was reported, fileopen was awful. 
From LO 7.0 it's much better, as seen in comparison for O 7.1+. 
We need to newly define bug now, to see what's in other bugs.
Comment 9 Timur 2020-10-27 15:07:13 UTC
Bibisect 7.0 L:

This was made good with (thanks László and NISZ!): 
commit 8b2f1ac78f406f3e8b931dd1ce10e89750f3de53
Date:   Tue Mar 17 15:53:03 2020 +0100
    source sha:ab25bf4b2c51e5634bdfeaa1f84af4bb652f7a47
    previous source sha:84eacd97f0151076edf05ef0db69286476d222b9

author	László Németh <nemeth@numbertext.org>	2020-03-17 13:42:10 +0100
committer	László Németh <nemeth@numbertext.org>	2020-03-17 15:37:49 +0100
commit	ab25bf4b2c51e5634bdfeaa1f84af4bb652f7a47 (patch)
tree	0c598e57c6aeff6184bb12416393e80706036ea8
parent	84eacd97f0151076edf05ef0db69286476d222b9 (diff)
tdf#119800 DOCX import: fix vanished objects
Comment 10 Timur 2020-10-27 15:08:20 UTC
Later in 7.0, excessive lines were added (is it what Justin called  z-ordering problem?), so let's consider this bug a regression for that.

commit 658e68588fd4ade17837026b28d9c2efd0898a27
Date:   Thu Apr 23 22:38:27 2020 +0200
    source sha:6454b6336b8de9a4c5899adeab552af6f794cdc4
    previous source sha:0e75f025419f878dc772391cea8d55765bceb9fc

author	Gülşah Köse <gulsah.kose@collabora.com>	2020-04-14 15:49:28 +0300
committer	Gülşah Köse <gulsah.kose@collabora.com>	2020-04-23 10:07:13 +0200
commit	6454b6336b8de9a4c5899adeab552af6f794cdc4 (patch)
tree	efe9ea2e9b0131c4e9143cb1a085586de6f6e91a
parent	0e75f025419f878dc772391cea8d55765bceb9fc (diff)
tdf#130058 Import shadow size.

CC Gülşah, please take a look.
Comment 11 Timur 2020-10-27 15:09:35 UTC
(In reply to Justin L from comment #7)
> LO's shapes have textboxes that are too small, so the labels wrap.
Now that I converted this bug to regression, this is another issue, first to be seen if already reported.
Comment 12 Aron Budea 2020-12-25 21:11:53 UTC
The situation would probably be easier to follow if this bug was kept on the collective status of the document, and individual issues were spun off on the various problems that still need fixing, eg. the regression.
Comment 13 Gülşah Köse 2021-02-25 06:33:24 UTC
Fixed with befc0c2b0e0b3bf293a2446d71e38717ed53985b
Comment 14 Timur 2021-02-26 13:33:04 UTC
This bug was converted to shades and it's fixed now with bug 133473.

What's left should be dealt with elsewhere (because BZ is not per-document):

1. LO's shapes have textboxes that are too small, so the labels wrap
"Provider" text box width is 3,69 cm in MSO and 2,54 cm in LO. I see no fit options here.
Wrong from when some of it appeared in LO 4.1.
I'll just write this example in bug 123326.

2. shape positions misplaced
Looks like vertical positioning. Anyway, it's differently shown in MSO (to paragraph) and LO (to margin).
I'm not sure about exact bug, but I'd just write this example in bug 100920 and wait.
I dislike opening a ton of somewhat similar bugs where proper cause wasn't found and we see no tangible progress.
Comment 15 Timur 2021-02-26 13:34:39 UTC
Created attachment 170085 [details]
file DOCX compared MSO 2016 LO 7.2+
Comment 16 Xisco Faulí 2021-05-10 15:09:05 UTC
(In reply to Timur from comment #15)
> Created attachment 170085 [details]
> file DOCX compared MSO 2016 LO 7.2+

Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: d4f116d9576453f5974eb63db37a33c59ac53bc9
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded