Bug 133473 - FILEOPEN: Shadow is gone
Summary: FILEOPEN: Shadow is gone
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.2.0 target:7.1.2 target:7.0.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Images
  Show dependency treegraph
 
Reported: 2020-05-28 10:30 UTC by Xisco Faulí
Modified: 2021-03-11 20:49 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 7.0 master (163.71 KB, image/png)
2020-05-28 10:30 UTC, Xisco Faulí
Details
Comparison MSO 2010 and LibreOffice 7.0 master ( attachment 67862 ) (139.00 KB, image/png)
2020-05-28 11:21 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-05-28 10:30:23 UTC
Created attachment 161361 [details]
Comparison MSO 2010 and LibreOffice 7.0 master

Steps to reproduce:
1. Open attachment 75936 [details] from bug 45667

-> The watermark image doesn't have a shadow. See comparison image

Reproduced in

Version: 7.0.0.0.alpha1+
Build ID: 82894d85147840f1f587e9530b12f0058f2ef2c3
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded


[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-05-28 10:31:31 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=6454b6336b8de9a4c5899adeab552af6f794cdc4

author	Gülşah Köse <gulsah.kose@collabora.com>	2020-04-14 15:49:28 +0300
committer	Gülşah Köse <gulsah.kose@collabora.com>	2020-04-23 10:07:13 +0200
commit	6454b6336b8de9a4c5899adeab552af6f794cdc4 (patch)
tree	efe9ea2e9b0131c4e9143cb1a085586de6f6e91a
parent	0e75f025419f878dc772391cea8d55765bceb9fc (diff)
tdf#130058 Import shadow size.

Bisected with: bibisect-linux64-6.5

Adding Cc: to Gülşah Köse
Comment 2 Xisco Faulí 2020-05-28 11:20:23 UTC
attachment 67862 [details] from bug 55456 is also affected by this issue
Comment 3 Xisco Faulí 2020-05-28 11:21:10 UTC
Created attachment 161364 [details]
Comparison MSO 2010 and LibreOffice 7.0 master ( attachment 67862 [details] )
Comment 4 Xisco Faulí 2020-06-06 15:45:40 UTC
attachment 79084 [details] from bug 64424 is also affected by this issue
Comment 5 NISZ LibreOffice Team 2021-01-04 13:39:49 UTC
This commit is mentioned in several other reports :(.
Comment 6 Justin L 2021-01-21 14:56:19 UTC
(In reply to NISZ LibreOffice Team from comment #5)
> This commit is mentioned in several other reports :(.
Then it probably ought to just be reverted before it is too late.
Comment 7 Justin L 2021-01-25 07:30:33 UTC
(In reply to Justin L from comment #6)
> (In reply to NISZ LibreOffice Team from comment #5)
> > This commit is mentioned in several other reports :(.
> Then it probably ought to just be reverted before it is too late.

I tried to put together a revert patch since Gülşah Köse hasn't acknowledged this bug for 6+ months. However, too many things have built upon it already. So I failed. For the record, here is the order that I tried to revert things:

    • partial revert of a7505356872f981c951b2ec64383a95538890876  (debug)
    • partial revert of a75bf43a8d6c5dec6dcc86908c142ceec541aa8c  (new function use)
    • partial revert of e21d522dddce2590ed435890ae8d5fe39658a71a (fix origin)
    • revert messy 4ba368a3dd793bdc703858f358e1af7112decadd (cleanup patch)
    • revert 6454b6336b8de9a4c5899adeab552af6f794cdc4
    • revert related e2b0e614e1185c960b3015414919f69a1ed35aa0 (Gülşah Köse patch)
    • revert 736b0709796d96325542b624ce27a7dc83419cfb (Xisco unit test)
Comment 8 Xisco Faulí 2021-01-25 09:01:06 UTC
(In reply to Justin L from comment #7)
> (In reply to Justin L from comment #6)
> > (In reply to NISZ LibreOffice Team from comment #5)
> > > This commit is mentioned in several other reports :(.
> > Then it probably ought to just be reverted before it is too late.
> 
> I tried to put together a revert patch since Gülşah Köse hasn't acknowledged
> this bug for 6+ months. However, too many things have built upon it already.
> So I failed. For the record, here is the order that I tried to revert things:
> 
>     • partial revert of a7505356872f981c951b2ec64383a95538890876  (debug)
>     • partial revert of a75bf43a8d6c5dec6dcc86908c142ceec541aa8c  (new
> function use)
>     • partial revert of e21d522dddce2590ed435890ae8d5fe39658a71a (fix origin)
>     • revert messy 4ba368a3dd793bdc703858f358e1af7112decadd (cleanup patch)
>     • revert 6454b6336b8de9a4c5899adeab552af6f794cdc4
>     • revert related e2b0e614e1185c960b3015414919f69a1ed35aa0 (Gülşah Köse
> patch)
>     • revert 736b0709796d96325542b624ce27a7dc83419cfb (Xisco unit test)

At this point, I don't think reverting everything mentioned above is an option...
Comment 9 Gülşah Köse 2021-02-09 20:58:48 UTC
I've started to work on this
Comment 10 Commit Notification 2021-02-25 06:33:10 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/befc0c2b0e0b3bf293a2446d71e38717ed53985b

tdf#133473 Change SDRATTR_SHADOWSIZEX flag.

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2021-03-09 20:37:46 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 351b2382465087d18a3ad44509c2a3a66ca08aa6
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: 

@Gülşah Köse, thanks for fixing this issue!!
Comment 12 Commit Notification 2021-03-10 09:12:06 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/408f3007def50d5b99c0cd5afeedcaabe5291561

tdf#133473 Change SDRATTR_SHADOWSIZEX flag.

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-03-11 20:49:46 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/36538b33413b24241920d8c4d873beb5c671e13f

tdf#133473 Change SDRATTR_SHADOWSIZEX flag.

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.