Bug 130565 - EDITING: Cannot edit protected document
Summary: EDITING: Cannot edit protected document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard:
Keywords:
: 140282 (view as bug list)
Depends on:
Blocks: DOCX-Content_Control DOCX-Doc-Protection
  Show dependency treegraph
 
Reported: 2020-02-10 15:16 UTC by Hendrik Maryns
Modified: 2021-12-20 13:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
file showing the problem (from Dutch government) (95.40 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-02-10 15:16 UTC, Hendrik Maryns
Details
Sample DOCX with empty password (97.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-06-04 00:44 UTC, Aron Budea
Details
The second example document in current master (370.98 KB, image/png)
2021-12-20 11:35 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hendrik Maryns 2020-02-10 15:16:43 UTC
Created attachment 157773 [details]
file showing the problem (from Dutch government)

Hi, I cannot edit the attached document in LO.  Opening it in Word, I can edit the non-protected sections.
Comment 1 ian 2020-02-11 12:25:34 UTC
Thank you for reporting the bug. I opened the document in Word 2010, and I can confirm that it is editable in certain sections. I, additionally, can confirm that the bug is present in a recent master build on Windows. 

Using:

Version: 7.0.0.0.alpha0+ (x64)
Build ID: e8ac78d3afdeb0302eaea34a50f1ca912d5fe897
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

This appears to be covered under Bug 120763. 

I need someone else to confirm that this bug report is a duplicate.
Comment 2 Dieter 2020-02-12 14:22:49 UTC
(In reply to iantheprogrammer from comment #1)
> Thank you for reporting the bug. I opened the document in Word 2010, and I
> can confirm that it is editable in certain sections. I, additionally, can
> confirm that the bug is present in a recent master build on Windows. 

=> Status NEW

> I need someone else to confirm that this bug report is a duplicate.

Please add the number of the bug, this bug 130565 is probably a duplicate.
Comment 3 NISZ LibreOffice Team 2021-04-13 15:14:12 UTC Comment hidden (obsolete)
Comment 4 Aron Budea 2021-06-04 00:41:52 UTC
Bug 120499 is about removing the document protection using a password, while this bug is about being able to fill in the form fields, which should be possible.

I'm not sure what it's related to, since the document contains content controls, I'm adding it to that meta.

It also never worked, in old version even the document protection isn't imported.

Adding a version of the document that has empty password (it is still protected). It was created from the original by:
- unzipping it,
- removing the tag <w:documentProtection ...> from settings.xml,
- rezipping it,
- readding document protection in Word that only allows filling in forms.
Comment 5 Aron Budea 2021-06-04 00:44:20 UTC
Created attachment 172604 [details]
Sample DOCX with empty password
Comment 6 NISZ LibreOffice Team 2021-07-06 13:54:22 UTC
(In reply to Aron Budea from comment #4)
> Bug 120499 is about removing the document protection using a password, while
> this bug is about being able to fill in the form fields, which should be
> possible.
> 
> I'm not sure what it's related to, since the document contains content
> controls, I'm adding it to that meta.
> 

Content controls are not imported as content controls, but plain text. Which falls under the document protection so cannot be edited.

So this is really a duplicate of bug #104823 (or bug 137466 ) where content controls are lost on import.

Not importing the password (bug 120499) is indeed a different issue.
Comment 7 Gabor Kelemen (allotropia) 2021-12-20 11:35:13 UTC
Created attachment 177032 [details]
The second example document in current master

Looks better in:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 82ceab070de76d447505a598d07d5a9a1c48d80d
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded

The Rich text content controls are now imported as fields and can be edited.
The document contains some checkbox controls, those are still unfixed, see bug 99571.
Comment 8 Gabor Kelemen (allotropia) 2021-12-20 13:16:38 UTC
*** Bug 140282 has been marked as a duplicate of this bug. ***
Comment 9 Gabor Kelemen (allotropia) 2021-12-20 13:40:16 UTC
With the issue filed under bug 146334 this is layout-wise solved (see bug 137466). Saving as docx is also supported.
Several improvements could be made visually and feature-wise still, to be filed as separate bugs.