Bug 130731 - Mixed language in LibreOffice UI/Menu (macOS)
Summary: Mixed language in LibreOffice UI/Menu (macOS)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: User-Locale UI
  Show dependency treegraph
 
Reported: 2020-02-17 12:00 UTC by Ahmad Haris
Modified: 2020-03-20 11:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
printmenu (672.89 KB, image/png)
2020-02-17 12:01 UTC, Ahmad Haris
Details
save (194.38 KB, image/png)
2020-02-17 12:15 UTC, Ahmad Haris
Details
printe menu from local build (606.33 KB, image/png)
2020-02-17 13:43 UTC, Ahmad Haris
Details
nomixedlanguage (518.40 KB, image/png)
2020-03-20 11:10 UTC, Ahmad Haris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ahmad Haris 2020-02-17 12:00:49 UTC
Description:
File - Printer menu got mixed language

Steps to Reproduce:
1. open LibreOffice Writer
2. open File - Printer menu



Actual Results:
Printer dialog got mixed language

Expected Results:
It should be just one language (in my case, English (US)


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+
Build ID: 15c0f22c31a46ce37e98f9394e6a8e0bc92495f9
CPU threads: 8; OS: Mac OS X 10.15.3; UI render: default; VCL: osx; 
Locale: en-ID (en_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Ahmad Haris 2020-02-17 12:01:38 UTC
Created attachment 157939 [details]
printmenu

It is also doesn't have keyID
Comment 2 Xisco Faulí 2020-02-17 12:04:11 UTC
*** Bug 104547 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2020-02-17 12:07:51 UTC
Confirmed by Imanuel in bug 104547
Comment 4 Xisco Faulí 2020-02-17 12:08:52 UTC
I can't reproduce it in

Versión: 6.4.0.3 (x86)
Id. de compilación: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Subprocs. CPU: 2; SO: Windows 6.1 Service Pack 1 Build 7601; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

will try with master.
Comment 5 Xisco Faulí 2020-02-17 12:14:49 UTC
@Imanuel, Could you please paste the info from Help - about LibreOffice ?
Comment 6 Ahmad Haris 2020-02-17 12:15:39 UTC
Created attachment 157940 [details]
save

It's also happen in File - Save
Comment 7 Imanuel Ronaldo 2020-02-17 12:26:39 UTC
(In reply to Xisco Faulí from comment #5)
> @Imanuel, Could you please paste the info from Help - about LibreOffice ?

Version: 7.0.0.0.alpha0+
Build ID: 4caa7b790cf99eebbe47fc2e6a56124c42f1f3fc
CPU threads: 4; OS: Mac OS X 10.15.3; UI render: default; VCL: osx; 
Locale: en-US (en_ID.UTF-8); UI-Language: en-US
Calc: threaded

this is my LibreOffice Dev 7
Comment 8 Ahmad Haris 2020-02-17 13:43:30 UTC
Created attachment 157950 [details]
printe menu from local build

I build on my local, and it's work. No mixed language.

Version: 7.0.0.0.alpha0+
Build ID: 09e6824bc868990095233825c415556399dd0652
CPU threads: 8; OS: Mac OS X 10.15.3; UI render: default; VCL: osx; 
Locale: en-ID (en_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Timur 2020-03-08 18:12:56 UTC
this is a mess with many bugs on the same issue. 
We don't have steps nor it's reproducible so no need to have multiple bugs.

*** This bug has been marked as a duplicate of bug 94090 ***
Comment 10 Buovjaga 2020-03-09 16:34:48 UTC
Putting back to NEW per Timur's comment in bug 94090
Comment 11 Ahmad Haris 2020-03-20 11:09:37 UTC
I think it's already fix in master build.

Version: 7.0.0.0.alpha0+
Build ID: 22225256e8e2c64978fdcd87c5390764a3ac7b6b
CPU threads: 8; OS: Mac OS X 10.15.3; UI render: default; VCL: osx; 
Locale: en-ID (en_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Ahmad Haris 2020-03-20 11:10:09 UTC
Created attachment 158830 [details]
nomixedlanguage