Download it now!
Bug 131697 - Slow scrolling if shapes are visible in Calc with Skia enabled in Software mode
Summary: Slow scrolling if shapes are visible in Calc with Skia enabled in Software mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords:
: 131408 132013 132228 (view as bug list)
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-03-30 09:45 UTC by Telesto
Modified: 2020-05-11 13:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (11.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-03-30 09:46 UTC, Telesto
Details
Example file (351.09 KB, application/vnd.oasis.opendocument.presentation)
2020-04-15 19:30 UTC, Telesto
Details
Example file (10.59 KB, application/vnd.oasis.opendocument.text)
2020-04-17 12:34 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-03-30 09:45:54 UTC
Description:
Slow scrolling if shapes are visible in Calc with Skia enabled in Software mode

Steps to Reproduce:
1. Open the attached file
2. Check if Skia is enabled & in software mode (Tools -> Options -> LibODev -> View)
3. Scroll up/down

Actual Results:
Choppy scrolling

Expected Results:
Smooth scrolling


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 7ae9c9572ccac55c0926b8a9779bb63c4236291c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-03-30 09:46:09 UTC
Created attachment 159139 [details]
Example file
Comment 2 Roman Kuznetsov 2020-03-30 12:15:06 UTC
confirm in

Версия: 7.0.0.0.alpha0+ (x64)
ID сборки: 4501a0ba623ad61c5a4e0b807da2e96f0e4ce82c
Потоков ЦП: 4; ОС: Windows 10.0 Build 18362; Отрисовка ИП: Skia/растр; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 3 Telesto 2020-03-30 12:23:40 UTC
Not limited to Calc actually dragging an image in Impress also slow.
Comment 4 Luboš Luňák 2020-04-07 09:58:26 UTC
Current master after https://cgit.freedesktop.org/libreoffice/core/commit/?id=81edf0ceef264dbbb338d2ed91378baa59b7a3bf should do in raster mode about as well as possible, with the exception that Skia's raster needs to be compiled with Clang to perform well. That still needs to be handled for provided binaries.
Comment 5 Luboš Luňák 2020-04-07 09:58:40 UTC
*** Bug 131408 has been marked as a duplicate of this bug. ***
Comment 6 Luboš Luňák 2020-04-14 13:35:39 UTC
*** Bug 132013 has been marked as a duplicate of this bug. ***
Comment 7 Telesto 2020-04-15 19:30:04 UTC
Created attachment 159592 [details]
Example file

1. Click Slide 2
2. Click a different slide -> Takes a while (insane large PNG; fine with different renderings including Vulkan)
Comment 8 Telesto 2020-04-17 12:34:31 UTC
Created attachment 159656 [details]
Example file

Another case
1. Open the attachment (2 pages of some forms elements
2. Press Print Preview -> Slow
Comment 9 Commit Notification 2020-04-20 09:16:38 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/647499ef8151d9383983f89230a970edcb44b5bb

prefer building Skia with Clang if possible (tdf#131697)

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Luboš Luňák 2020-04-22 09:37:28 UTC
*** Bug 132228 has been marked as a duplicate of this bug. ***
Comment 11 Telesto 2020-04-28 20:40:13 UTC
@Lubos
FWIW: PNG image are still an issue
1. Open attachment 144465 [details] & drag the image around. Smooth with all backends except SKIA/Raster. Unworkable slow
Comment 12 Telesto 2020-05-02 19:13:47 UTC
@Lubos
Will there be development builds, build with Clang? I prefer not having to wait for a (alpha) release build..
Comment 13 Luboš Luňák 2020-05-04 13:55:11 UTC
Build machines need to get Clang installed (which is to be done somewhen now).
Comment 14 Telesto 2020-05-05 16:09:37 UTC
Before I forget it to check it after Clang
1. Open attachment 160389 [details] and start typing at the beginning of the document.. slow
Comment 15 Luboš Luňák 2020-05-11 13:58:51 UTC
Clang is now used to build Skia, so together with the other optimizations I consider this handled. If there are more specific problems, please report them as separate issues.