Download it now!
Bug 132725 - Crash in: BigPtrArray::Index2Block(unsigned __int64) anchor to paragraph
Summary: Crash in: BigPtrArray::Index2Block(unsigned __int64) anchor to paragraph
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: high major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6....
Keywords: bibisected, bisected, regression
: 132724 (view as bug list)
Depends on:
Blocks: Anchor-and-Text-Wrap Crash-BigPtrArray Crash
  Show dependency treegraph
 
Reported: 2020-05-05 15:38 UTC by Telesto
Modified: 2020-06-24 14:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["BigPtrArray::Index2Block(unsigned __int64)"]


Attachments
Example file (71.17 KB, application/vnd.oasis.opendocument.text)
2020-05-05 15:38 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-05 15:38:19 UTC
Created attachment 160388 [details]
Example file

This bug was filed from the crash reporting server and is br-ee854979-230c-4c95-b887-09b9ade34efa.
=========================================

1. Open the attached file
2. Type AA after opening
3. Backspace
4. Backspace
5. CTRL+Z
6. CTRL+Z
7. CTRL+Y
8. CTRL+Y
9. CTRL+Z -> crash

Anchor to paragraph. No crash in 6.0
Comment 1 MM 2020-05-05 17:50:53 UTC
Confirmed on windows 10 x64 with Version: 6.4.4.1 (x64)
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Comment 2 Xisco Faulí 2020-05-07 08:56:27 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=91b2325808a75174f284c48c8b8afc118fad74e4

author	Michael Stahl <Michael.Stahl@cib.de>	2019-12-05 16:49:33 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2019-12-06 13:26:32 +0100
commit	91b2325808a75174f284c48c8b8afc118fad74e4 (patch)
tree	d456e57e6d0d0532592030cb0d3d20585b8fe7a4
parent	6ed12ab2d0742f86ce25defec3c776562dbfad9a (diff)
tdf#121300 sw: consistent fly at-pargraph selection

Bisected with: bibisect-linux64-6.5

Adding Cc: to Michael Stahl
Comment 3 Telesto 2020-05-10 10:37:15 UTC
Note: No crash with tracking changed enabled
Comment 4 Commit Notification 2020-06-10 15:40:35 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/32c162ad1723512763b74d01eaec32c1296f3a55

tdf#132725 sw: SwUndoDelete: don't group if flys are be deleted

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Stahl (CIB) 2020-06-10 15:43:14 UTC
fixed on master
Comment 6 Commit Notification 2020-06-10 21:53:55 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c98ba4767bfaa250b1d779b6393e80fdbdec353a

tdf#132725 sw: SwUndoDelete: don't group if flys are be deleted

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-06-10 21:55:30 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5c2c03dde718b2bf627ef9ef8f985fc41454b1ab

tdf#132725 sw: SwUndoDelete: don't group if flys are be deleted

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-06-11 08:59:32 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 03b77f972f6be23f75dfe3773266a660e61e5607
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Michael S, thanks for fixing this issue!!
Comment 9 Xisco Faulí 2020-06-11 09:03:40 UTC
*** Bug 132724 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2020-06-11 18:36:37 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cd47dba9aa4b91bb0edf0744561d29e2eef61cc9

tdf#132725: sw: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-06-24 14:15:13 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-5":

https://git.libreoffice.org/core/commit/5eb42c7cdf4111019634347b39c29992b6ff732f

tdf#132725 sw: SwUndoDelete: don't group if flys are be deleted

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.