Bug 132764 - PDF export produces empty documents in Lubuntu
Summary: PDF export produces empty documents in Lubuntu
Status: RESOLVED DUPLICATE of bug 125234
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 133213 (view as bug list)
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2020-05-06 12:34 UTC by Lennart
Modified: 2020-06-18 05:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lennart 2020-05-06 12:34:37 UTC
Description:
When trying to export a document to PDF the PDF is empty. Used OS: Lubuntu 20.04.

Steps to Reproduce:
1. Create a document in LibreOffice Writer.
2. Export it to PDF.

Actual Results:
The PDF is empty in qpdfview and Firefox’s built-in PDF viewer shows a lot of characters and states that the PDF might not be shown corr

Expected Results:
Create a proper PDF.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.3.2
Build-ID: 1:6.4.3-0ubuntu0.20.04.1
CPU-Threads: 4; BS: Linux 5.4; UI-Render: Standard; VCL: qt5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded
Comment 1 ian 2020-05-09 15:37:26 UTC Comment hidden (obsolete)
Comment 2 Lennart 2020-05-10 10:59:31 UTC Comment hidden (obsolete)
Comment 3 ian 2020-05-10 15:43:44 UTC
Thanks for providing the extra information, Lennart.

I will attempt to reproduce this using LibreOffice in Linux (I need to update the version I'm currently using there (it's at 6.4.0.3) since it's in a virtual machine). 

I couldn't reproduce the bug using the latest stable build and recent master build in Windows.

Using: 
Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

And 
Version: 7.0.0.0.alpha1 (x64)
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win; 
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 4 Xisco Faulí 2020-05-11 09:53:11 UTC Comment hidden (obsolete)
Comment 5 Timur 2020-05-22 11:55:32 UTC
*** Bug 133213 has been marked as a duplicate of this bug. ***
Comment 6 Timur 2020-05-22 11:57:40 UTC
New by duplicate bug. Sample is attachment 161057 [details].
This needs to be tested by adding Lubuntu desktop (I don't have space thought).
Comment 7 Simone Tommasini 2020-05-24 12:25:29 UTC
(In reply to Timur from comment #5)
> *** Bug 133213 has been marked as a duplicate of this bug. ***

Good morning to all of you. Just to start, I searched some other exiting bug but I couldn't find the bug Timur told me: sorry for that.
Today I delete Libreoffice 6.4 and tried to install the 6.3 and the 7.0 beta releases and the results were the same.
At this point I installed the old Abiword and it changed the odt to pdf file with no problem.
But, since the Libreoffice 6.4 is part of the package Lubuntu 20.04 LTS, I put a Ubuntu 20.04 LTS (without the "L") on a pen drive and tried Libreoffice 6.4 provided with the operative system and all the stuff runs!
At this point I think the problem could be in the Lubuntu (with the "L") and for this reason I'll write to the Italian Lubuntu community just to ask if the release of Lubuntu is simply obtained by changing the Unity to LXDE or if it's obtained not only switching the desktop environment by changing some other things.
I was forced to think so because some other guy had similar problem with Lubuntu 20.04 (with the "L").
Thanks and ciao.
Simone
Comment 8 Timur 2020-05-24 13:55:35 UTC
Lubuntu should have LXQt. 
This could be upstream Lubuntu bug, not LO, and that would be NotOurBug then. 
You should report to Lubuntu,https://bugs.launchpad.net/~lubuntu-packaging . If confirmed, this status would be Moved then.
Comment 9 Simone Tommasini 2020-05-25 16:34:58 UTC
Ciao to everyone.
I got it! As I suspected, the problem comes from Lubuntu 20.04 itself but the fix is easy to get.

The answer is here:
https://discourse.lubuntu.me/t/libreoffice-export-to-pdf-has-no-text/1042


In particular I paste here from the site above:

"Best solution/workaround at present seems to be this…
Go to LUBUNTU MENU: Preferences -> LXQt settings -> Session settings -> Environment variables

Then, add this:
Variable Name: SAL_VCL_QT5_USE_CAIRO
Fill the Value with: true

Restart your computer, and it will resolve the fonts rendering while exporting documents to a PDF on LibreOffice.
(There is just one small inconvenience – see below).

A few other people have hit this too, however it has been reported and discussed elsewhere as problem with PRINTING from LibreOffice (see “Printing problem with 20.04” in this forum). The connection between these two manifestations of a problem is that LibreOffice generates a PDF, which is then sent to be printed via CUPS. Without the above (or similar) fix, the generated PDF is invalid, because the required fonts fail to get embedded.

A MINOR INCONVENIENCE : with this “fix” in place, you will always have to start either LibreOffice-writer, LibreOffice-calc, -draw, -impress, etc, because trying to start “bare” LibreOffice will throw an error. In my opinion this is a minor inconvenience compared to not being able to export to PDF, or print anything at all."

Since it's the first time I write to Libreoffice, Timur, would you mind move yourself the bug from Libreoffice to where you wrote me yesterday?
Thank you very much! Ciao. Simone
Comment 10 Timur 2020-05-25 18:34:00 UTC
Status "MOVED" is symbolic, meaning problem is reported elsewhere. 
It's step further from "NOTOURBUG". 

Thanks for workaround. But even better is that you report bug to Lubuntu and write that URL here. 

Note that we can start LO manually with different rendering, if installed:
SAL_USE_VCLPLUGIN=gen soffice
SAL_USE_VCLPLUGIN=gtk3 soffice
SAL_USE_VCLPLUGIN=qt5 soffice
where soffice is LO itself.
Comment 11 Timur 2020-06-18 05:47:33 UTC

*** This bug has been marked as a duplicate of bug 125234 ***