Bug 133935 - Table header row rendered incorrectly when marked up as header row
Summary: Table header row rendered incorrectly when marked up as header row
Status: RESOLVED DUPLICATE of bug 119951
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pptx, regression
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2020-06-12 16:02 UTC by Simon Gaeremynck
Modified: 2020-11-19 16:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Table headers rendered incorrectly presentation (51.74 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-06-12 16:02 UTC, Simon Gaeremynck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Gaeremynck 2020-06-12 16:02:05 UTC
Created attachment 161925 [details]
Table headers rendered incorrectly presentation

The attached pptx file renders the table header row incorrectly (gray text rather than black).

This renders correctly in MS Powerpoint, OS X Preview and weirdly, old 6.3.? versions on Mac. I've now upgraded to 6.4 and don't know which version of 6.3 renders it correctly unfortunately.
Comment 1 Buovjaga 2020-10-19 13:47:52 UTC
Simon: is the origin of this file Microsoft Office (which version)? It has never been saved from LibreOffice?

I bisected the change with Linux 7.0 repo to https://git.libreoffice.org/core/commit/7f82e6dae98bc5e75ec03885eb955a7a72047bb4
tdf#107604 Handle predefined table styles.

Adding Cc: to Gülşah Köse
Comment 2 Simon Gaeremynck 2020-10-19 15:50:04 UTC
Buovjaga: I don't know where it originated from. For what it's worth, I did extract that slide on Powerpoint for Mac, but it was already present in the original. Unfortunately, I no longer have the original pptx nor a way to contact the person who sent me the file.
Comment 4 Xisco Faulí 2020-11-19 16:47:14 UTC
it looks like MSO PowerPoint if https://cgit.freedesktop.org/libreoffice/core/commit/?id=037fe3671cbdad51f52d2f69f72f47f463dba7c2 is reverted.
Closing as duplicate of bug 119951

*** This bug has been marked as a duplicate of bug 119951 ***