Bug 134392 - CRASH: importing file with Enable very large spreadsheets enabled
Summary: CRASH: importing file with Enable very large spreadsheets enabled
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, bisected, haveBacktrace
: 134461 (view as bug list)
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-06-29 13:44 UTC by Xisco Faulí
Modified: 2020-09-21 05:52 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (21.51 KB, text/plain)
2020-06-29 17:18 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-06-29 13:44:04 UTC
Steps to reproduce:
1. Options - Advanced - Enable experimental features
2. Options - Calc - Defaults - Enable very large spreadsheets
3. Open attachment 162504 [details] from bug 134388

-> Crash

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 42bf9bdf3d551eb59604f952204c49f7d7a1e913
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-06-29 13:45:28 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5bcdbf03012e9d2754c3eb166bd5a01201406d9b

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-12-13 20:45:33 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-12-14 06:57:53 +0100
commit 5bcdbf03012e9d2754c3eb166bd5a01201406d9b (patch)
tree c910eac80023f9cb1c0f943c8edad1928977968f
parent 113444f59dc7690850919155b9b164b1a686bbe7 (diff)
sc: rowcol: tdf#50916 convert Valid* methods
which means we end up passing around ScDocument*
__everywhere__

Bisected with: bibisect-linux64-7.0

Adding Cc: to Noel Grandin
Comment 2 Julien Nabet 2020-06-29 17:18:39 UTC
Created attachment 162514 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today + gen rendering, I could reproduce this.

I retrieved the bt from last throw.
Comment 3 Telesto 2020-06-30 08:15:03 UTC
Again the same.. multi_type_vector::position

FWIW: It's worthless/waste of effort to use/ test/ file reports against very large spreadsheets at this point.. it crashes all the time with multi_type_vector::position.. needs to be sorted out first.
Comment 4 Telesto 2020-07-02 07:09:16 UTC
For the record.. Support for very large spreadsheets is largely advertised in the release notes.. Even in Experimental state they multi_type_vector::position bug should go away before release.. you can't touch nearly anything or it crashes.. see the others

Gives a bad impression.. some people are eager to try and end up in a disillusion.. managing expectation.. you can better advertise something as experimental although it actually should be rock solid already. Instead of creating hopes which aren't met.. it's a disappointing experience for probably everybody..

I know that people are in awaiting of Support for very large spreadsheets eagerly and that there is some pressure to deliver etc

However this now moves to the area where a developer has to look at it, and it can't be  handled as a side project.. Ok, it still can.. but should be somewhat useable
Comment 5 Julien Nabet 2020-07-02 07:33:07 UTC
Following last Telesto's comment that I completely agree, let's increase importance of this tracker.
Comment 6 Noel Grandin 2020-07-02 07:46:25 UTC
This should be removed from the release notes, it is not ready for being more widely advertised
Comment 7 Julien Nabet 2020-07-02 07:48:57 UTC
Luboš: I put you in cc because considering ee2d2184133b3bf47d38a03b14abab2caa15dad1 ("don't add a cell to a non-existent column (tdf#104865)"), thought you might be interested in this one. But of course, don't hesitate to remove yourself if you don't have time or just don't want to.
Comment 8 Xisco Faulí 2020-07-02 08:24:10 UTC
(In reply to Noel Grandin from comment #6)
> This should be removed from the release notes, it is not ready for being
> more widely advertised

+1
Comment 9 Xisco Faulí 2020-07-02 08:28:08 UTC
Info was added in https://wiki.documentfoundation.org/index.php?title=ReleaseNotes/7.0&diff=267011&oldid=266967.
Anyway, will bring the topic to today's ESC meeting before doing anything
Comment 10 Xisco Faulí 2020-07-02 14:52:34 UTC
(In reply to Xisco Faulí from comment #9)
> Info was added in
> https://wiki.documentfoundation.org/index.php?title=ReleaseNotes/7.
> 0&diff=267011&oldid=266967.
> Anyway, will bring the topic to today's ESC meeting before doing anything

Removed as agreed in the ESC minutes
Comment 11 Julien Nabet 2020-07-02 17:16:36 UTC
*** Bug 134461 has been marked as a duplicate of this bug. ***
Comment 12 Julien Nabet 2020-07-02 17:19:18 UTC
Let's increase importance of this one since it seems it may have several dups.
It would be interesting to avoid to waste people time hitting this same bug.
Of course, I don't pretend it's easy to fix and if it's indeed difficult perhaps we should make some announcement (in forum, a comment on these bugs) to tell people not to test this part for the moment.
Comment 13 NISZ LibreOffice Team 2020-07-06 09:58:28 UTC
(In reply to Julien Nabet from comment #12)
> Let's increase importance of this one since it seems it may have several
> dups.

A quick search for multi_type_vector::position brought up these reports I just put to See Also.
Comment 14 Xisco Faulí 2020-09-07 11:36:03 UTC
*** Bug 136546 has been marked as a duplicate of this bug. ***
Comment 15 Roman Kuznetsov 2020-09-16 20:35:18 UTC
no crash in

Version: 7.1.0.0.alpha0+
Build ID: 8c18cd6823ddf4ef5ba67801a84cee26c9b5a9a6
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

WFM
Comment 17 Commit Notification 2020-09-21 05:52:35 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/40240877eed74e4a886c78ad86e163bdd8f6290c

tdf#134392: sc_jumbosheets_test: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.