Bug 139074 - CRASH on Paste from clipboard into dialog or other floating window, paste to document canvas is fine; Windows only?
Summary: CRASH on Paste from clipboard into dialog or other floating window, paste to ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.0.0.beta1+
Hardware: All Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0.2
Keywords: bibisected, bisected, haveBacktrace, regression
: 139146 139156 139186 139244 139275 139282 139284 139287 139327 139349 139366 139406 139445 139456 139477 139563 139581 139582 139586 139821 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-19 18:02 UTC by V Stuart Foote
Modified: 2021-01-28 09:17 UTC (History)
26 users (show)

See Also:
Crash report or crash signature:


Attachments
WinDbg stack trace paste into an Insert -> Comment (12.38 KB, text/plain)
2020-12-19 18:22 UTC, V Stuart Foote
Details
WinDbg stack trace paste into Expert Configuration edit of ooName (21.45 KB, text/plain)
2020-12-19 18:24 UTC, V Stuart Foote
Details
WinDbg ST crash on paste into Expert Configuration edit of ooName (19.81 KB, text/plain)
2020-12-22 18:59 UTC, V Stuart Foote
Details
a bit better ST of 7.1.0.1 for crash in Writer with paste into a Text Box object (31.64 KB, text/plain)
2020-12-28 20:55 UTC, V Stuart Foote
Details
a bit better (x64) ST of 7.1.0.1 for crash pasting to ooName stanza of ExpertConfig (44.22 KB, text/plain)
2020-12-29 18:47 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2020-12-19 18:02:45 UTC

    
Comment 1 V Stuart Foote 2020-12-19 18:07:10 UTC
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Attempting to <Ctrl>+V paste text into a dialog object is crashing.

Observed pasting into an Insert -> Comment object.

Also, crash pasting into an edit from the 'Expert configuration' dialog, e.g. setting the 'ooName' stanza.
Comment 2 V Stuart Foote 2020-12-19 18:22:51 UTC
Created attachment 168343 [details]
WinDbg stack trace paste into an Insert -> Comment
Comment 3 V Stuart Foote 2020-12-19 18:24:01 UTC
Created attachment 168344 [details]
WinDbg stack trace paste into Expert Configuration edit of ooName
Comment 5 Jan-Marek Glogowski 2020-12-22 18:35:58 UTC
Didn't try yet, but see the comments in https://gerrit.libreoffice.org/c/core/+/107675. Major problem is the fact, that these patches are also in 7.1. I don't have time to implement the correct solution to handle clipboard in the main thread. I still don't like the original idea of https://bugs.documentfoundation.org/show_bug.cgi?id=139074, but we need something for 7.1 and if that flies, so be it. Maybe the better solution can be backported later...
Comment 6 V Stuart Foote 2020-12-22 18:59:32 UTC
Created attachment 168426 [details]
WinDbg ST crash on paste into Expert Configuration edit of ooName

Continued crash on Windows with paste from clipboard for 2020-12-22 TB77 build.

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4041c68ea59181f1c4774c356809066d2051db41
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 7 Telesto 2020-12-22 19:04:01 UTC
Bug 139146 might be related.. stack has some similarity's (and cut/paste)
Comment 8 V Stuart Foote 2020-12-22 19:53:29 UTC
*** Bug 139156 has been marked as a duplicate of this bug. ***
Comment 9 V Stuart Foote 2020-12-22 19:54:41 UTC
*** Bug 139146 has been marked as a duplicate of this bug. ***
Comment 10 V Stuart Foote 2020-12-22 19:58:08 UTC
re STR of bug 139156, like Writer and Impress, paste onto Draw canvas works. But if content of the new draw textbox is emptied a paste from clipboard into that object crashes.
Comment 11 V Stuart Foote 2020-12-23 16:33:31 UTC
*** Bug 139186 has been marked as a duplicate of this bug. ***
Comment 12 V Stuart Foote 2020-12-23 16:36:38 UTC
https://gerrit.libreoffice.org/c/core/+/107894 pushed issue into 7.1.0.1 rc1
Comment 13 Telesto 2020-12-24 08:57:50 UTC
QA engineer and bumping priority so it makes it to the mailing-list.. as this will  cause a number of reports, I assume
Comment 14 Telesto 2020-12-24 09:21:06 UTC
Paste inside a comment box in Writer will also cause a crash
Comment 15 V Stuart Foote 2020-12-26 20:02:20 UTC
*** Bug 139244 has been marked as a duplicate of this bug. ***
Comment 16 Telesto 2020-12-28 16:07:41 UTC
*** Bug 139284 has been marked as a duplicate of this bug. ***
Comment 17 V Stuart Foote 2020-12-28 20:21:34 UTC
*** Bug 139287 has been marked as a duplicate of this bug. ***
Comment 18 V Stuart Foote 2020-12-28 20:45:52 UTC
*** Bug 139282 has been marked as a duplicate of this bug. ***
Comment 19 V Stuart Foote 2020-12-28 20:55:26 UTC
Created attachment 168539 [details]
a bit better ST of 7.1.0.1 for crash in Writer with paste into a Text Box object
Comment 20 V Stuart Foote 2020-12-29 18:47:13 UTC
Created attachment 168562 [details]
a bit better (x64) ST of 7.1.0.1 for crash pasting to ooName stanza of ExpertConfig
Comment 21 Ming Hua 2020-12-30 22:29:27 UTC
*** Bug 139327 has been marked as a duplicate of this bug. ***
Comment 22 V Stuart Foote 2020-12-31 21:58:52 UTC
*** Bug 139349 has been marked as a duplicate of this bug. ***
Comment 23 Julien Nabet 2021-01-03 10:04:40 UTC
Considering:
- the number of dups (so not a corner a case)
- it's a regression
- it's a crash
=> let's put this one to max priority.
ok it doesn't concern all envs but Windows is the mainstream OS for desktop (I don't want to start a troll, I personally use Debian)
Comment 24 Xisco Faulí 2021-01-04 12:00:29 UTC
I do confirm this issue was introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f5ab8bcbfd20ecce4a358f62ee3f81b8b968a5de

author	Jan-Marek Glogowski <glogow@fbihome.de>	2020-12-14 10:47:04 +0100
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2020-12-16 18:02:15 +0100
commit	f5ab8bcbfd20ecce4a358f62ee3f81b8b968a5de (patch)
tree	78eeb346b2bd8a875becb3dcde7e766400e49fce
parent	e4c21a3c1fa8acd0078029d7a42f304ff2b40773 (diff)
WIN don't notify clipboard change with SolarMutex

Bisected with: win64-7.2
Comment 25 Ming Hua 2021-01-04 14:45:37 UTC
*** Bug 139406 has been marked as a duplicate of this bug. ***
Comment 26 Xisco Faulí 2021-01-06 11:48:07 UTC
Hopefully the crashes should be fixed after https://cgit.freedesktop.org/libreoffice/core/commit/?id=c921f9bd64187823af2356d7a8ceb77444c17219
Comment 27 Ming Hua 2021-01-06 15:37:55 UTC
*** Bug 139445 has been marked as a duplicate of this bug. ***
Comment 28 V Stuart Foote 2021-01-06 22:04:12 UTC
*** Bug 139456 has been marked as a duplicate of this bug. ***
Comment 29 Xisco Faulí 2021-01-07 15:15:22 UTC
*** Bug 139366 has been marked as a duplicate of this bug. ***
Comment 30 Xisco Faulí 2021-01-07 15:41:39 UTC
(In reply to Xisco Faulí from comment #26)
> Hopefully the crashes should be fixed after
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=c921f9bd64187823af2356d7a8ceb77444c17219

I do confirm the issue is fixed in

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 0f7008e91f45cf8e3cee6f372ce012b38a795e26
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded

@Mike Kaganski, thanks for fixing this issue.
Comment 31 Xisco Faulí 2021-01-07 16:35:49 UTC
*** Bug 139477 has been marked as a duplicate of this bug. ***
Comment 32 m.a.riosv 2021-01-07 16:44:09 UTC Comment hidden (obsolete)
Comment 33 Xisco Faulí 2021-01-07 18:54:51 UTC
A new daily build containing the fix is available at https://dev-builds.libreoffice.org/daily/master/Win-x86_64@tb77-TDF/current/
Please, doublecheck the crashes are gone with this build. If you find a crash, please, report it in a new ticket. Thanks
Comment 34 V Stuart Foote 2021-01-07 20:13:47 UTC
(In reply to Xisco Faulí from comment #33)

> Please, doublecheck the crashes are gone with this build.

Verified reliable paste that no longer crash with today's TB77 build
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 57a59ad02d2e5e89724c0d2e60cf6e7d99fba005
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

This is resolved, but be aware the work to improve Windows clipboard handling remains, paste issues could reappear.

=-ref-=
https://gerrit.libreoffice.org/c/core/+/107669

Backport to 7.1 
https://gerrit.libreoffice.org/c/core/+/108860
Comment 35 Junichi Matsukawa 2021-01-08 08:08:37 UTC
OK. Thank you for the fix.
Comment 36 m.a.riosv 2021-01-12 09:00:03 UTC
*** Bug 139275 has been marked as a duplicate of this bug. ***
Comment 37 Xisco Faulí 2021-01-12 14:43:47 UTC
*** Bug 139563 has been marked as a duplicate of this bug. ***
Comment 38 Xisco Faulí 2021-01-13 10:48:18 UTC
*** Bug 139581 has been marked as a duplicate of this bug. ***
Comment 39 Xisco Faulí 2021-01-13 11:03:16 UTC Comment hidden (obsolete)
Comment 40 Xisco Faulí 2021-01-13 12:22:24 UTC
*** Bug 139582 has been marked as a duplicate of this bug. ***
Comment 41 Commit Notification 2021-01-13 19:15:49 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/f9c3a734221228cdf5a52ed6ebf9c0a3c1d44607

tdf#139074: Revert "WIN replace clipboard update thread with Idle" et al

It will be available in 7.1.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 42 mwtjunkmail 2021-01-13 22:31:07 UTC
Just a process question because I'm ignorant, does fixing something in 7.1.0.2 mean that it will also show up approximately at the same time in a daily build for 7.2.0.0 alpha?
Comment 43 V Stuart Foote 2021-01-13 22:56:33 UTC
(In reply to mwtjunkmail from comment #42)
> Just a process question because I'm ignorant, does fixing something in
> 7.1.0.2 mean that it will also show up approximately at the same time in a
> daily build for 7.2.0.0 alpha?

No, it is already in the daily build. 

While the 7.1.0.2 incremental release will be finalized as scheduled, which could have been weeks/months away. However, the rc2 build is scheduled for this week [1], so in this case it is soon.

=-ref-=
[1] https://wiki.documentfoundation.org/ReleasePlan/7.1#7.1.0_release
Comment 44 mwtjunkmail 2021-01-18 14:58:55 UTC
(In reply to Commit Notification from comment #41)
> Stephan Bergmann committed a patch related to this issue.
> It has been pushed to "libreoffice-7-1":
> 
> https://git.libreoffice.org/core/commit/
> f9c3a734221228cdf5a52ed6ebf9c0a3c1d44607
> 
> tdf#139074: Revert "WIN replace clipboard update thread with Idle" et al
> 
> It will be available in 7.1.0.2.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Works for me in 
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 1a167625314bf36b735176ed488e6ba9b5e9b675
CPU threads: 8; OS: Windows 10.0 Build 21292; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 45 Xisco Faulí 2021-01-21 22:24:18 UTC
*** Bug 139821 has been marked as a duplicate of this bug. ***
Comment 46 James Buton 2021-01-23 23:15:37 UTC
(In reply to mwtjunkmail from comment #44)
> (In reply to Commit Notification from comment #41)
> > Stephan Bergmann committed a patch related to this issue.
> > It has been pushed to "libreoffice-7-1":
> > 
> > https://git.libreoffice.org/core/commit/
> > f9c3a734221228cdf5a52ed6ebf9c0a3c1d44607
> > 
> > tdf#139074: Revert "WIN replace clipboard update thread with Idle" et al
> > 
> > It will be available in 7.1.0.2.
> > 
> > The patch should be included in the daily builds available at
> > https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> > information about daily builds can be found at:
> > https://wiki.documentfoundation.org/Testing_Daily_Builds
> > 
> > Affected users are encouraged to test the fix and report feedback.
> 
> Works for me in 
> Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
> Build ID: 1a167625314bf36b735176ed488e6ba9b5e9b675
> CPU threads: 8; OS: Windows 10.0 Build 21292; UI render: Skia/Raster; VCL:
> win
> Locale: en-US (en_US); UI: en-US
> Calc: CL

I have updated from 7.1.0.2 to 7.1.0.2 and can report that this bug is now FIXED in this version! Thanks so much
Comment 47 James Buton 2021-01-23 23:16:53 UTC
I have updated from 7.1.0.2 to 7.1.0.2 and can report that this bug is now FIXED in this version! Thanks so much
Comment 48 Xisco Faulí 2021-01-28 09:17:22 UTC
*** Bug 139586 has been marked as a duplicate of this bug. ***