Bug 139241 - Column headers become misaligned with columns on resize
Summary: Column headers become misaligned with columns on resize
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.2.0 target:7.1.4
Keywords: bibisected, bisected, regression
: 140277 141105 (view as bug list)
Depends on:
Blocks: RTL-UI
  Show dependency treegraph
 
Reported: 2020-12-26 09:40 UTC by Eyal Rozenberg
Modified: 2021-05-19 08:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2020-12-26 09:40:35 UTC
Description:
I'm working on an RTL page in a worksheet. If I resize my columns (i.e. their widths) - the resize works, but the column header row (with the "A", "B", "C" etc. headers) does not respect the new sizes... until the window repaints.

Steps to Reproduce:
1. Create a new worksheet
2. Make sure your worksheet is RTL
3. Drag the side of the "A" column, using its header, to make the column wider.

Actual Results:
Column width changes, column header width doesn't

Expected Results:
Column width changes, column header width changes accordingly.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
This is fairly new, I don't remember this occurring in 6.x versions. Not sure about eariler 7.x versions.

Version: 7.0.3.1
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Linux 5.2; UI render: default; VCL: gtk3
Locale: he-IL (en_IL); UI: en-US
Calc: threaded
Comment 1 Regina Henschel 2021-02-09 01:48:07 UTC
Same happens with insert columns. See it on Windows.
Comment 2 Regina Henschel 2021-02-09 01:48:49 UTC
*** Bug 140277 has been marked as a duplicate of this bug. ***
Comment 3 Uwe Auer 2021-03-18 22:38:22 UTC
*** Bug 141105 has been marked as a duplicate of this bug. ***
Comment 4 Mike Kaganski 2021-05-10 17:23:42 UTC
All three reports (this one, and the two dupes) mention that it was OK previously (tdf#141105 specifically mentions 6.4.6 as OK) => regression.
Comment 5 raal 2021-05-11 18:32:58 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one?
Thanks

54e5ad0169461359030972b3437aabcda10b3956 is the first bad commit
commit 54e5ad0169461359030972b3437aabcda10b3956
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Apr 16 09:23:10 2020 +0200

    source sha:059f07f9f33460c809a93e0fda1165f5c6f6d805

https://git.libreoffice.org/core/+/059f07f9f33460c809a93e0fda1165f5c6f6d805
    fixes for code creating reversed Rectangles
Comment 6 Mike Kaganski 2021-05-11 19:05:07 UTC
https://gerrit.libreoffice.org/c/core/+/115284
Comment 7 Commit Notification 2021-05-11 19:50:12 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/05f8f239d49bd66145e736b4e2e28ad073ef6f2f

tdf#139241: partially revert 059f07f9f33460c809a93e0fda1165f5c6f6d805

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Eyal Rozenberg 2021-05-11 20:17:53 UTC
(In reply to Commit Notification from comment #7)
> Affected users are encouraged to test the fix and report feedback.

Thank you, and I'll test it soon when it's in a daily.
Comment 9 Commit Notification 2021-05-12 00:43:52 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/8bdbc928cb2d79e161aaa6a5ac1cd816ab6c591b

tdf#139241: partially revert 059f07f9f33460c809a93e0fda1165f5c6f6d805

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 BogdanB 2021-05-19 08:31:34 UTC
Everything works well.
Verified with Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: b238522ca121ca8f863fe4d3394ade088a65ad01
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded