Bug 140096 - Add Ctrl+F6 and clarify F6 in Shortcut keys
Summary: Add Ctrl+F6 and clarify F6 in Shortcut keys
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2021-02-02 15:58 UTC by sdc.blanco
Modified: 2021-02-05 02:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen shot of proposed text for Ctrl+F6 and Ctrl+Shift+F10 (30.88 KB, image/png)
2021-02-04 00:46 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2021-02-02 15:58:33 UTC
1. Open Sidebar, Open Find toolbar (Ctrl+F), place cursor in search (Find Text) field.  Press F6 (repeatedly)

   Actual Result: Cursor cycles from Find toolbar to menubar, other open toolbars, and the window (canvas) with text.

   Expected Result:  Cursor goes directly from Find toolbar to window (canvas) with text.

2.  Close Sidebar, place cursor in Find toolbar, press F6.

Expected and Actual Result:  Cursor goes directly from Find toolbar to window (canvas) with text.

According to: 
https://help.libreoffice.org/7.2/en-US/text/shared/04/01010000.html

F6   Sets focus in next subwindow, for example, document/data source view.

Results produced with both Writer and Calc (so setting to LibreOffice).

Tested with:

6.3.6.2 and 

7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 396c2ad2daad6fe6a11703d0ae1593929834afe2
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Comment 1 Regina Henschel 2021-02-02 18:00:48 UTC
The behavior is correct and the way it is described in the help. For to switch to the document press Ctrl+F6.

More about short-cuts for accessibility on https://help.libreoffice.org/7.2/en-US/text/shared/guide/keyboard.html
Comment 2 sdc.blanco 2021-02-02 20:08:58 UTC
Thanks Regina.  I need to read the manual more carefully.
The page that you cited explains it clearly.

The page I cited: 

https://help.libreoffice.org/7.2/en-US/text/shared/04/01010000.html

did not mention Ctrl+F6 in the section "Shortcut keys for controlling documents and windows" --  so I will add that.

But is the explanation for F6 correct?  

(I do not understand what a "subwindow" is, but it seems like a better description might be given). 

Thanks
Comment 3 V Stuart Foote 2021-02-03 06:11:29 UTC
F10 and F6 get special treatment as they are core a11y shortcuts.

F10, and <Shift>+F10 to move to main menu, and canvas.

While F6, <Shift>+F6 move between GUI sub-windows (Main menu, Standard TB, Formatting TB, Status Bar, Sidebar, Document Canvas).

And <Ctrl>+F6 has been added to go directly to canvas.

Those coupled with <TAB> and Cursor <U,D,L,R> give the basic non-mouse keyboard controls needed for a11y support of Assistive Technology. And all controls are supposed to respond with a reasonable "accessible event" announcing the control with focus.

Things remain borken badly by the NB MUFFIN assemblages. Notably bug 107343 and the NB a11y meta bug 107316
Comment 4 sdc.blanco 2021-02-03 11:35:31 UTC
Thanks Regina, and thanks for explanations Stuart. 
I will "reconfigure" this ticket as a "Documentation" updating.

Still a couple of questions/clarifications needed, always in relation to:
https://help.libreoffice.org/7.2/en-US/text/shared/04/01010000.html

> F10, and <Shift>+F10 to move to main menu, and canvas.
According to existing help (and 7.2.0.0 behavior), Shift+F10 opens a context menu. (F10 toggles between main menu and canvas)  Are they wrong about Shift+F10?
 
> While F6, <Shift>+F6 move between GUI sub-windows (Main menu, Standard TB,
> Formatting TB, Status Bar, Sidebar, Document Canvas).
Should Status bar be in the list?  (In 7.2.0.0, F6 cycles in the order that you have given, but I could not see Status Bar -- maybe you meant Find bar?)

Also, afaict, all open toolbars are included in the cycling.

[before I filed this ticket I looked at help, did not know meaning of "subwindow", but saw "Document".  Now I will try to explain better]

Here is my current formulation (which I think is accurate, and reasonably comprehensible).

     Sets focus in next subwindow, including menu bar, all open toolbars, 
     open windows such as Sidebar and Navigator, and document/data source.

 
> And <Ctrl>+F6 has been added to go directly to canvas.
Will add to the help page.

btw...when I opened Navigator window, tore away the "Character Highlighting Color" window from toolbar, then started from canvas, and used F6  to "cycle", things started all right (menu, toolbars, Character Highlighting), but 
(a) never got to Navigator window, 
(b) and after Character Highlighting, remained in a loop between the lowest toolbar (on the top), the toolbar on the bottom) and the Character Highlighting window).

Additional:

(c) also, same problem/behavior with Character Highlighting, w/o Navigator involved.
(d) w/o Character Highlighting torn away, no problem to include Navigator window in the cycle.

Will not file a ticket (or maybe it is already filed), only mention it in case it is relevant/interesting for you.
Comment 5 V Stuart Foote 2021-02-03 16:06:27 UTC
(In reply to sdc.blanco from comment #4)
> > F10, and <Shift>+F10 to move to main menu, and canvas.
> According to existing help (and 7.2.0.0 behavior), Shift+F10 opens a context
> menu. (F10 toggles between main menu and canvas)  Are they wrong about
> Shift+F10?
>  

No I was wrong/misremembering. 

F10 is overloaded and the <Shift>+F10 does not return directly to document canvas--the <Ctrl>+F6 does that. With no other movements/actions F10 will toggle between main menu and document canvas.

<Shift>+F10 opens the context menus, actually hardcoded in winproc.cxx. 

<Ctrl>+<Shift>+F10 will dock and undock for floating sub-windows (TB & SB Deck).

And in a continuing bug, an F10 when in NB views (i.e. main menu hidden) will move focus outside LibreOffice to its main window (bug 107343).

F6 cycling order is not the Status bar (which can't be reached by keyboard at all) rather the normally empty Info bar was removed from the F6 cycling (bug 105518).

It is helpful to use an assistive technology tool (e.g. NVDA screen reader on windows, or ORCA on linux) to exercise keyboard navigation.
Comment 6 V Stuart Foote 2021-02-03 16:10:02 UTC
@Jim, any input to Seth as he looks at correcting the Help for the F6 keys, and glitches noted in his comment 4
Comment 7 sdc.blanco 2021-02-04 00:11:57 UTC
(In reply to V Stuart Foote from comment #5)
> <Ctrl>+<Shift>+F10 will dock and undock for floating sub-windows (TB & SB
> Deck).
Appears to be missing from General Shortcut Keys in the "Shortcut keys for controlling documents and windows" section -- so I will add this as well
in the patch.

And another btw --  no complaints -- just feedback from a naive user trying to use Ctrl-Shift-F10 for the first time. 

1.  Works great with SB and Navigator -- in the sense of being able to toggle
    them back and forth in docking.  

2.  Does not work with "locked" toolbars (fair enough, not so surprising)

3.  Is it easy to keep state information about "last used tb"? 
   
    Had expected that that I could toggle a tb back and forth (like sb)
    But after docking, the focus remains in the canvas. 
  
    Could be practical to be able to use Ctrl-Shift-F10 and have the 
    "last used tb (or SB/Navigator as the case may be)" to undock again.

    Then one can type, pop up tb (possibly one's own customized version),
    double-click it back, continue typing, and bring it up again later 
    (Ctrl-Shift-F10), without having to navigate (with keys or mouse).
    
    Could be particularly useful with customized toolbars (with draw objects, 
    or custom styles).

    Could also be justified as accessibility improvement, because do not need 
    to first F6 to same tb each time. 

 4.  Tried to use Ctrl-Shift-F10 with open "Character Highlighting Color" window, but it did not close it.  (perhaps not so surprising -- because it is not exactly "docking" -- but it is possible to navigate there with F6 (as noted in comment 4). 

> It is helpful to use an assistive technology tool ... 
> ... to exercise keyboard navigation.
Or to have learned to edit with a visual editor before mice existed.
Comment 8 sdc.blanco 2021-02-04 00:46:03 UTC
Created attachment 169461 [details]
Screen shot of proposed text for Ctrl+F6 and Ctrl+Shift+F10

Attached is screenshot of proposed descriptions for Ctrl+F6, Ctrl+Shift+F10, and revised version for F6 -- shown in their "context" --
Comment 9 sdc.blanco 2021-02-04 00:48:48 UTC
ummm....I think the F6 description should refer to "visible" toolbars and "visible windows" (like Sidebar and Navigator) -- not "open" --   

does that sound right?
Comment 10 V Stuart Foote 2021-02-04 05:28:56 UTC
(In reply to sdc.blanco from comment #8)
> Created attachment 169461 [details]
> Screen shot of proposed text for Ctrl+F6 and Ctrl+Shift+F10
> 
> Attached is screenshot of proposed descriptions for Ctrl+F6, Ctrl+Shift+F10,
> and revised version for F6 -- shown in their "context" --

All good except the <ctrl>+<alt>+<shift>+<home> -- does not seem to be functional. Do you have a commit or BZ issue related to use of that shortcut?

(In reply to sdc.blanco from comment #9)
> ummm....I think the F6 description should refer to "visible" toolbars and
> "visible windows" (like Sidebar and Navigator) -- not "open" --   
> 
> does that sound right?

either is good, "open" the legacy but no reason to retain if "visible" seems more applicable and can be translated.
Comment 11 sdc.blanco 2021-02-04 15:26:33 UTC
(In reply to V Stuart Foote from comment #10)
> All good 
Thanks

>except the <ctrl>+<alt>+<shift>+<home> -- does not seem to be functional. 
Repro.  (that shortcut was "found" in current help)

> Do you have a commit or BZ issue related to use of that shortcut?
Nope.  But when I assigned .uno:Menubar to Ctrl-Alt-Shift-Home (in the LibreOffice section), then the help page becomes accurate.
 
> either is good, "open" the legacy but no reason to retain if "visible"
> seems more applicable and can be translated.
could not find any "open toolbar" or "open toolbars" in existing help, but could find "visible toolbar".  (will "open" be (mis)read as "undocked"?) 
Concerned that "open window" would not be interpreted to include "docked" SB or Navigator, hence "visible". And blind readers? Case of choosing a lesser evil?
Comment 12 V Stuart Foote 2021-02-04 15:35:19 UTC
(In reply to sdc.blanco from comment #11)
> (In reply to V Stuart Foote from comment #10)
> > All good 
> Thanks
> 
> >except the <ctrl>+<alt>+<shift>+<home> -- does not seem to be functional. 
> Repro.  (that shortcut was "found" in current help)
> 
Dump it then?

> > Do you have a commit or BZ issue related to use of that shortcut?
> Nope.  But when I assigned .uno:Menubar to Ctrl-Alt-Shift-Home (in the
> LibreOffice section), then the help page becomes accurate.
>  
Sure, but if I were setting it myself, I'd use a different shortcut.

But, still worth a Help note that it is available to customize--and maybe a BZ ticket to assign it a viable shortcut.

> > either is good, "open" the legacy but no reason to retain if "visible"
> > seems more applicable and can be translated.
> could not find any "open toolbar" or "open toolbars" in existing help, but
> could find "visible toolbar".  (will "open" be (mis)read as "undocked"?) 
> Concerned that "open window" would not be interpreted to include "docked" SB
> or Navigator, hence "visible". And blind readers? Case of choosing a lesser
> evil?

Well technically they are "exposed" but I don't think we want to split that hair.  The "visible" label would be fine, I don't think it is objectionable for Political Correctness or a11y sensitivities.
Comment 13 sdc.blanco 2021-02-04 15:50:22 UTC
(In reply to V Stuart Foote from comment #12)
> > >except the <ctrl>+<alt>+<shift>+<home> -- does not seem to be functional. 
> > Repro.  (that shortcut was "found" in current help)
> > 
> Dump it then?
Not mentioned in "Getting Started Guide 6.4", where Ctrl+F6 is mentioned.
But following Mike Kaganski's principle, report all discrepancies between help and LO behavior.
 
> Well technically they are "exposed" but I don't think we want to split that
> hair.  
Especially when it may be lost in translation. 

Meanwhile, this dialogue has inspired a simplification (because menubar can also be hidden), so "visible" can be moved up to modify "subwindow":

        Sets focus in next visible subwindow, including menu bar, 
        toolbars, windows such as Sidebar and Navigator, and 
        document canvas/data source
Comment 14 Commit Notification 2021-02-05 02:34:03 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/5c476f480cddb8a6dd7b0020564953b22fe0660a

tdf#140096  add Ctrl+F6 and Ctrl+Shift+F10 to shortcut keys