Bug 140940 - Formula Editor scaling of glyphs into sm nodes -- Skia font rendering broken
Summary: Formula Editor scaling of glyphs into sm nodes -- Skia font rendering broken
Status: RESOLVED DUPLICATE of bug 141715
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Formula-Editor Skia
  Show dependency treegraph
 
Reported: 2021-03-10 18:44 UTC by V Stuart Foote
Modified: 2021-04-21 14:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
clip of a OLE formula in Writer opened -- Skia rendering (145.95 KB, image/png)
2021-03-10 19:05 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2021-03-10 18:44:03 UTC
Some recent change affecting scaling of root, nroot glyphs with Skia based rendering (Vulkan, or raster). The glyph is no longer fitting its calculated node in the sm module.

Default GDI rendering of the node & glyph remains correct.
Comment 1 V Stuart Foote 2021-03-10 18:57:42 UTC
Similar to some of the issues at 5.3 as Harfbuzz was being implemented. Some recent change is breaking root & nroot nodes in sm formulas.

We had this done for Harfbuzz support:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4375eefb644d03ab4bafbc091436166a8494dc91&h=libreoffice-5-3

Recently there was Armin's font.cxx scaling work for bug 127471, but this affects just the Skia rendering--default GDI rendering is unaffected.

https://gerrit.libreoffice.org/c/core/+/110330
Comment 2 V Stuart Foote 2021-03-10 19:05:21 UTC
Created attachment 170394 [details]
clip of a OLE formula in Writer opened -- Skia rendering
Comment 3 V Stuart Foote 2021-03-10 19:08:29 UTC
Issues also apparent with Skia rendering enabled for the sm example formulas:

c = sqrt{ a^2 + b^2 }
newline
%DELTA t' = { %DELTA t } over sqrt{ 1 - v^2 over c^2 }
newline
f(x) = {1} over { %sigma sqrt{2 %pi} } func e^-{ {(x-%mu)^2} over {2 %sigma^2} }
newline
Comment 4 V Stuart Foote 2021-03-10 20:01:15 UTC
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9d8accf03984a64a4105826e55b221962628eb93
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 5 Roman Kuznetsov 2021-03-11 09:38:49 UTC
confirm in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9d8accf03984a64a4105826e55b221962628eb93
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

but not in

Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

really regression
Comment 6 Roman Kuznetsov 2021-03-11 09:48:01 UTC
I bisected it with win64-7.2 bisect repo and I got the SHA

13f53741dabc33c5ac12ae26538a2803c6ba1073

https://gerrit.libreoffice.org/c/core/+/111522

https://git.libreoffice.org/core/commit/13f53741dabc33c5ac12ae26538a2803c6ba1073
Comment 7 V Stuart Foote 2021-03-12 20:58:23 UTC
*** Bug 140974 has been marked as a duplicate of this bug. ***
Comment 8 Pierre C 2021-03-20 06:42:46 UTC
AS it is a dupe of 140974, confirmed with LO 7.1.1.1, adjusting earliest version impacted
Comment 9 Pierre C 2021-03-21 22:09:01 UTC
As the bug in #140974 is solved in 7.1.2.1 (or I'm wrong) adjusting the earliest version affected to its initial value
Comment 10 Luboš Luňák 2021-04-20 09:14:24 UTC

*** This bug has been marked as a duplicate of bug 141715 ***