Bug 143152 - Crash just after startup in 7.3 master nightly build (AMD video drivers problem?).
Summary: Crash just after startup in 7.3 master nightly build (AMD video drivers probl...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2021-07-02 03:53 UTC by JO3EMC
Modified: 2021-09-14 00:52 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Status of Windows update. JO3EMC 20210705 (518.65 KB, image/png)
2021-07-05 00:23 UTC, JO3EMC
Details
Status of display adapter in device manager. JO3EMC 20210705 (413.62 KB, image/png)
2021-07-05 00:24 UTC, JO3EMC
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JO3EMC 2021-07-02 03:53:37 UTC
Description:
Can't launch LibreOfficeDev 7.3 master nightly build in Windows OS.
(/daily/master/Win-x86_64@tb77-TDF/)
Crash just after startup.

Steps to Reproduce:
1. Delete existing user profile for LibreOfficeDev.
2. Launch the LibreOfficeDev.
(or you can launch LibreOfficeDev with specified new profile by startup option.)

Actual Results:
Clash just after splash screen and white-outed main window.

Expected Results:
LibreOfficeDev starts.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
The problem has been occurring since "/daily/master/Win-x86_64@tb77-TDF/2021-06-19_06.18.04/".
"daily master Win-x86_64@tb77-TDF 2021-06-17_05.25.14" or "/daily/libreoffice-7-2/Win-x86_64@tb77-TDF/2021-06-30_15.39.11/" starts without any problem. ("daily master Win-x86_64@tb77-TDF 2021-06-18_05.27.46" also starts, but it seems to have another issue.)

In crashed case, startup log ended with such a message line,
"warn:vcl.skia:12392:17768:vcl/skia/gdiimpl.cxx:439: GPU context has run out of memory, aborting."

For trial.
Using the copied profile which is made by 2021-06-17_05.25.14 build with "skia option removed", after versions also starts normally (but with another issue).

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3964e0854507b2696ae0fbe48a4fb005c779947e
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL
Comment 1 m.a.riosv 2021-07-02 09:16:39 UTC
No issue here.
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3964e0854507b2696ae0fbe48a4fb005c779947e
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: threaded
Comment 2 Julien Nabet 2021-07-03 10:14:31 UTC
Could you give a try at https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.28Skia.29 ?
Comment 3 JO3EMC 2021-07-04 14:30:43 UTC
(In reply to Julien Nabet from comment #2)
> Could you give a try at
> https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.
> 28Skia.29 ?

I tried.

Immediately after a clean installation, LibreOffice cannot be started, and the display in the "About LibreOffice" dialog cannot be seen, so I inherited the user profile whose settings were changed in 2021-06-17_05.25.14 version and saw the behavior in 2021-07-01_04.57.10 version.

The results are as follows.

* UI Render: Skia/Vulkan -> Crash  ("Use Skia for all rendering" cheked)
* UI Render: Skia/Raster -> Launch ("Force Skia software rendering" cheked)
* UI Render: default     -> Launch (Skia is disabled.)

skia.log for Skia/Vulkan
---
RenderMethod: vulkan
Vendor: 0x1002
Device: 0x15dd
API: 1.1.101
Driver: 2.0.83
DeviceType: integrated
DeviceName: AMD Radeon(TM) Vega 8 Graphics
Denylisted: no
---

skia.log for Skia/Raster
---
RenderMethod: raster
Compiler: Clang
---
Comment 4 Julien Nabet 2021-07-04 16:59:15 UTC
(In reply to JO3EMC from comment #3)
> (In reply to Julien Nabet from comment #2)
> ...
> The results are as follows.
> 
> * UI Render: Skia/Vulkan -> Crash  ("Use Skia for all rendering" cheked)
> * UI Render: Skia/Raster -> Launch ("Force Skia software rendering" cheked)
> * UI Render: default     -> Launch (Skia is disabled.)
> ...

So with Skia disabled, it works.
Did you check Windows was up-to-date also graphic driver?

Luboš: if the user is up-to-date for Windows and graphic card driver, in vcl/skia/skia_denylist_vulkan.xml, should we 
change this line:
<entry os="all" vendor="amd" compare="less_equal" version="2.0.49">
to
<entry os="all" vendor="amd" compare="less_equal" version="2.0.84">
(since 2.0.83 doesn't work)
or add specific deny entry for:
Vendor: 0x1002
Device: 0x15dd
?
Comment 5 JO3EMC 2021-07-05 00:23:25 UTC
Created attachment 173352 [details]
Status of Windows update. JO3EMC 20210705
Comment 6 JO3EMC 2021-07-05 00:24:04 UTC
Created attachment 173353 [details]
Status of display adapter in device manager. JO3EMC 20210705
Comment 7 JO3EMC 2021-07-05 00:30:44 UTC
(In reply to Julien Nabet from comment #4)
> So with Skia disabled, it works.
> Did you check Windows was up-to-date also graphic driver?
> 

I don't currently know how to check if the graphics driver is up-to-date, but Windows seems to be reasonably up-to-date.
(attachment 173352 [details])

Also, display adapter in device manager seems to be not so bad.
(attachment 173353 [details])

System information, below.

---
[Windows]
エディション	Windows 10 Home
バージョン	20H2
インストール日	‎2021/‎03/‎13
OS ビルド	19042.1052
エクスペリエンス	Windows Feature Experience Pack 120.2212.2020.0
---
[Device]
デバイス名	DESKTOP-R6N655H
プロセッサ	AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx     2.00 GHz
実装 RAM	8.00 GB (6.96 GB 使用可能)
---

---
[RADEON SETTINGS - Overview]
Radeon ソフトウェア バージョン - 19.10.08.06
Radeon ソフトウェア エディション - Adrenalin
グラフィックス チップセット - AMD Radeon(TM) Vega 8 Graphics
メモリー サイズ - 1024 MB
メモリー タイプ - DDR4
コアのクロック - 1101 MHz
Windows バージョン - Windows 10 (64 bit)
システム メモリー - 8 GB
CPU の種類 - AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
---
[RADEON SETTINGS - Software]
Radeon Settings のバージョン - 2019.1104.0631.11728
ドライバー パッケージのバージョン - 19.10.08.06-191104a-348389C-HP
プロバイダー - Advanced Micro Devices, Inc.
2D ドライバー バージョン - 8.1.1.1634
Direct3D® Version - 9.14.10.01394
OpenGL® Version - 26.20.11000.13558
OpenCL™ Version - 10.0.2841.5
AMD オーディオ ドライバーのバージョン - 10.0.1.6
Vulkan™ Driver Version - 2.0.83
Vulkan™ API Version - 1.1.101
---
[RADEON SETTINGS - Hardware AMD Radeon(TM) Vega 8 Graphics]
グラフィックス カードの製造元 - Powered by AMD
グラフィックス チップセット - AMD Radeon(TM) Vega 8 Graphics
デバイス ID - 15DD
ベンダー ID - 1002
サブシステム ID - 8496
サブシステム ベンダー ID - 103C
修正 ID - C4
バス タイプ - PCI
現在のバス設定 - PCI
BIOS バージョン - 016.002.000.009
BIOS パーツ番号 - 113-RAVEN-112
BIOS 日付 - 2018/10/11 07:36
メモリー サイズ - 1024 MB
メモリー タイプ - DDR4
メモリー クロック - 1200 MHz
コアのクロック - 1101 MHz
メモリー全体の帯域幅 - 38 GByte/s
メモリー ビット レート - 2.40 Gbps
2D ドライバー ファイルのパス - /REGISTRY/MACHINE/SYSTEM/CurrentControlSet/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000
OpenGL® API Version - 4.6
OpenCL™ API Version - 2.0
---
Comment 8 QA Administrators 2021-07-06 04:00:58 UTC Comment hidden (obsolete)
Comment 9 Julien Nabet 2021-07-06 20:29:45 UTC
Thank you for your feedback.
Except letting Skia disabled, I don't have more ideas.
Comment 10 JO3EMC 2021-07-07 06:15:37 UTC
Unfortunately, as long as I can't get a reproduction report, I guess I don't have a choice.

Thank you for your efforts to resolve.
Comment 11 Dmitriy Siushkin 2021-07-22 12:54:58 UTC
no reproduce in 

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c5ca46e75e28ba4245d8544ca53c71fea87d1bbd
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 12 Roman Kuznetsov 2021-08-28 18:28:33 UTC
JO3EMC, what about previous LibreOffice versions? Did you have the same problem with 7.1.5 and 7.2.0.4?
Comment 13 JO3EMC 2021-08-29 01:23:31 UTC
Thanks for your comment.

(In reply to Roman Kuznetsov from comment #12)
> JO3EMC, what about previous LibreOffice versions? Did you have the same
> problem with 7.1.5 and 7.2.0.4?

No.
My trouble occurs for the first time in Tanaka "/daily/master/Win-x86_64@tb77-TDF/2021-06-19_06.18.04/".
Previous versions includeng 7.2, 7.1 and "daily master Win-x86_64@tb77-TDF 2021-06-18_05.27.46" start with no problem.
Comment 14 JO3EMC 2021-08-29 01:26:04 UTC
Excuse me.
In the previous comment, I forgot to erase the extra words.
Modify as follows.

---
Thanks for your comment.

(In reply to Roman Kuznetsov from comment #12)
> JO3EMC, what about previous LibreOffice versions? Did you have the same
> problem with 7.1.5 and 7.2.0.4?


No.
My trouble occurs for the first time in "/daily/master/Win-x86_64@tb77-TDF/2021-06-19_06.18.04/".
Previous versions includeng 7.2, 7.1 and "daily master Win-x86_64@tb77-TDF 2021-06-18_05.27.46" start with no problem.
Comment 15 QA Administrators 2021-08-29 04:09:42 UTC Comment hidden (obsolete)
Comment 16 Roman Kuznetsov 2021-08-29 10:03:13 UTC
I asked people with Vega 8 check this problem in daily build from 28-08-2021. They didn't have problem, but they have only Skia/Raster at once after LO started.

Device Index: 0
  Selected: true
  Device Name: gfx902
  Device Vendor: Advanced Micro Devices, Inc.
  Device Version: OpenCL 2.0 AMD-APP (3180.7)
  Driver Version: 3180.7 (PAL,HSAIL)
  Device Type: gpu 
  Device Extensions: cl_khr_fp64 cl_amd_fp64 cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_int64_base_atomics cl_khr_int64_extended_atomics cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_fp16 cl_khr_gl_sharing cl_khr_gl_depth_images cl_amd_device_attribute_query cl_amd_vec3 cl_amd_printf cl_amd_media_ops cl_amd_media_ops2 cl_amd_popcnt cl_khr_d3d10_sharing cl_khr_d3d11_sharing cl_khr_dx9_media_sharing cl_khr_image2d_from_buffer cl_khr_subgroups cl_khr_gl_event cl_khr_depth_images cl_khr_mipmap_image cl_khr_mipmap_image_writes cl_amd_liquid_flash cl_amd_copy_buffer_p2p cl_amd_planar_yuv
  Device OpenCL C Version: OpenCL C 2.0 
  Device Available: true
  Device Compiler Available: true
  Device Linker Available: true
  Platform Name: AMD Accelerated Parallel Processing
  Platform Vendor: Advanced Micro Devices, Inc.
  Platform Version: OpenCL 2.1 AMD-APP (3180.7)
  Platform Profile: FULL_PROFILE
  Platform Extensions: cl_khr_icd cl_khr_d3d10_sharing cl_khr_d3d11_sharing cl_khr_dx9_media_sharing cl_amd_event_callback cl_amd_offline_devices
Comment 17 JO3EMC 2021-08-29 11:13:44 UTC
(In reply to Roman Kuznetsov from comment #16)
> I asked people with Vega 8 check this problem in daily build from
> 28-08-2021. They didn't have problem, but they have only Skia/Raster at once
> after LO started.
> 
Yes.
I can also start it using Skia/Raster.
But the default setting of LO just after installed is Skia/Vulkan.
So, if I install LO in a clean environment, I will not be able to start it at all. Of course, I can't change the settings.
The same is true after changing the Skia setting.
Comment 18 JO3EMC 2021-08-29 11:17:53 UTC
I would like to say that the situation is ongoing with "/daily/master/Win-x86_64@tb77-TDF/2021-08-25_09.28.12".
Comment 19 JO3EMC 2021-09-12 13:31:46 UTC
As you know ...

I found 
$ORIGIN/share/skia/skia_denylist_vulkan.xml
, so I tried rewriting the 
<entry os="all" vendor="amd" compare="less_equal" version="2.0.49">
line to 
<entry os="all" vendor="amd" compare="less_equal" version="2.0.83">
, and of course LibreOfficeDev started without any problems.
Comment 20 JO3EMC 2021-09-12 13:35:16 UTC
Failed with
<entry os="all" vendor="amd" compare="less_equal" version="2.0.82">
Comment 21 himajin100000 2021-09-12 13:48:41 UTC
Do you find any newer graphic driver released from your PC vendor, not from windows update?

at least, this table doesn't mention the driver version you are using, and this is why I suspect the driver is from the PC vendor.

https://gpuopen.com/version-table/#more
Comment 22 JO3EMC 2021-09-12 14:39:23 UTC
(In reply to himajin100000 from comment #21)
> Do you find any newer graphic driver released from your PC vendor, not from
> windows update?
> 
> at least, this table doesn't mention the driver version you are using, and
> this is why I suspect the driver is from the PC vendor.
> 
> https://gpuopen.com/version-table/#more

My situation is reported in Comment 7.
This information is viewed with AMD tool "AMD RADEON SETTINGS" pre-installed on my PC.

As far as seeing the "HP Support Assistant" tool pre-installed on my PC, I don't think there is no update notifications about graphics drivers from my PC vendor.

Best of all, it works fine except for the recent LibreOffice.
Comment 23 JO3EMC 2021-09-13 03:43:59 UTC
I'm sorry that the testing was delayed, but I found that this issue has been resolved in recent nightly builds since
"/daily/master/Win-x86_64@tb77-TDF/2021-09-01_07.44.32/".

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d5ade739771ddf06cc7ee6d4af15672bfcf09ed6
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL

UI rendering has some trouble, but LO launches smoothly.
The latest confirmed one is
"/daily/master/Win-x86_64@tb77-TDF/2021-09-12_05.43.05/".

As reference information.
Nightly builds released from 2021-08-29 to 2021-08-31 behaved differently than those on 2021-08-25.
(The ones released from 2021-08-26 to 2021-08-28 are not available and have not been tried.)
They show no reaction immediately after the first launch (although a user profile is created) and when I try to launch it again it launches smoothly in Skia / Raster.
The comment 16 report may have said this.

"/daily/master/Win-x86_64@tb77-TDF/2021-08-31_05.41.16/"
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a866d63e0ac9de4ff7e59b3928f09ec21877bef3
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL