Bug 144499 - KDE: styles cannot be applied from drop down
Summary: KDE: styles cannot be applied from drop down
Status: RESOLVED DUPLICATE of bug 144037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 144579 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2021-09-14 14:34 UTC by Ryan Cragun
Modified: 2021-09-20 06:01 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is a screenshot showing me selecting the style from the formatting toolbar but to no avail. This no longer applies styles. (74.68 KB, image/png)
2021-09-14 14:34 UTC, Ryan Cragun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Cragun 2021-09-14 14:34:21 UTC
Created attachment 175023 [details]
This is a screenshot showing me selecting the style from the formatting toolbar but to no avail. This no longer applies styles.

I just upgraded to 7.2.1.2. In the previous version of LibreOffice Writer, I could apply a style to some text by selecting the text and then using the dropdown menu on the formatting toolbar and selecting the style I wanted to apply. As of 7.2.1.2, that no longer works. 

I can still apply styles from the sidebar by highlighting the text and selecting the style on the sidebar. But the dropdown option on the formatting toolbar no longer applies styles to text in LibreOffice Writer.

I write a lot, almost exclusively in LibreOffice Writer. And I use styles all the time. This is going to cause me a lot of problems even with the workaround.
Comment 1 Jean-Baptiste Faure 2021-09-14 17:00:32 UTC
Not reproducible for me with

Version: 7.2.2.0.0+ / LibreOffice Community
Build ID: 168065841250c190808261cf65afa00f9ecd52e7
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Ubuntu_20.04_x86-64
Calc: threaded

Note: it is not necessary to select the text you want apply a paragraph style to. It is enough to set the cursor in this paragraph.

What is the operating system of your computer?

Status has been set to NEEDINFO, please set it back to UNCONFIRMED once requested information has been provided.

Best regards. JBF
Comment 2 Ryan Cragun 2021-09-14 17:17:30 UTC
Operating System: Kubuntu 20.04 (with all updates applied). 
Kernel Version: 5.4.0-84-generic.
KDE Plasma: 5.18.5.
Comment 3 Jean-Baptiste Faure 2021-09-14 17:28:56 UTC
(In reply to Ryan Cragun from comment #2)
> Operating System: Kubuntu 20.04 (with all updates applied). 
> Kernel Version: 5.4.0-84-generic.
> KDE Plasma: 5.18.5.

Thank you. Please could you try with the generic backend (instead of kf5). In a terminal, use the following command to start LibreOffice:

SAL_USE_VCLPLUGIN=gen libreoffice

Best regards. JBF
Comment 4 Ryan Cragun 2021-09-14 17:33:32 UTC
The dropdown option from the toolbar worked when I loaded LibreOffice that way.

Does that mean the bug is with KDE?
Comment 5 Jean-Baptiste Faure 2021-09-14 18:38:20 UTC
(In reply to Ryan Cragun from comment #4)
> The dropdown option from the toolbar worked when I loaded LibreOffice that
> way.
> 
> Does that mean the bug is with KDE?

Indeed. I changed the summary accordingly.

Best regards. JBF
Comment 6 Julien Nabet 2021-09-14 19:57:59 UTC
How did you install 7.2.1.2 ?
I mean LO ppa doesn't contain 7.2.1.2.
If you use snap, you should contact them.
If you download deb files from tdf, have in mind that deb and rpm are more for repository maintainers since they check required dependencies.
Comment 7 Ryan Cragun 2021-09-14 20:00:35 UTC
I'm using a pre-release PPA:
http://ppa.launchpad.net/libreoffice/libreoffice-prereleases/ubuntu/

Given the problems I'm running into, I'm probably going to change to the version in the Kubuntu repositories. All sorts of problems are occurring with 7.2.1.2 - menus aren't working at all.
Comment 8 David 2021-09-14 21:56:52 UTC
It fails with qt5 and kde5 using the install packages from the LO archives and from a custom compiled version.  I would consider 7.2.1 not to be ready for release, as this is IMO a rather major bug.
Comment 9 Callegar 2021-09-15 00:05:00 UTC
See also bug 144485 that may be related.
Comment 10 Julien Nabet 2021-09-15 19:15:05 UTC
You should contact Ubuntu since they, not TDF, provide packages from PPA.
Comment 11 Robert Großkopf 2021-09-18 09:33:54 UTC
Could confirm the buggy behavior with

Version: 7.2.1.2 / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 6; OS: Linux 5.3; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded

There are more than only the styles which can't be set right with LO 7.2.1.2 and VCL: kf5.

Do this with kf5: 
Mark Text. 
Switch the color of text by choosing any color of the opened dialog.
Switching doesn't work.
Only setting color to the default red color for fonts will work. Switching back is impossible.

This buggy behavior isn't shown with LO 7.2.0.4.

And there are many more buttons with the same bug: Trying to input a table by button won't work, Trying to set the background color won't work …
Comment 12 Julien Nabet 2021-09-18 09:53:56 UTC
On pc Debian x86-64 with master sources updated today + kf5 rendering, I don't reproduce this.

Caolán: I noticed this on console
warn:legacy.osl:41864:41864:svl/source/items/custritm.cxx:70: CntUnencodedStringItem::PutValue(): Wrong type
warn:sfx:41864:41864:sfx2/source/appl/appuno.cxx:310: Property not convertible: Color
could it be related with tdf#144464 ?

Michael/Jan-Marek: since it seems specific to kf5, thought you might be interested in this one.
Comment 13 Caolán McNamara 2021-09-18 10:37:21 UTC
(In reply to Julien Nabet from comment #12)
> warn:legacy.osl:41864:41864:svl/source/items/custritm.cxx:70:
> CntUnencodedStringItem::PutValue(): Wrong type
> warn:sfx:41864:41864:sfx2/source/appl/appuno.cxx:310: Property not
> convertible: Color. Could it be related with tdf#144464 ?

That warning is tdf#144464, but that's not having an effect on this popup related problem which might be related to tdf#144037. Popup windows are always bizarrely difficult to get working right in all circumstances.
Comment 14 geraldg 2021-09-18 10:46:50 UTC
*** Bug 144579 has been marked as a duplicate of this bug. ***
Comment 15 Michael Weghorn 2021-09-20 06:01:38 UTC
(In reply to Caolán McNamara from comment #13)
> That warning is tdf#144464, but that's not having an effect on this popup
> related problem which might be related to tdf#144037. Popup windows are
> always bizarrely difficult to get working right in all circumstances.

Yes, that's tdf#144037, which is fixed in LibreOffice 7.2.2 (and 7.3).

*** This bug has been marked as a duplicate of bug 144037 ***