Bug 145658 - l10n - paragraph style name 'Quotations' not translated
Summary: l10n - paragraph style name 'Quotations' not translated
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK-Japanese
  Show dependency treegraph
 
Reported: 2021-11-13 11:35 UTC by JO3EMC
Modified: 2021-12-19 11:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot in 7.3.0.0a1 (400.09 KB, image/png)
2021-11-13 12:06 UTC, JO3EMC
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JO3EMC 2021-11-13 11:35:37 UTC
Description:
In the list of predefined paragraph styles of Writer, 'Quotations' is not translated in Japanese language.




Steps to Reproduce:
1. Open the "Options" dialog. ([Tool]-[Option] or "Alt + F12")
2. Follow [Language Settings]-[Languages].
3. Select "Japanese" in the [Language Of]-[User Interface:] field.
4. Press the "OK" button and restart LibreOffice.
5. Start "Writer".
6. Press the "F11" button to display the "Styles" side pane.

Actual Results:
The style name "Quotations" appears untranslated in the paragraph style.

Expected Results:
Expect to see the translated string.
It has already been translated on Weblate (Key ID = "xiVb7").
https://translations.documentfoundation.org/translate/libo_ui-master/swmessages/ja/?q=language%3Aja+note%3A%3DxiVb7


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.3.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 742b8befecbcfc0cfab87cfcd87c83b7d8ef32ab
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL

This issue seems to occur from 7.0.6.2 / 7.1.3.2.
Translations have been applied in 7.0.5.2 / 7.1.3.2.
I'm not sure if it's related, but I'd like to mention that the translation changes were applied in Weblate just in the meantime (2021-04-18).

The problem is currently confirmed only with ja-JP.
I looked at the situation of zh-CN and zh-TW, but it seemed that the translation was done.
(I can't read ko-KR and can't verify it.)

It has already been resolved, but it seems that similar issues have been reported in the past.

* Bug 93903 - Style sheet "Quotations" not translated into German language
* Bug 91376 - l10n - paragraph style name 'Quotations' not translated
* Bug 81465 - UI: the untranslated style "Quotations" in the styles list.
Comment 1 Ming Hua 2021-11-13 12:03:04 UTC
(In reply to JO3EMC from comment #0)
> In the list of predefined paragraph styles of Writer, 'Quotations' is not
> translated in Japanese language.
> 
> [...]
> 
> It has already been resolved, but it seems that similar issues have been
> reported in the past.
> 
> * Bug 93903 - Style sheet "Quotations" not translated into German language
> * Bug 91376 - l10n - paragraph style name 'Quotations' not translated
> * Bug 81465 - UI: the untranslated style "Quotations" in the styles list.
If you look through these resolved bugs, you will find the reason the translation is missing from the UI.  For example in https://bugs.documentfoundation.org/show_bug.cgi?id=81465#c6 :

> Helen, there is one more thing. Translations of STR_POOLCOLL strings must be
> unique. In Russian: 
> STR_POOLCOLL_TOX_CITATION Citation Цитата
> STR_POOLCOLL_HTML_BLOCKQUOTE Quotations Цитата
> 
> It is wrong, you must choose a different translation.
And here you have exactly the same problem with Japanese translation.  The string STR_POOLCOLL_TOX_CITATION "Citation" is already translated as "引用":
https://translations.documentfoundation.org/translate/libo_ui-master/swmessages/ja/?checksum=b30b5438af191790

If I remember correctly, you are a UI translator yourself.  So you (and other Japanese translators) need to decide on a different translation, making STR_POOLCOLL_TOX_CITATION "Citation" and STR_POOLCOLL_HTML_BLOCKQUOTE "Quotations" distinctive.

> I'm not sure if it's related, but I'd like to mention that the translation
> changes were applied in Weblate just in the meantime (2021-04-18).
The change made on 2021-04-18 was ill-advised and changed two different translations ("引用" and "引用句") to be the same.
Comment 2 JO3EMC 2021-11-13 12:06:56 UTC
Created attachment 176229 [details]
Screenshot in 7.3.0.0a1
Comment 3 JO3EMC 2021-11-13 13:25:03 UTC
Ming Hua:

I see ...
I didn't know that "translation of STR_POOLCOLL string must be unique". I didn't read enough of the discussion in the existing report.
I don't understand the details of the restrictions, but I understood that the problem can be avoided by distinguishing the translated words.

The distinction between "Citation" and "Quotation" is not clear in Japanese, and I think that both are often translated as "引用". It is quite difficult to properly use the appropriate translation, but I would like to consult with other translators to deal with it.

It's also annoying that I can't find the place where "Citation" appears on the UI ...

Thanks for your help.
Comment 4 Kevin Suo 2021-11-15 13:01:49 UTC
If we have different SIDs for two different string but they need to be translated differently in order to show on the UI, then there must be a bug.
Comment 5 Kevin Suo 2021-11-15 13:21:14 UTC
Oh sorry, this is not a bug - For those style names within in the same category (e.g. Paragraph Styles), the names must be unique. In other words, you can not have two styles both named 引用, even if the have different parents. The same rule applies when you create styles on the UI.

So please revise the translation on weblate.

I think there should be a check for this kind of errors in our PO Check script.
Comment 6 Kevin Suo 2021-11-15 13:25:43 UTC
> I think there should be a check for this kind of errors in our PO Check script.

And should someone update the wiki to explain and document this?
Comment 7 sophie 2021-11-15 14:04:58 UTC
(In reply to JO3EMC from comment #3)
(In reply to JO3EMC from comment #3)
> Ming Hua:
> 
> I see ...
> I didn't know that "translation of STR_POOLCOLL string must be unique". I
> didn't read enough of the discussion in the existing report.
> I don't understand the details of the restrictions, but I understood that
> the problem can be avoided by distinguishing the translated words.

Each style name has to be unique, see
https://wiki.documentfoundation.org/UI_and_Help_files_Content_Guide
> 
> The distinction between "Citation" and "Quotation" is not clear in Japanese,
> and I think that both are often translated as "引用". It is quite difficult to
> properly use the appropriate translation, but I would like to consult with
> other translators to deal with it.

Please post on the l10n list for that
> 
> It's also annoying that I can't find the place where "Citation" appears on
> the UI ...

Yes it's annoying that we don't have a reverse search with keyID, but it's a style name :)
Comment 8 Ming Hua 2021-11-15 16:27:27 UTC
(In reply to Kevin Suo from comment #5)
> I think there should be a check for this kind of errors in our PO Check
> script.
I'm pretty sure we already do.  I checked the .po file for Japanese in the git repo, and this whole entry for "Quotations" is missing there, presumably detected and deleted by the po-check scripts.

I wish there is a way translators can check the po-check output to spot anything suspicious for their language, though.  (Maybe the result of the po-check script run is already published somewhere and I just am not aware?)
Comment 9 sophie 2021-11-15 16:47:55 UTC
(In reply to Ming Hua from comment #8)
> (In reply to Kevin Suo from comment #5)
> > I think there should be a check for this kind of errors in our PO Check
> > script.
> I'm pretty sure we already do.  I checked the .po file for Japanese in the
> git repo, and this whole entry for "Quotations" is missing there, presumably
> detected and deleted by the po-check scripts.

Yes and the string is in fuzzy state on Weblate
> 
> I wish there is a way translators can check the po-check output to spot
> anything suspicious for their language, though.  (Maybe the result of the
> po-check script run is already published somewhere and I just am not aware?)

On Weblate, under Tools menu at the top, there is a Failing checks entry. I think those errors are also reported along with xml failing checks.
Comment 10 JO3EMC 2021-11-17 11:44:58 UTC
Thank you, everyone.
I agree. I have no doubt that this issue is NOT A BUG.

I have already fixed the translation of Weblate.
Now, I'm just waiting for it to be reflected in the build.

Including the rules of Unique Terms, it was my ignorance that I didn't know the Wiki page "UI and Help files Content Guide" that sophie taught me.
I would like to share information again in the Japanese local community too.

By the way, I can't confirm it now, but before the fix, on Weblate, I think there was no error report similar to XML failing checks.

Regarding "Quotations" in this issue, I couldn't find the conflicting style name "Citation" on UI.
There were no duplicate style names on UI.
Also, there are only three "Citations" on the UI, including the invisible style name that caused the collision here.
https://translations.documentfoundation.org/search/?q=language%3Aen+project%3A%22libo_ui-master%22+source%3A%22citation%22
Such a lack of encounter opportunities on UI may have contributed to my mistake, I think.

Anyway, first of all, it may be necessary for me to review the translation of "Citation" in Japanese.
Comment 11 JO3EMC 2021-12-19 11:01:37 UTC
I have confirmed that the translation fix has been reflected in the build.
I would like to close the issue.