Bug 145826 - Single column footnotes in double column section
Summary: Single column footnotes in double column section
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.0.alpha1+
Hardware: All Linux (All)
: high normal
Assignee: Attila Szűcs
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, regression
: 145825 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-11-22 10:45 UTC by David
Modified: 2021-12-11 07:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
double column section with footnotes (15.01 KB, application/octet-stream)
2021-11-22 10:45 UTC, David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2021-11-22 10:45:53 UTC
Created attachment 176419 [details]
double column section with footnotes

When using a double column section, the footnotes are only displayed in a single column. This is a regression beginning with version 7.3 alpha.
Comment 1 David 2021-11-22 16:27:04 UTC
A likely candidate for this regression seems to be commit https://git.libreoffice.org/core/+/4c31b4ef2083087a822c3ae648fd09acc67d2f88%5E%21.
Comment 2 Attila Szűcs 2021-11-24 13:57:12 UTC
This gerrit 
https://gerrit.libreoffice.org/c/core/+/125442
will solve the problem for old odt files

For newly created odt files, you can still reach the same layout, by setting:
Format -> Sections... -> Options... -> Footnotes/Endnotes ->
 Collect at end of text
+ inserting a page break, if needed

funny thing that Bug 138508 ask exactly the opposite of this ticket :)

Note:
LibreOffice never really supported multy-column footnotes. 
The footnotes can be at the end of its page, or at the end of its text column.
(MSWord support only the end-of-page footnotes, but can put them in multiple columns regardless of how many columns there are on the page)

If a footnote is at the end of its column, then it is part of the column... 
and if "Collect at end of text" is not set, then it should look like the footnote is at the end of the page... 
but if (page end not equal with column end) then it would be a logical contradiction...
to avoid the contradiction someone (20+ years ago) forced these sections to occupy the full page.. even if it had only 2 line of text.. that is Bug 54465

before my commit, footnotes in a column, was always put into its column end.. and every other case it was put into its page end.

Now you can 'choose' (with 'Collect at end of text') where to put the footnote.. into its column, or into its page.
(beeing in a section and in an 'evenly distributed column' also a requirement to put the footnotes into the page end.)
Comment 3 Kevin Suo 2021-11-25 09:34:32 UTC
Change status to ASSIGNED per comment 2.
Comment 4 Xisco Faulí 2021-11-25 13:12:44 UTC
(In reply to David from comment #1)
> A likely candidate for this regression seems to be commit
> https://git.libreoffice.org/core/+/
> 4c31b4ef2083087a822c3ae648fd09acc67d2f88%5E%21.

I do confirm this regression was introduced by this commit
Comment 5 Attila Szűcs 2021-11-29 12:29:33 UTC

*** This bug has been marked as a duplicate of bug 54465 ***
Comment 6 Attila Szűcs 2021-11-29 13:11:08 UTC
the mentioned gerrit https://gerrit.libreoffice.org/c/core/+/125442
is merged for Bug 54465 
The attached (old odt) file now should be displayed so the footnotes are displayed in 2 columns.
Comment 7 David 2021-11-29 17:56:34 UTC
Verified fixed with https://gerrit.libreoffice.org/c/core/+/125442
Comment 8 Xisco Faulí 2021-11-30 17:29:13 UTC
I don't think this is a duplicate of bug 54465 nor of 139336 since both issues were reported long time ago. Let's keep this one as RESOLVED FIXED independingly
Comment 9 Commit Notification 2021-12-01 08:19:41 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/26f976aad49683f18e62219a2b5c0efcb38090d4

tdf#145826: sw_layoutwriter: Add unittest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2021-12-01 09:25:05 UTC
*** Bug 145825 has been marked as a duplicate of this bug. ***