Bug 147062 - [GTK] shortcut Ctrl+Alt+<letter> works as Alt+<letter> : opens the first menu starting with <letter>
Summary: [GTK] shortcut Ctrl+Alt+<letter> works as Alt+<letter> : opens the first menu...
Status: RESOLVED DUPLICATE of bug 146739
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.3 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 145924 (view as bug list)
Depends on:
Blocks: GTK3 Shortcuts-AltGR
  Show dependency treegraph
 
Reported: 2022-01-29 18:25 UTC by Jean-Baptiste Faure
Modified: 2022-02-19 20:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2022-01-29 18:25:25 UTC
Description:
With the GTK backend, Ctrl+Alt+<letter> opens the first menu with name starting with letter <letter>.
As a consequence assigning for example Ctrl+Alt+O to the Text Body paragraph style, this shortcut opens the Outils menu instead (in French corresponding to Tools menu).
In previous versions, including 7.1, it worked as expected : Ctrl+Alt+<letter> does not open a menu. Only Alt+<letter> does.

Steps to Reproduce:
1. Assign Ctrl+Alt+O (because Ctrl+0 is not usable on a notebook without numeric pad) to the Text Body style
2. Create a new text document and insert some text with style paragraph
3. Hit Ctrl+Alt+O to this paragraph

Actual Results:
In the French version, that opens the Outils (Tools) menu. In the English version, that opens the Format menu.

Expected Results:
Apply the Text Body style


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Reproduced in LO 7.2.6.0.0+, LO 7.3.1.0.0+ and current master
Works as expected in LO 7.1.8.0.0+

Works as expected if I use the generic backend instead of GTK3 one.
Comment 1 Jean-Baptiste Faure 2022-01-31 16:16:41 UTC
Forgot to add regression keyword.

Best regards. JBF
Comment 2 Michael Warner 2022-02-19 14:12:02 UTC
*** Bug 145924 has been marked as a duplicate of this bug. ***
Comment 3 Jean-Baptiste Faure 2022-02-19 15:46:43 UTC
(In reply to Michael Warner from comment #2)
> *** Bug 145924 has been marked as a duplicate of this bug. ***

So, this duplicate confirms my bug report. Setting as NEW.

Best regards. JBF
Comment 4 Caolán McNamara 2022-02-19 19:43:42 UTC
I don't know if there is going to be any solution that fully satisfies the conundrum

*** This bug has been marked as a duplicate of bug 146739 ***