Bug 156885 - add toggle to show / hide authorship metadata in popup Calc comments
Summary: add toggle to show / hide authorship metadata in popup Calc comments
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.6.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL: https://ask.libreoffice.org/t/comment...
Whiteboard: target:24.8.0 inReleaseNotes:24.8
Keywords: needsDevAdvice
: 159344 159739 160134 160656 (view as bug list)
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
 
Reported: 2023-08-23 22:09 UTC by Josh
Modified: 2024-06-26 08:39 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josh 2023-08-23 22:09:42 UTC
Add an option to show, and not show, metadata in Calc's comment system.

NOTES: https://ask.libreoffice.org/t/comments-in-calc-added-dates-after-updating-from-7-5-to-7-6/94934/3
Comment 1 Stéphane Guillou (stragu) 2023-08-25 20:47:15 UTC
Balázs, I understand we don't have a way to turn that off currently, is that right?

In Tools > Options > LibreOffice Calc > View > Display, we already have "Comment indicator". I could imagine having "Comment authorship" in there as well.
Comment 2 Balázs Varga (allotropia) 2023-08-25 21:13:26 UTC
(In reply to Stéphane Guillou (stragu) from comment #1)
> Balázs, I understand we don't have a way to turn that off currently, is that
> right?
> 
> In Tools > Options > LibreOffice Calc > View > Display, we already have
> "Comment indicator". I could imagine having "Comment authorship" in there as
> well.

Yes, there is no config key to turn on/off this feature. Can be add ofc, but should be the default value true/turned on, I think.
Comment 3 Heiko Tietze 2023-08-28 09:59:34 UTC
Why should we make metadata optional in Calc but not other modules? What is the deal to hide the authorship from comments anyway?
Comment 4 Stéphane Guillou (stragu) 2023-08-28 10:41:52 UTC
(In reply to Heiko Tietze from comment #3)
> Why should we make metadata optional in Calc but not other modules? What is
> the deal to hide the authorship from comments anyway?

Because comments are used very differently in Calc, with their position and size relative to the rest of the content possibly being something important to the user (i.e. sized to not hide spreadsheet contents), and with the authorship possibly being completely irrelevant. (i.e. comments used as instruction popups. Users would be annoyed seeing author names and dates polluting the content.)

I previously thought they should be made more consistent with Writer's comment but Maxim's comments in bug 73537 comment 7 (and the discussion on gerrit) made me reconsider.
Comment 5 Heiko Tietze 2023-08-28 11:32:29 UTC
All good points but it still feels wrong to have an expert option. The sidebar idea sounds good, and I could imagine a function to clear metadata from (own) comments.
Comment 6 ady 2023-08-28 12:24:45 UTC
(In reply to Heiko Tietze from comment #5)
> All good points but it still feels wrong to have an expert option. The
> sidebar idea sounds good, and I could imagine a function to clear metadata
> from (own) comments.

FWIW, only recently Calc added the additional info to the comments. Additionally, normal comments (or "notes") in Calc are not the same as "tracking changes" comments, in which the author and date+time data probably have greater importance.

There are cases in which automatically adding this info in each comment might be useful, but there are (many) cases in which users want a _minimal_ comment (such as instructions, or a reminder), especially when the spreadsheet is aimed at themselves (not to be shared or edited by others). In those later cases, repeating unnecessary text within each comment is not useful (or even distracting, or even bothering).

Some Calc users might even claim that this (recently) added data should be OFF by default, imitating what was the "normal" situation until recently in LO Calc.

The (recently) added data might be useful for some users, but might be counterproductive too, so it needs some kind of toggle option or method to set it ON/OFF.
Comment 7 Stéphane Guillou (stragu) 2023-08-28 23:10:54 UTC Comment hidden (obsolete)
Comment 8 Stéphane Guillou (stragu) 2023-08-28 23:12:10 UTC
(In reply to Stéphane Guillou (stragu) from comment #7)
> What is the sidebar idea?

Ah, from Maxim's comment, got it.
Comment 9 Josh 2023-08-29 02:16:50 UTC
(In reply to Heiko Tietze from comment #3)
> Why should we make metadata optional in Calc but not other modules? What is
> the deal to hide the authorship from comments anyway?

It threw me off because it wasn't there before the update, and I have alot of comments.  I have use comments as a '3d spreadsheet' then use find to 'countif' the comments (or tags) of repeating patterns in the data set.
Comment 10 QA Administrators 2023-08-29 03:18:41 UTC Comment hidden (obsolete)
Comment 11 Eyal Rozenberg 2023-08-30 21:16:36 UTC
My opinion:

* Showing or hiding authorship metadata should indeed be toggle-able.
* It should be off by default
* The toggle should not be difficult to locate. Perhaps such a (global) toggle could appear even in the in-comment context menu.
* We could very well consider such a toggle for other modules; the fact that they don't have a toggle is not a reason to avoid adding one in Calc (especially since it seems to matter more here)
* It would be even better if the timestamp and the author could be toggled separately from each other. I might care about the date but know all comments are from just one person, for example.
Comment 12 Heiko Tietze 2023-09-08 06:42:00 UTC
The topic was on the agenda of the design meeting.

The majority agrees with the request and welcome an option. Rather than disabling a functionality I think we add a function to clear the meta data. 

And showing comments in a sidebar would be very beneficial for Calc.
Comment 13 Ian Hodge 2023-11-30 17:28:37 UTC
I completely agree with comments #4 and #11

Comments in calc are not used for tracking changes and this extra info now being displayed in every comment is distracting and generally of no interest to most users I imagine. The new giant magenta triangle that has replaced the previous small red one to indicate a hidden comment is also distracting!
Comment 14 bphft 2023-12-13 08:07:56 UTC
I too would like the option to remove this info from comments. It's an annoying nuisance cluttering up my calc comments with extra lines I don't need or want. It can be a useful feature for shared documents that have multiple editors but it's irrelevant to a person who only uses Liber Office apps for personal, private documents and projects.
Comment 15 Stéphane Guillou (stragu) 2023-12-18 11:26:20 UTC
(In reply to Heiko Tietze from comment #12)
> The majority agrees with the request and welcome an option. Rather than
> disabling a functionality I think we add a function to clear the meta data. 
The fix for bug 156336, available in 24.2, allows removing metadata via Tools > Options > LO > Security > Options > Remove personal information on saving (like Writer allows).
However, this is buried deep into the options dialog, and more importantly: the anonymised information "AuthorX, day/month/year" is still visible in comments.

Comments sidebar deck is tracked in bug 106316.
Comment 16 Eike Rathke 2024-01-23 17:54:50 UTC
*** Bug 159344 has been marked as a duplicate of this bug. ***
Comment 17 thomasxb 2024-01-23 18:08:02 UTC
I completely agree with comments #4, #11, #13 and #14

There should be a configuration setting to disable the display of "AuthorX, day/month/year". And I would propose to disable this by defualt for Unknown authors, to avoid the display of "Unkown Author, day/month/year" at all.
Comment 18 Rafael Lima 2024-01-23 22:28:59 UTC
(In reply to Heiko Tietze from comment #12)
> The topic was on the agenda of the design meeting.

I know that this has already been discussed in a previous design meeting, but I would like to propose the following solution:

We can create a new Uno command to toggle the visibility of the comment's authorship... it could be placed in the View menu ("View - Comment Authorship").

If the toggle is unchecked, hovering over a cell with a comment would not display author and date.
Comment 19 ady 2024-01-24 03:24:05 UTC
An alternative would be to leave the comment always untouched, and the author+date_time could be only added to a second/separate optional balloon, possibly with its own comment-like features (show, hide, size, edit or whatever). IDK whether such item could be supported by ODF.

The forced addition of the author+date_time info within current/existing comments has broken too many properties of the normal comments already (e.g. inserted pictures being distorted; position or size of comments; unwanted info in many cases,...)
Comment 20 Heiko Tietze 2024-01-24 08:42:37 UTC
(In reply to Rafael Lima from comment #18)
> View - Comment > Authorship
Smalls like feature-creep to me. Keep it simple, stupid ;-)
Comment 21 Rafael Lima 2024-02-15 16:57:01 UTC Comment hidden (me-too)
Comment 22 Ian Eales 2024-03-10 19:50:03 UTC
Calc comments have been fine. A large portion users likely don't colaborate, so the additional information breaks a perfectly good system that has worked for years.

There are too many open bugs that impact everyday functionality that should be fixed before next to useless changes are added.
Comment 23 Stéphane Guillou (stragu) 2024-03-26 11:12:44 UTC Comment hidden (me-too)
Comment 24 knecker 2024-04-08 12:52:14 UTC Comment hidden (me-too)
Comment 25 Ian Eales 2024-04-10 14:05:47 UTC Comment hidden (me-too)
Comment 26 ady 2024-04-13 19:42:52 UTC
*** Bug 160656 has been marked as a duplicate of this bug. ***
Comment 27 Ian Hodge 2024-05-06 13:58:59 UTC
It's nine months since this unwanted 'feature' was added. When is it going to be fixed? If adding a toggle is so hard, perhaps the patch that added this 'feature' could be reverted or backed out?
Comment 28 Jeffrey Alan Klute 2024-05-06 23:51:40 UTC
(In reply to Ian Hodge from comment #27)
> It's nine months since this unwanted 'feature' was added. When is it going
> to be fixed? If adding a toggle is so hard, perhaps the patch that added
> this 'feature' could be reverted or backed out?

I agree 100% with your comment, Ian, it was a very unwanted 'feature' for the way I use Calc. I won't upgrade into the mess created by this 'improvement' because it will break some huge spreadsheets I work with daily and require a lot of rework. That is, all upgrades to Calc are on hold until a way to easily "kill" this unwanted feature is provided.

Importance should not be "enhancement" but "major" or "critical."
Comment 29 Heiko Tietze 2024-05-07 06:58:23 UTC
Since you ask so kindly... https://gerrit.libreoffice.org/c/core/+/167260
Comment 30 Heiko Tietze 2024-05-07 13:49:05 UTC
Added the option "Comment authorship" under tools > options > calc > view, which controls whether the additional information is shown on hover.
Comment 31 Commit Notification 2024-05-07 13:49:06 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a5d0114bbb40f5bffcb19d6e6b3a5bf43aab1446

Resolves tdf#156885 - Make comment authorship optional

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Ian Eales 2024-05-07 14:23:06 UTC Comment hidden (noise)
Comment 33 Heiko Tietze 2024-05-07 14:28:18 UTC Comment hidden (noise)
Comment 34 Ian Eales 2024-05-07 14:37:18 UTC Comment hidden (noise)
Comment 35 ady 2024-05-07 16:46:45 UTC Comment hidden (noise)
Comment 36 Ian Eales 2024-05-07 17:59:08 UTC Comment hidden (noise)
Comment 37 Heiko Tietze 2024-05-08 08:52:29 UTC Comment hidden (noise)
Comment 38 ady 2024-05-08 11:10:43 UTC Comment hidden (noise)