Download it now!
Bug 32899 - [Mailmerge] Impossible to get a document per record when mail merging in a file
Summary: [Mailmerge] Impossible to get a document per record when mail merging in a file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium critical
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords: regression
: 34428 35119 39335 39451 (view as bug list)
Depends on:
Blocks: 34184
  Show dependency treegraph
 
Reported: 2011-01-07 07:13 UTC by sophie
Modified: 2011-08-04 15:46 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sophie 2011-01-07 07:13:35 UTC
Steps to reproduce
- Open a new writer file, 
- hit F4 to display the registered databases, click on Bibliography table to display the records
- Drag and drop fields header from database to the document (2 is enough)
- File > Print, then said yes to the dialog box asking to print a form letter
- in the dialog that opens, select 3 records in the table
- select File as Output, Save as Individual Documents and then click ok, 
==> as a result you get only one file instead of the 3 (one per record) you should have 

It is seen as critical by several of our users because this type of output is more used in companies than an output in only one file containing all the records. 
Sophie
Comment 1 Alex Thurgood 2011-02-04 09:58:15 UTC
Confirming on Mac OSX. This is a stopper for me.

Concrete business example :

Patent renewal fee reminders sent to clients. Query database, use query to fill in a template that fits to headed letter paper (so particular formatting), each renewal fee reminder must end up in a separate file, not just for convenience, but because each one is particular to a given client (and stored individually), thereby respecting confidentiality issues.


Alex
Comment 2 Alex Thurgood 2011-02-04 09:58:44 UTC
It is also a regression compared to OOo 3.2.1
Comment 3 Alex Thurgood 2011-02-04 09:59:37 UTC
Changing version to releass because bug still present.
Comment 4 Alex Thurgood 2011-02-18 00:55:37 UTC
*** Bug 34428 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2011-03-07 04:34:29 UTC
Can reproduce this in 3.3.1 on Ubuntu
Comment 6 Rainer Bielefeld Retired 2011-03-08 22:18:47 UTC
*** Bug 35119 has been marked as a duplicate of this bug. ***
Comment 7 Rainer Bielefeld Retired 2011-03-08 22:26:28 UTC
It's annoying, but I do not believe that it's a critical bug, because function will work fine from Mail Merge Wizard. Only for those who are used to select Addresses manually that alternative will not work.

Might be related: Save-Monitor-Message remains empty for me when saving from Print menu, but shows progress when saving from Mail Merge Wizard.
Comment 8 vitriol 2011-03-08 22:34:22 UTC
@Rainer Bielefeld
An option shown in the UI is completely broken, than I think it's a serious bug. I don't us the wizard, like many other (advanced?) users...
Comment 9 Heinz Repp 2011-03-21 09:34:43 UTC
@Rainer Bielefeld:

Unfortunately, function from Mail Merge Wizard DOES NOT WORK fine for me as it seems to be affected by my OOo bug 88451 (mail merge deletes section on save to one, http://openoffice.org/bugzilla/show_bug.cgi?id=88451): it seems to create the individual documents by going through a combined document, all target pages are splitted into two pages. Saving to individual documents did work in OOo 3.2.1 and kept the layout, with LibreOffice 3.3.0/1 I have NO WAY to print my mail merge letters other than using F4, values to fields, print normal, select next row, values to fields, print normal, ... Fortunately I have usually not more than 30 records, so this is possible, it would not work with significantly bigger tables. This IS a show stopper.

And about the wizard: I tried to train secretaries to use the wizard, without much success. The straightforward direct approach was much more successful, so I believe most frequent mail merge users will not use the wizard at all, especially in companies. So this regression should be fixed ASAP.
Comment 10 Espen 2011-03-22 04:00:33 UTC
@Rainer Bielefeld

Is this a critical bug or not depends if LibreOffice should be an amateur software or a professional software?

Is this just going to be a software for private use, it's not that important, but if LibreOffice should be a competitor for MS Office and be useful for companies. This is very critical.  

I am doing mail merge with about 400 records per month and if mail merge is not working, LibreOffice is no option. There is no way I will type in 400 records manually and print them out. And in a business view. Thing should just work. If not, you go for another option, because time is money for businesses.

I have been recommended OpenOffice/ LibreOffice for many years, but it has been harder and harder to recommend it since the mail merge wizard has never worked and still not, and now in LibreOffice 3.3.x the workaround is not working either. Which means I using two versions on my computer. I have OOo 3.2.1 and LibreOffice 3.3.1. Print out with the first and work on the last.

The workaround in OOo 3.2.1 is as follows:
- F4, 
- drag fields into document, 
- print normal, 
- yes to question, 
- tick of single print outs(very important - we have a professional printer which can fold and staples the print outs, which means, if I don't tick of this, the printer will print all records and then fold them together and staple them together! instead of fold each record and staple them separately), 
- choose from 1 to n+1(if I only choose to n, it will not print out the n-record), 
- OK, 
- check the printer settings(since it doesn't remember the printer settings from time to time).

I have been using OOo since version 1 and used different ways of workarounds throughout the versions history. For every new version, I had to find a new way round to mail merge.
Comment 11 Francois 2011-04-07 13:09:48 UTC
Bug still present in LO 3.3.2
Comment 12 vitriol 2011-04-07 13:19:02 UTC
This bug was already fixed in OOo:

http://openoffice.org/bugzilla/show_bug.cgi?id=116336
Comment 13 ribotb 2011-06-03 03:09:36 UTC
Bug still present in LibO 3.4rc2 (Windows 7 SP1).
Comment 14 Heinz Repp 2011-07-01 11:08:36 UTC
(In reply to comment #12)
> This bug was already fixed in OOo:
> 
> http://openoffice.org/bugzilla/show_bug.cgi?id=116336

Just in case, developers didn't find it, this is what they changed in OOo to fix this issue:

http://hg.services.openoffice.org/DEV300/rev/c82a607f1f92

so hopefully someone will pick this up, as we left 3.3.0 far behind, and still this bug - now correctly classified as critical and as one of the most annoying bugs - failed to attract sufficient attention and is still present in 3.4.1. Wouldn't just porting the OOo changes to LibO do the job already?
Comment 15 Alex Thurgood 2011-07-21 08:16:10 UTC
*** Bug 39335 has been marked as a duplicate of this bug. ***
Comment 16 Tom 2011-07-21 10:20:55 UTC
*** Bug 39335 has been marked as a duplicate of this one ***
Comment 17 Rainer Bielefeld Retired 2011-07-21 22:31:12 UTC
*** Bug 39451 has been marked as a duplicate of this bug. ***
Comment 18 Caolán McNamara 2011-08-04 15:22:32 UTC
http://hg.services.openoffice.org/DEV300/rev/c82a607f1f92 is a combined bunch of changes, the apparent specific bit required is a backport of

http://cgit.freedesktop.org/libreoffice/writer/commit/?id=2c284c0d082c4dff8545e51b8b2c58324d59f9b0