Bug 33591 - Transparency gradient edge case different in edit mode / slideshow mode
Summary: Transparency gradient edge case different in edit mode / slideshow mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 RC4
Hardware: All All
: medium normal
Assignee: Radek Doulik
QA Contact:
URL:
Whiteboard: target:3.6.0 target:3.5.3
Keywords:
: 36470 36547 39905 39924 (view as bug list)
Depends on:
Blocks: Impress-Gradient mab3.5
  Show dependency treegraph
 
Reported: 2011-01-27 06:45 UTC by maddoxflower
Modified: 2014-07-14 19:31 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Minimal presentation to reproduce the bug. (30.76 KB, application/vnd.oasis.opendocument.presentation)
2011-01-27 06:45 UTC, maddoxflower
Details
additional minimal test case (15.94 KB, application/vnd.oasis.opendocument.presentation)
2011-03-08 15:37 UTC, Jean-François Fortin Tam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description maddoxflower 2011-01-27 06:45:38 UTC
Created attachment 42591 [details]
Minimal presentation to reproduce the bug.

Area transparency does not work properly in presentation mode. Simplest way to reproduce (see also attachment):
1. Create a rectangle on top of some text
2. Fill color: white
3. Choose transparency 50%. Rectangle is correctly displayed (Normal view).
4. Switch into presentation mode: The rectangle appears in transparent gray, not transparent white (if you choose a different fill color, light red for instance, the transparency also seems to translate into a gray shaded red).
5. There is a way around the problem: Choose a linear transparency gradient with start value 50% and end value 50%. Funnily, the rectangle is fully transparent in Normal view, but appears 50% transparent (white) in presentation mode.
Comment 1 Jean-François Fortin Tam 2011-03-08 15:37:50 UTC
Created attachment 44251 [details]
additional minimal test case

I'm also seeing this. The color rendering of transparent gradients is completely different in editing mode than in presentation view.
Comment 2 toddrme2178 2011-03-28 09:48:24 UTC
I'm having this problem as well.  It applies both to transparencies in the main document and those in the master pages.
Comment 3 Derek Keats 2011-05-01 01:48:32 UTC
I get the same problem and it is a big issue for people using LO for presentations. I would hope this can be given a higher priority because transparency is an important aspect of making good presentations. I am happy to help testing.
Comment 4 Rainer Bielefeld Retired 2011-05-02 04:39:52 UTC
[Reproducible] with "additional minimal test case" and "LibreOffice 3.4Beta3  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:3)]". In presentation mode there is an additional grey in the transparnet colors green and brown.

Related to "Bug 36470 - Transparency rendering grey instead of white in presentation mode"?
Comment 5 Christopher M. Penalver 2011-05-17 09:33:18 UTC
*** Bug 36470 has been marked as a duplicate of this bug. ***
Comment 6 Radek Doulik 2011-07-12 04:42:05 UTC
I have fixed this problem in master branch and sent for review to include in 3-4 branch as well.
Comment 7 Raphaël 2011-08-05 10:26:36 UTC
I suggest to reopen this bug: see my attachment and comment in bug 36766 !
Comment 8 Rainer Bielefeld Retired 2011-08-07 08:06:39 UTC
I still see the problem with Master "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI, but I think code base of that version (master~2011-07-11_09.48.50_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe) can't contain the fix. 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"


@Radek:
Can you please contribute target or GIT information?

@Raphaël
What information do you have that the fix has been integrated into code for 3.4.2? Please do not modify pickers if you are not sure concerning interrelations and consequences.

I will close this bug again without new information.
Comment 9 Raphaël 2011-08-07 09:48:29 UTC
(In reply to comment #8)
> I still see the problem with Master "LibO-dev 3.4.5  – WIN7  Home Premium 
> (64bit) English UI, but I think code base of that version
> (master~2011-07-11_09.48.50_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe) can't
> contain the fix. 
> [(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
>     2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
>     6a9633a-931d089-ecd263f-c9b55e9-b31b807
>     82ff335-599f7e9-bc6a545-1926fdf)]"
> 
> 
> @Radek:
> Can you please contribute target or GIT information?
> 
> @Raphaël
> What information do you have that the fix has been integrated into code for
> 3.4.2? Please do not modify pickers if you are not sure concerning
> interrelations and consequences.
> 
> I will close this bug again without new information.


My information about the integration of the fix patch in version 3.4.2 was the fact that something changed from 3.4.1: the issue as described in comment 0 seems to be fixed now. But the problem isn't: in the file attached in comment 5 bug 36766, you can see that, for instance, black areas with transparency gradient on black background turn gray in presentation mode !

So, if the problem seems to be solved for 'simple' transparency areas, it is not the case for 'gradient' transparency areas, so I think it is better to re-open this bug than to open a new one called 'Area with gradient transparency turns gray in presentation mode'... Issue clearly connected with bug 35681.
Comment 10 Rainer Bielefeld Retired 2011-08-08 04:06:39 UTC
*** Bug 39905 has been marked as a duplicate of this bug. ***
Comment 11 Rainer Bielefeld Retired 2011-08-11 02:18:01 UTC
@Raphaël:
(In reply to comment #9)

The only interesting fact would be that you show that in build where the fix is integrated still shows the problem (also from Bug 39905) "grey instead of transparent". This info still is missing, so I close this bug again.

Please feel free to reopen the Bug if you can contribute a build name with integrated fix that still shows the "additional grey" problem.

BTW, the effect from Report step 5 es something completely different, DUP of "Bug 39924 - VIEWING shapes with transparent color gradient filling wrong for equal start and end value"
Comment 12 Rainer Bielefeld Retired 2012-02-29 09:43:37 UTC
@Radek:
For me the problem is visible with "additional minimal test case" and also with both samples from "Bug 36547 - Impress: Rendering problems with some .odp files" <https://bugs.freedesktop.org/show_bug.cgi?id=36547> using
"LibreOffice 3.5.1.1 German UI/Locale [Build-ID: 45a2874-aa8c38d-dff3b9c-def3dbd-62463c8] on German WIN7 Home Premium (64bit) 
and with 
"LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit)

I reopen this bug because I can't find any version in the past for what the "transparency turns gray" problem has been solved and git information still is missing.


@Radek:
May I remind you to my 8? Can you please check?
Comment 13 Rainer Bielefeld Retired 2012-02-29 09:52:15 UTC
*** Bug 36547 has been marked as a duplicate of this bug. ***
Comment 14 Thorsten Behrens (CIB) 2012-04-12 02:59:08 UTC
Much of this is fixed with bug 45219 (a slew of transparency issues, shown by the bugdoc there).

I retain the problem from "Minimal presentation to reproduce", that the 50-50 transparency gradient is different under slideshow mode.
Comment 15 Thorsten Behrens (CIB) 2012-04-16 06:56:05 UTC
Fixed in master. In fact, slideshow is right, edit view was wrong here.
Comment 16 Not Assigned 2012-04-16 07:02:05 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=983c27402e151126c5bef6623eeb07f333456243

Fix fdo#33591 - edge-case trans gradients came out empty
Comment 17 Not Assigned 2012-04-17 03:15:58 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=513ae531ccd3080fa1089d2d9d7dc829e96267cf&g=libreoffice-3-5

Fix fdo#33591 - edge-case trans gradients came out empty


It will be available in LibreOffice 3.5.3.
Comment 18 Thorsten Behrens (CIB) 2012-05-11 02:43:32 UTC
*** Bug 39924 has been marked as a duplicate of this bug. ***